Se connecter / S'enregistrer
Votre question

Où configurer internet sous linux

Tags :
  • linux
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
1 Juillet 2005 22:34:30

Kestion à la con :
Où est-ce que je configure ma conexion internet sous Ubuntu ? Normalement j'ai un CD avec Wanadoo mais il est pas compatible ... donc je sais pas si il va reconnaitre mon Modem .....

Autres pages sur : configurer internet linux

1 Juillet 2005 22:48:19

Ya personne qui veut aider un pauvre petit débutant en linux ?

1 Juillet 2005 22:53:35

Alors le truc c'est qu'il faut que tu nous donne le model du modem. Les manipulations diffère en fonction du modem.

@+

EDIT : essait

Contenus similaires
1 Juillet 2005 23:40:33

C'est un Thomson ST 330 USB
Externe pour ADSL 512 ko
2 Juillet 2005 10:44:14

Euh je comprends un peu rien voir pas du tout ....
2 Juillet 2005 10:48:05

Qu'est-ce que j'en fais de ce script ???? :o hlala:
J'ai jamais utilisé un truc comme ça....
2 Juillet 2005 12:15:46

Alors c'est un peu long.

Tu télécharge ça : speedtouch
Et ces deux là aussi : atm-dev et atm-tool
Tu récupère ces fichiers téléchargés et tu les met dans : /home/<le nom de ton user>

Tu lance une console ( là ou tu peux mettre les lignes de commandes ) et tu tape :
$ sudo dpkg -i atm-tools_2.4.1-17_i386.deb
il te demande ton mot de passe ( utilisateur )
$ sudo dpkg -i atm-dev_2.4.1-17_all.deb

Ensuite tu installe le driver speedtouch :
$ sudo dpkg -i speedtouch_1.3.1-2_i386.deb
Normalement il est installé.

Ensuite tu modifies les fichiers de configurations :
- /etc/modules.conf
- /etc/ppp/chap-secrets
- /etc/ppp/peers/adsl
et tu crées un fichier qui s'appel network ( ou comme tu veux )
en faisant :
$ touch network

Tu te base sur ce site pour changer les fichiers de configurations. ( sachant que tu peux modifier un fichier avec nano -w <nom du fichier> en ligne de commande ou avec gedit en allant chercher le fichier dans l'arborescence )

network est le fichier qui s'appel script de connexion sur le site.

Ensuite quand c'est fait tu fait :
$ sudo chmod 755 network
et quand tu veux lancer le net tu fait :
$ sudo ./network

Et normalement c'est bon. @+

Et dis nous si tu as un problème.
2 Juillet 2005 12:45:02

Quelques soient les emplacement de :
$path/modules.conf
$path/ppp/options
$path/ppp/chap-secrets
$path/ppp/peers/adsl

ces fichiers restent identique...
La chose importante qui fait que l'ensemble c'est mis à fonctionner c'est l'option -k dans :
modem_run -k -f /usr/local/bin/mgmt.o -m;

Ensuite ce script modem est là pour lancer de façon indifférent le modem USB et le réseau...(ethX...)
De plus j'espère avoir mis suffisamment de commentaires dans "modem" pour qu'il soit compris.... Car moi-même ne suis pas un expert en script... Mais des bouts de l'un, des bouts des autres et hop ce script était né ;-)
C'est aussi une compilation exhaustive de ce que j'ai pu lire sur le net :
lea-linux, le site de benoit papillault....etc

A+
2 Juillet 2005 13:24:50

Je comprends pas la notion de "mofifier les fichiers de configurations". Qu'est-ce que je leur fais réellement ?

Et question à la con : je la trouve où la console ?
2 Juillet 2005 15:23:54

***@ubuntu:~$ sudo dpkg -i atm-tools_2.4.1-17_i386.deb
Password:
Sélection du paquet atm-tools précédemment désélectionné.
(Lecture de la base de données... 58640 fichiers et répertoires déjà installés.)Dépaquetage de atm-tools (à partir de atm-tools_2.4.1-17_i386.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de atm-tools :
atm-tools dépend de libatm1 ; cependant :
Paquet libatm1 n'est pas installé.
atm-tools dépend de libc6 (>= 2.3.4-1) ; cependant :
La version de libc6 sur le système est 2.3.2.ds1-20ubuntu13.
dpkg : erreur de traitement de atm-tools (--install) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
atm-tools


Voilà où j'en suis et donc à mon avis il y a déja un blème ...
2 Juillet 2005 15:47:49

Mais de quel problème s'agit t'il ?
2 Juillet 2005 16:30:33

Il te le dit clairement :
Paquet libatm1 n'est pas installé.

donc tu fais
sudo dpkg -i libatm
2 Juillet 2005 17:19:55

oui mais je ne l'ai pas ce paket, où est-ce que je peux le trouver ?
3 Juillet 2005 00:48:30

Personne ne sait où je peux trouver ce paquet ?????
3 Juillet 2005 16:41:19

Donc il faut que j'installe libatm1 et libc6 , mais sur ton site je ne sais pas quelle architecture il faut que je prenne pour mon ubuntu
sachant que mon proc est un AMD Sempron 2600+
3 Juillet 2005 17:25:25

désolé pas le bon post !
3 Juillet 2005 22:28:25

La version de libc6 que propose ton site n'est pas la bonne, tu ne sais pas où je pourrais trouver la 2.3.4-1 ??? =)
3 Juillet 2005 23:14:42

pouarrffff j'arrive pas à la trouver sur internet
4 Juillet 2005 01:10:30

Quel message t'indique qu'il te faut la 2.3.4
4 Juillet 2005 14:18:32

atm-tools dépend de libc6 (>= 2.3.4-1) ; cependant :
La version de libc6 sur le système est 2.3.2.ds1-20ubuntu13.
dpkg : erreur de traitement de atm-tools (--install) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
atm-tools

c'est celui la
4 Juillet 2005 16:50:15

WOOOoooOOOOW
Ayé j'ai installé le driver du modem !!!!
En faite on m'avait donné de mauvaises version de paquet.
Bon passons à l'étape suivante, j'ai pas trop bien compri ton histoire de modifier des fichiers de config avec l'option k .... si tu pouvait me donner plus de précisions... merci !!!
4 Juillet 2005 17:14:09

Tu dois mofifier les fichiers de configuration c'est comme si tu t'étais trompé dans l'écriture d'un fichier texte: tu l'ouvre et tu le modifie.

Ben tu l'ouvre avec des logiciels:
- gedit ( c'est son nom )
Tu ouvre une console et tu fais :
$ sudo gedit
passwd: <la tu tape ton mot de passe>
et ensuite tu fait ouvrir et tu va ouvrir les fichiers de configuration que je t'ai mentionné pour mettre le texte qui lui convient ( écrit à coté du nom du fichier )

Et après tu sauvegarde.

C'est tout bete. @+
4 Juillet 2005 17:26:29

elimine la ligne usepeerdns de /etc/ppp/options
lance cette commande
Citation :
echo "nameserver 80.10.246.1">>/etc/resolv.conf

tu met dans /etc/ppp/pap-secrets:
identifiant (tab)*(tab) pass

pour lancer ta connection internet :
Citation :

/etc/rc.d/ppp start

pour stopper
Citation :
/etc/rc.d/ppp stop
4 Juillet 2005 17:41:59

je dois placer "network" dans home/myname ???
4 Juillet 2005 18:22:04

Oui pour pourvoir le lancer pour que tu ais le net.

Tu feras :
$ ./network

@+
4 Juillet 2005 18:44:25

j'ai quelque problèmes avec les fichiers de config:

-Dans ppp/chap-secrets, faut -il remplacer :# client server secret IP addresses
"your_login_here" "*" "your_password_here" "*"
, par mon login et mon code, ou faut-il le laisser tel quel ?

-Ensuite, je ne trouve pas "/ppp/pers/adsl", ai-je oublié d'installer quelque chose ?
4 Juillet 2005 19:15:59

AU SECOUR vince1407 ou Lolotux !!!!!!
4 Juillet 2005 19:39:44

ou quelqu'un d'autre ....
4 Juillet 2005 19:44:03

Citation :
Dans ppp/chap-secrets, faut -il remplacer :# client server secret IP addresses
"your_login_here" "*" "your_password_here" "*"
, par mon login et mon code, ou faut-il le laisser tel quel ?


Ben tu modifie le fichier pour mettre ton identifiant internet là où il y a marqué "your_login_here" et ton mot de passe dans l'autre ( tu laisse la ligne avec un dièse ) :

Ce qui doit donner:
"identifiant" * "mot de passe" *

Citation :
Ensuite, je ne trouve pas "/ppp/pers/adsl", ai-je oublié d'installer quelque chose ?


Si il n'existe pas tu peux le créer et ensuite le modifier pour que son contenu soit le bon.

@+
4 Juillet 2005 21:42:39

Autre problème :

myname@ubuntu:~$ sudo ./network
Password:
./network: line 18: /etc/rc.d/init.d/functions: Aucun fichier ou répertoire de ce type

Ja fais quoi ? On ne m'avais dit nul part de toucher à ce fichier ....
4 Juillet 2005 23:01:29

Muarrrrrrf AU SECOUR !!!!!
4 Juillet 2005 23:21:40

Fais pèter :
  1. # Source function library.
  2. . /etc/rc.d/init.d/functions
  3.  
  4. # Source networking configuration.
  5. . /etc/sysconfig/network


Ce sont des "include" mandrake qui contiennent des fonctions...
Dont on ne se sert pas dans le script modem
4 Juillet 2005 23:24:29

j'en fait quoi de ça ?????
4 Juillet 2005 23:28:53

tu effaces ces 4 lignes !
:-)
4 Juillet 2005 23:34:20

et après je fait quoi pour me connecter ?
4 Juillet 2005 23:34:47

usage: modem_run [OPTION]... -f firmware
modem_run version 1.3
.......
-k : using the kernel mode driver
......
--help : this message

Bref -k utilise le driver noyaux
4 Juillet 2005 23:41:23

Escuse moi mais tu me parle en marsiens :-o
4 Juillet 2005 23:49:04

tu peux développer un peu STP ?
5 Juillet 2005 00:33:20

Pour me connecter il me demande le password root, mais je ne sais pas de quel mot de passe il s'agit, j'ai essayer mon passW delogin et celui de mon fournisseur d'accès, et ça marche po Snifff
(Bon aller !!! motivé on va y arriver !!!!! enfin j'espère ...)
5 Juillet 2005 01:51:42

Le mot de passe qu'il te demande est le mot de passe root !
Tu dois l'avoir défini à l'install sinon cela veut dire qu'il est null (vide : trés dangereux)

Le script "network" doit être enregistré dans /etc/init.d, il doit l'être en root car pppd doit être lancé par root...
Ce répertoire /etc/init.d/ est le répertoire contenant les scripts suceptibles de se lancer au démarrage... Or dans celui-çi il existe déjà un script network !
Tu devrais donc le nommer différemment comme "modem" !
Ce script doit être éxécutable : en root
chmod +x /etc/init.d/modem

Pour que ce script soit éxecuté au démarrage il faut comprendre que le(s) démarrage(s) ont des niveaux d'éxécution de 0 à 6
0 : l'arret
1: mono utilisateur = root
2-3-4 : chez moi, multi-utilisateur + reseau + sans interface graphique
5 : multi+reseau+interface graphique
6 : redémarrage

Ces niveau contiennent donc une partie des scripts de /etc/init.d, or les niveaux sont représentés par :
/etc/rc0.d
/etc/rc1.d
....
/etc/rc5.d
/etc/rc6.d
Mais dans ces répertoires, les scripts ne doivent pas être lancés au hasard ! Donc il sont appelés S01... S02... etc
Ainsi S01 est lancé avant S02 avant S03.... S99
Donc pour que ton script /etc/init.d/modem soit lancé au démarrage, il faut qu'il soit aussi dans /etc/rc5.d et à la bonne place soit apres le script "iptables"
Si c'est /etc/rc5.d/S15iptables alors il faut que se soit /etc/rc5.d/S16modem.
Pour le faire nous créons un liens symbolique entre /etc/init.d/modem et /etc/rc5.d/S16modem en tapant en root :
ln -s /etc/init.d/modem /etc/rc5.d/S16modem

Citation :
Je te conseillerais tout de même de lire :
http://casteyde.christian.free.fr/online/install_linux/book1.html
Pour ce qui est de l'install et utilisation de GNU/Linux !


Je sais que cela peut paraitre long, mais sans une petite connaissance de base, la config d'une connexion avec les modems sont un peu folkloriques... C'est souvent dû aux fabriquants qui ne fournissent pas les spécifications de leurs modems aux développeurs Linux, parce qu'il ne payent pas comme M$ ??? (do not troll !)

Mais quoi qu'il en soit tu verra, que ce qu'on perdre en ergonomie d'utilisation (ce qui est faux) on gagne tellement plus en liberté de mouvement, de choix....
J'ai des prog Suse, Debian, Red Hat, Fedora et bien évidemment Mandrake qui tournent... J'ai investit 8€ environs dans trois CD Mandrake 9.1 que j'ai fait évoluer vers un melange 9.1 9.2 10.1...
Par téléchargements gratuits et libres... et cela tu le calculs sur 3 ans !
C'est imbattable et quoi qu'on pensent mon micro tourne tout le temps et ne plante jamais !
5 Juillet 2005 11:57:10

Citation :
quelqu'un demandait le mot de passe root sous Ubuntu ; il n'y a pas de root par défaut.Tu utilises la commande sudo devant la commande et c'est ton mot de passe utilisateur
Si tu veux utiliser plusieurs commandes avec sudo, tu peux faire sudo -s et tu te retrouves sous root.

Si tu veux un vrai compte root, tu commences par faire sudo passwd motdepasse


C'était tou simplement pour ça que je ne trouvais pas ...

5 Juillet 2005 13:44:03

J'ai 2 nouveaux problèmes :

-Quand je tente de me connecter sans avoir configurer la connection au démarrage il me dit :
./network : line 72 : gprintf : command not found

-Ensuite quand je veux mettre le script "modem" dans etc/rc5.d, tu me dis de le mettre après "iptables", mais il n'existe pas ...
5 Juillet 2005 15:07:55

Alors qu'est'ce qui cloche ?
5 Juillet 2005 18:19:50

Muarrrrrf Snif ya personne qui veut m'aider ???
5 Juillet 2005 18:32:18

(moi j'admire ce que tout ces jolie post, le devoument que les autre montre pour toi, alors s'il te plait, attend, soit patient, et ne dit plus "personne veut m'aider", merci ;-) )
5 Juillet 2005 18:37:05

oui je sais, je leur suis extrêmement reconnaissant déjà !!! Il m'ont déjà super avancé et il ne doit rester que des petits éléments à revoir.
      • 1 / 2
      • 2
      • Dernier
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS