Se connecter / S'enregistrer
Votre question

Kubuntu : probleme avec disque dur externe NTFS

Tags :
  • Disque dur externe
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
20 Avril 2006 18:31:22

Ayant décidé de passer sous Kubuntu, j'ai fait un back up de mes données sur un disque dur portable (en NTFS j'avais pas vu :( ) usb. Malheureusement, je ne peux y accèder qu'en root, hors je désirerais copier son contenu dans mon /home. Il est monté dans media/sda1. Voici mon fstab :
Citation :
proc /proc proc defaults 0 0
/dev/sda2 / ext3 defaults,errors=remount-ro 0 1
/dev/sda6 /home ext3 defaults 0 2
/dev/sda1 /media/sda1 ntfs defaults 0 0
/dev/sda5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0


merci d'avance pour votre aide :D 

Autres pages sur : kubuntu probleme disque dur externe ntfs

20 Avril 2006 18:56:05

Essayes comme ceci:

/dev/sda1 /media/sda1 ntfs rw,user,auto,utf8,umask=002,gid=1000,uid=1000 0 0
20 Avril 2006 18:59:12

Mais je crois que le NTFS n'est pas compatible Linux...désolé !

Passe en FAT32 et ca marche nickel (expérience vécue) :-)
Contenus similaires
20 Avril 2006 19:02:28

Le NTFS fonctionne sous linux, enfin surtout en lecture. L'ecriture est assez instable, mais bon tu peu quand meme voir ce qu'il y a dessus.
20 Avril 2006 19:10:07

NTFS est parfaitement compatible avec linux du moins en lecture. Pour ce qui est de l'écriture c'est un autre problème et je ne préfère pas entrer dans les détails.

Ainsi pour réaliser ce que tu as à faire 2 solutions s'offrent à toi.

- faire comme te l'a indiqué lanfeust18
- faire ta copie en root et changer les permissions propriétaires avec la commande "chown" (fais un man dessus)

--
Voili voilou
Bye & @+
20 Avril 2006 19:14:44

Ca a marché mais j'ai fait une petite erreur. sda1 est en réalité ma partition windows :D  mais au moins jpeux accèder dessus lol

Le problème a l'air un peu plus compliqué : lorsque je raccorde mon disque au port usb, il me dit la chose suivante :
Citation :
Un problème s'est produit lors du chargement de media:/sdc1 :
Le fichier ou le dossier media:/sdc1 n'existe pas.


Idem lorsque je branche ma cle usb :
Citation :
Un problème s'est produit lors du chargement de media:/sdd1 :
Le fichier ou le dossier media:/sdd1 n'existe pas.


Je viens d'installer linux, je suis un peu paumé la, que dois-je faire ?
20 Avril 2006 19:19:13

Oki, donc rajoute la ligne suivant dans ton fstab:

/dev/sdc1 /mnt/sdc1 ntfs rw,user,auto,utf8,umask=002,gid=1000,uid=1000 0 0

Puis:
sudo mkdir /mnt/sdc1

Ensuite tu dois pouvoir y acceder avec konqueror dans /mnt/sdc1
20 Avril 2006 19:20:09

oop
20 Avril 2006 19:20:17

sauf votre respect, ce n'est pas plutot media/sdc1 au lieu de mnt/sdc1 ?
20 Avril 2006 19:22:43

Tu as essayer ce que je t'ai dit??
Sinon autre chose l'option umask=002 définie tes droits, dans ce cas les droits sont assez larges si tu veu les restreindre met ceci:
umask=027
20 Avril 2006 19:25:05

Pour ta clé usb
/dev/sdd1 /mnt/cle vfat rw,user,auto 0 0

en console:
sudo mkdir /mnt/cle

Et losque que tu créer des points de montage tu peu les mettre dans /mnt, c'est fait pour....
20 Avril 2006 19:27:13

j'ai fait ce que tu m'a dit, et je suis allé voir avec konqueror, et il n'y avait rien dans mon disque. j'ai debranché et rebranché la prise usb, et j'obtient cela :
Citation :
Un problème s'est produit lors du chargement de media:/sde1 :
Le fichier ou le dossier media:/sde1 n'existe pas.


c'est quoi le soucis ?
20 Avril 2006 19:29:27

Pour la cle usb ca marche :) 
20 Avril 2006 19:42:17

Que puis-je faire avec mon disque portable ? :s j'ai toutes mes données dessus :-( Je suis ignorant aidez moi s'il vous plait ! :-)

Il se dit etre maintenant sde1, pourquoi ?
20 Avril 2006 19:47:17

Probablement parce que tu as changer de port usb
Remet le sur le port de tout à l'heure et
Fait en console:
sudo mount /dev/sdc1
20 Avril 2006 19:50:57

problème reglé je ne sais pas pourquoi :D  merci pour tout !
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS