Votre question

Probleme installation drivers sous linux mandriva 2007

Tags :
  • Nvidia
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
13 Février 2007 00:44:03

Bonsoir, je vien vous voir car ca fait deja longtemp que j'éssai d'installer mon drivers de carte graphique : Nvidia Geforce 7300 LE ( sous linux) mias je n'y arrive pas! j'ai pourtant essayer avec tt les méthode annoncer sur divers forum, mais rien n'y fait...
En fait je voulais installer les drivers de ma carte sous linux: NVIDIA-Linux-x86x1.0-7184-okg1.run ( que j'ai trouvé dailleur sur nvidia.fr) pour profiter de l'accélértion 3d pour avoir par la suite le bureau 3D.

Si qq'1 pouvait me proposer une méthode et la démarhce a suivre se serait super sympa! je compte sur votre aide ...

Cordialement, Scara 74 ! :hello:  :hello: 

Autres pages sur : probleme installation drivers linux mandriva 2007

13 Février 2007 01:14:10

SVP aidé moi :( :(  merci
13 Février 2007 01:46:29

HELLLLLLPPPPP svpppp !:( :( :( :(  :'( 
merci a vous , assurer donner moi une soluce !:( 
Contenus similaires
13 Février 2007 11:17:41

Tu sais la nuit y a personne ! :) 

Que n'arrives tu pas à faire ?
13 Février 2007 12:49:47

bonjour :)  ! bah ne faite comme je l'est dis plus haiut je n'arrive pas a installer mon driver de carte graphique( nvidia geforce 7300 LE) sous linux . j'espere que tu pourra m'aider et me donner la démarche a suivre car je débute dans linux
merci !:) ;)
13 Février 2007 12:59:59

Personne pourrait m'aidé svp ?
13 Février 2007 13:30:14

ce qu'il a voulu te demander (je pense) c'est qu'est ce que t'as commencé à faire, ou t'en est arrivé, c'est quoi le message d'erreur?
si tu sais pas comment commencer, c'est en root:
  1. # sh NVIDIA-Linux-x86x1.0-7184-okg1.run
13 Février 2007 13:36:23

bah en faite le probleme c'est que quand je tape ce que tu ma indiqué , ca ne marche pas . le drivers que j'ai téléchargé je l'est mis sur le bureau, faut ilo le mettre dans une dossier spécial , si oui leqeul ? meci bcp ( je suis débutant je ne mis connai pas tres bien )
13 Février 2007 13:39:32

meme si je suis pas ce qu'on peut appeler debutant, je peux pas deviner ce que tu as comme erreur, alors sois un peu plus precis.
ce que je t'ai donné est à taper dans un terminal depuis le dossier ou tu as le fichier
si ca te retourne une erreur, au lieu de dire "ca ne marche pas" ca serait mieux de donner l'erreur
13 Février 2007 13:42:47

je n'arrive a me mettre en root depuis le terminal que j'ai ouvert depuis le dossier.merci de ton aide
13 Février 2007 13:50:48

pour se mettre en root:
  1. $ su

13 Février 2007 13:52:15

ah merci coca25
13 Février 2007 13:55:40

quand je tape " sh NVIDIA..... .run " j'ai une message d'erreur :
ERROR: this.run file is intended for the Linux-x86 platform, but your appear to be runing on linux-x86_x64. Aborting installation
13 Février 2007 14:02:27

Citation :
HELP !! Aidéé moi :'( :'(  c'est urgent c 'est pour mon frere qui doit partir se soir au état unis :(  merci...


s'il n'a pas le driver nvidia, il ne le laissent pas passer la douane???

scara74 a dit :
quand je tape " sh NVIDIA..... .run " j'ai une message d'erreur :
ERROR: this.run file is intended for the Linux-x86 platform, but your appear to be runing on linux-x86_x64. Aborting installation


ca ne peut etre plus clair, tu as telecharge le mauvais, il faut telecharger celui pour architecture x64
13 Février 2007 14:05:34

lol nn mais c'est que la bas il a besoin de l'accléarteur 3D , et il n'uraus pas internet , bref ce n'est ps le le probleme .... :)  je vais essayer de chercher ce drivers et je te tien au courant. merci bcp deja^pour ton ide ;)  je cherche...:) 
13 Février 2007 14:12:01

je ne trouve pas le drivers sur nvidia.fr , comment faire ? merci
13 Février 2007 14:28:51

tu n'exageres pas un peu?
nvidia.fr -> telechargement pilote -> Linux | FreeBSD | Solaris -> amd 64/em64t
13 Février 2007 14:29:41

voila j'ai trouvé le drivers je le test et je te tien au courant
merci!!
13 Février 2007 14:30:44

amd 64
13 Février 2007 14:32:41

coca25 a dit :
tu n'exageres pas un peu?
nvidia.fr -> telechargement pilote -> Linux | FreeBSD | Solaris -> amd 64/em64t

Euh... bon t'es chier toi ! :) 
Mais c'est vrai que ce matin ils avaient des problèmes de script !

J'espère qu'il n'a pas pris encore le mauvais ! ;) 
13 Février 2007 14:36:27

je sens que ca va durer, pour peu qu'il n'ait pas le module pour le bon noyau ou que les packages pour compiler ne soient pas installés etc... :) 
mais bon c'est comme ca qu'on apprend
13 Février 2007 14:47:46

voila j'ai rentré " sh NVIDIA-Linux-x86_64.....;run" et j'ai une message d'érreur:
ERROR : You appear to be running an X server; please exit X before installing.
ERROR: Installation has failed. please see the file : '/var/log/nvidia-installer.log' for details

Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 1.0-7184....

Que dois je faire ? merci bcp de votre aide!! :) 
13 Février 2007 15:50:42

il faut le faire depuis une console texte en ayant quitter X (mode graphique)
sous mandriva je sais plus comment on arrete le serveur X.
tu peux quitter ta session, taper Ctrl+Alt+F1 puis se logguer en root:
  1. # /sbin/init 3
  2. # cd le repertoire ou se trouve le NV...
  3. # sh NV...

13 Février 2007 15:50:58

Tue ton interface X
/etc/init.d/dm stop
coca25 a dit :

  1. # /sbin/init 3
  2. # cd le repertoire ou se trouve le NV...
  3. # sh NV...


D'ailleur si init 3 ne tue pas X, alors ce n'est pas un init 3 !
Ou tu ne l'as pas fait ! :) 
13 Février 2007 17:06:31

mon NV... est sur le bureau , dans la konsole doit je taper : cd /home/julien/desktop ?? merci de votre réponse
13 Février 2007 17:19:45

Oui !
Et vérifie qu'il soit executable !
Pour être sur :
cd /home/julien/desktop
chmod +x NV.....
sh NV......

NB : Il faut que ai installé, les sources de ton noyaux, gcc, make
Parce que le pilote NVIDIA, en réalité va le fabriqué en fonction de ta machine !

13 Février 2007 17:38:18

c'est bon j'ai réussi !! mnt faut il le configurer car je n'arrive tjrs pas a avoir l'accélération 3D. merci
13 Février 2007 17:42:43

Vérifie que ton fichier /etc/X11/xorg.conf contienne le nom du pilote nvidia plutôt que nv !

cat /etc/X11/xorg.conf | grep nv
13 Février 2007 17:44:42

Sinon je crois qu'on peut configurer sa 3D dans "drakconf".
13 Février 2007 17:49:26

le probleme c'estq que je ne peux pas écrire dans le fichier xorg.conf , pour remplacer "nv " par "nvidia". j'ai une erreur : accès refusé , impossible décrire dans /etc/X11/xorg.conf.part

Merci de ta réponse! ;) :) :) 
13 Février 2007 17:55:13

Évidemment tu n'es pas en root ! :) 
Seul l'admin à le droit de tout foutre en l'air !
13 Février 2007 17:55:23

ou trouver le logiciel drakconf pour configure ma 3D ? merci bcp
13 Février 2007 17:56:19

Donc en console tu tapes :
su [entré]
mot de passe root
Et là seulement vi /etc.....
13 Février 2007 18:00:22

tu va croire que je ne suis pas doué, tu a de bonne raison :)  lol mais je n'arrive pas. pour me mettre en root je quitte ma session et je met comme login :root ? sauf qu'après je n'est pas de périphérique pour aller explorer le disk et trouver "xorg.conf". merci bcp de ton aide!
13 Février 2007 18:05:19

dsl mais peut tu me récapituler la démarche a suivre pour configurer ma 3D. merci bcp !!!!! :$
13 Février 2007 18:09:01

pourrais tu m'envoyer ton msn en privé stp ? se serait bcp plus simple . merci bcp bcp
13 Février 2007 18:14:45

ok merci; mais que doivent faire une fois dans le drak conf ? dsl je debute sous linux je ne m'y connait . merci bcpp
13 Février 2007 18:22:18

Dans un des onglets il devrait y avoir 3D (enfin j'en suis pas certain, etant sous la 2006.0)
13 Février 2007 18:31:46

en faite je pense qu'il faudrait juste selectionner le nouveau drivers installer. mais comment faire ? merci de vos réponse :) 
13 Février 2007 18:37:52

tu es sous kde?
  1. su -c 'kedit /etc/X11/xorg.conf'

change nv par nvidia puis redemarre le X
13 Février 2007 19:07:46

oui je suis sous kde
13 Février 2007 19:12:40

quand je rentre -c 'kedit /etc/X11/. xorg.conf' sa me met : > .que dois je faire ?:( 
13 Février 2007 19:18:10

Tu as oublié su !
su -c commande : lance la commande en root
Donc : su -c kwrite /etc/X11/xorg.conf
Lance kwrite en root, qui lui ouvre le fichier /etc/X11/xorg.conf
13 Février 2007 19:23:00

s'a me dis que la commande n'existe pas . j'ai fais : ouert une console, taper su encuite le mot de passe après jai taper : su -c kwrite /etc/X11/xorg.conf. Et j'ai un message d'erreur : commande not found :( 
13 Février 2007 19:32:09

sois un peu imaginatif, t'as quoi comme editeur?

le but c'est d'ouvrir un fichier texte en l'occurence : /etc/X11/xorg.conf
aller à la ligne ou tu trouve "nv"
et la remplacer par "nvidia"
puis sauvegarder et redemarrer

alors comme on ne connait pas ton systeme ni ce que tu as installe dedans, on peut pas deviner
au pire rentres en root dans le mode graphique, ouvre un editeur n'importe et fais le changements
...............
ok je m'en vais
13 Février 2007 19:34:58

"au pire rentres en root dans le mode graphique, ouvre un editeur n'importe et fais le changements
" comment faire ? merci bcp
13 Février 2007 19:38:27

c'est bon j'ai trouvé, j'ai modifé le fichier : je redémare et je vous dis;) mercii :) 
      • 1 / 2
      • 2
      • Dernier
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS