Se connecter / S'enregistrer
Votre question

Probleme driver nvidia

Tags :
  • Nvidia
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
5 Avril 2007 14:20:38

Salut,

Ma config : AMD Athlon X2 64 3800+ / Geforce Nvidia 7600GT / 1Go de ram

J'ai installé la mandriva 2007 free. J'ai téléchargé les .ISO (4CDs) et je les ai gravés.
L'installation se passe sans aucun problème.
Arrive le moment d'installer le driver gaphique et là message d'erreur. J'ai installé kernel-source, gcc.

Dans ma console je fais :

Su
Init 3
sh /home/..../...../drivernvidia.run (il se lance)
J'accepte le contrat
Il Build avec kernel et message d'erreur : Unable to build
et j'en ai un autre apres qui me dit que les versions de gcc et kernel sont pas aux memes niveaux (un truc dans le genre)
et Intall Failed.

Donc j'ai deux questions : Quel driver Nvidia dois-je télécharger vu ma config et Comment installer ce driver ?

Merci pour votre aide

Autres pages sur : probleme driver nvidia

5 Avril 2007 14:45:34

voici l'erreur avec le driver NVIDIA-Linux-x86_64-1.0-9755-pkg2.run :

ERROR: Unable to load the kernel module 'nvidia.ko'. This happens most
frequently when this kernel module was built against the wrong or
improperly configured kernel sources, with a version of gcc that differs
from the one used to build the target kernel, or if a driver such as
rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
obtaining ownership of the NVIDIA graphics device(s).

ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
5 Avril 2007 16:14:10

salut,
tapes
  1. uname -r
pour connaitre la version du noyau et installer les bonnes sources de noyau
quant au gcc, je pense que le noyau est compilé avec la version 3.4, vérifies que c'est pas seulement la 4 qui est installé
Contenus similaires
5 Avril 2007 16:22:19

ok merci j'essaierai se soir et je te tiendrai au courant (je ne suis pas chez moi mais au boulot lol sous Windaube)
5 Avril 2007 16:32:36

voici la version du kernel 2.6.17-5mdv ! et comme j'ai installer les packages pour le gcc je pense que c'est la version 4, comment faire pour connaitre la version du gcc ?
5 Avril 2007 16:42:26

paeovran a dit :
(je ne suis pas chez moi mais au boulot lol sous Windaube)

;)  question de point de vue

pour gcc:
  1. gcc --version


ou alors avec le gestionnaire de paquet
vérifie si tu as installé les bonnes sources de noyau
5 Avril 2007 16:45:12

la commande fonctionne pas :( 
5 Avril 2007 16:59:52

tu es sur que tu as installé gcc?
5 Avril 2007 17:03:21

ma version est la 4, ce qui veut dire ?
5 Avril 2007 17:03:58

pourquoi ces erreurs a la noix ?
5 Avril 2007 18:07:43

je te l'ai expliqué plus haut:
nvidia doit compiler son module avec les sources du noyau que tu utilises et avec la version du compilateur utilisé pour compiler le noyau
5 Avril 2007 18:13:37

Donc si je comprend bien, je dois installer la version 3.4 du gcc. Mais je la trouve ou ? et je dois desinstallé la version 4. C'est sa ?
5 Avril 2007 18:18:12

par contre sur un autre forum qui est presence pc, on me dit qu'il faut mettre a jour mon gcc avec
  1. urpmi update gcc

Bizarre lol
5 Avril 2007 18:36:10

tu n'as pas répondu à la premiere question, le gcc était le 2eme choix.
as tu vérifié que tu as bien installé les sources correspondant au noyau sur lequel tu as booté?
5 Avril 2007 18:50:40

oui j'ai bien installé les sources correspondants au noyau sur lequel je boot
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS