Votre question

dual boot XP/VISTA

Tags :
  • Dual
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
28 Mai 2007 18:28:08

Bonjour,

Voilà mon blème, j'ai installé en dual boot XP d'abord, puis Vista depuis leur CD d'install (tous les deux depuis CD bootable) mais je m'aperçois que Vista a inversé les lettres de mes disques, je m'explique

quand je boot sur XP , tout est normal, j'ai
- Disque C: la partition ou est vraiment installé XP
- Disque D: la partition ou est vraiment installé Vista

mais quand je boot sur Vista c'est inversé, j'ai
- Disque C: vu par Vista comme D:
- Disque D: vu par Vista comme C:

Bizarre, non ? :whistle:  Vista ne gère pas le multiboot correctement ??

C'est génant dans la mesure ou je souhaite me servir de certains programmes mis sur le véritable C: sans avoir à les installer deux fois pour Vista. (et surtout éviter les embrouilles de lettres C: / D: quand j'installe des programmes, c'est une vraie con**rie Mr Microsoft )

Ce que je souhaite donc c'est de conserver sous Vista l'ordre des lettres de mes disques.

J'ai essayer de changer les lettres avec le gestionnaire de disques... ça ne marche pas, Vista refuse de le faire.
j'ai aussi vu qu'un petit log (VistaBootPro) permet de choisir l'ordre de boot et changer les lettres mais ça ne marche pas pour les lettres, au démarrage il m'a mis NTLDR manquante, le coup classique, si j'édite le boot.ini et que je le remet comme avant ça démarre bien sur XP ou Vista au choix, mais j'ai à nouveau les lettres inversées... si quelqu'un a été confronté a ce truc qui agace et a une solution, je suis preneur.

Merci à tous d'avance et bonne soirée. :hello: 

Autres pages sur : dual boot vista

28 Mai 2007 18:41:49

c'est totalement normal ton truc ! vista, xp, 98...... tous utilise le C: comme disque par défaut alors ne t'inkette pas c'est normal.

Sur XP, est installé sur ta partition D: et quand tu es sur Vista, Xp est installé sur la partion D: Donc pour Vista le C: d'xp c'est le D et pour Xp le C: de vista c'est le D:..... Je sais c'est un peu tordu mon histoire mé en gros windows ne peut pas booter sur une partition D donc il attribu le C: par defaut. :pt1cable: 
28 Mai 2007 19:55:01

Salut,
Comment tu as résolu le problème du NTLDR manquant?
Contenus similaires
28 Mai 2007 20:28:02

et bien la je sais pas trop.....essai de faire F10 au démarrage de windows et de taper: fixboot C:
et puis redemarre de pc.....


j'espere que ca résoudra le probleme
28 Mai 2007 20:34:49

Il se peut qu'il ait déjà utilisé fixboot pour résoudre le problème du NTLDR manquant, c'est pour ça que j'avais posé la question.
29 Mai 2007 10:56:11

Merci totointeractive pour ta réponse, les lettres inversées c'est normal alors. Dommage j'aurais bien voulu avoir le même ordre sur les deux systèmes.

Pour cracker, j'ai bien tenté le "fixboot" mais ça n'a pas marché j'ai été obliger d'effacer Vista et de bidouiller le fichier boot.ini d'XP pour remettre seule la partition C: en boot par défaut, boot.ini on peut l'éditer a partir d'un CD Linux Live. (y'a peut être plus simple comme méthode) Ensuite j'ai copier NTLDR et NTDETECT.COM depuis le CD d'install d'XP en ligne de commande, tous les deux se trouvent dans le répertoire i386, voici la manip
si ça peut te servir :

Démarre sur le cd XP et ensuite faites l'option "r". A l'invite de commande faire :
d: (ton lecteur) , enter
cd i386 , enter
copy ntldr c: , enter
copy ntdetect.com c: , enter.

ensuite on peut booter sur XP, par contre pour Vista je me suis tapé une réinstallation, la réparation n'a voulu marché... et j'ai retrouvé mes lettres inversées :lol: 

Encore merci :hello: 


29 Mai 2007 11:15:20

en fouillant sur le net j'ai trouvé peut-être une solution a mon problème,
http://www.clubic.com/forum/dual-boot-lecteur-inverse-d...

D'après ce topic il faudrait lancer l'installation de Vista après l'ouverture d' XP et non depuis le boot de l'ordi , là les lettres des lecteurs seraient conservées.
Je testerai ça à tête reposée

je vous tiens au courant @+ :hello: 
30 Mai 2007 11:38:34

:)  C'est bon, problème résolu

Pour info il faut donc installer Vista depuis le poste de travail d' XP en cliquant sur le DVD, Vista va reprendre la config des lettres assignées par XP aux disques durs y compris les lecteurs de CD et DVD, maintenant j'ai mes lettres de disques à l'identique sur les deux OS, pas d'embrouille.

Bonus : on peut avec VistaBootPro modifier par la suite l'ordre des systèmes d'exploitation mis en multiboot, (sinon c'est Vista qui se lancera en premier) ainsi que le temps d'attente de celui lancé par défaut, j'ai donc mis
- XP par défaut (8 s ça suffit pour choisir)
- Vista en second (manuel)
11 Juin 2007 23:17:08

C'est ce que j'ai fait: installé vista depuis XP.
Tout marche bien, sauf que le mode sans échec de XP lui ne fonctionne pas.
Quand je le sélectionne, l'ordi reboot après quelques secondes pendant le chargement de XP!
Je ne sais pas pourquoi?
XP et vista sont sur deux disques différents.
12 Juin 2007 15:01:51

salut, essaye de passer par la commande "msconfig" d'XP, sur l'onglet Boot.ini, coche /SAFEBOOT et clic sur redémarrer quand il le demande, normalement le mode sans échec devrait se lancer tout seul, sinon je ne vois pas trop...
12 Juin 2007 21:34:25

hypernaute a dit :
salut, essaye de passer par la commande "msconfig" d'XP, sur l'onglet Boot.ini, coche /SAFEBOOT et clic sur redémarrer quand il le demande, normalement le mode sans échec devrait se lancer tout seul, sinon je ne vois pas trop...


Je viens d'essayer, ça ne marche pas mieux, reboot dés le chargement du mode sans echec.
Mais je ne pouvais plus revenir au mode normal.....finalement j'ai du demarrer sur Vista et modifier le boot.ini !!!!

:pfff: 
13 Juin 2007 12:17:46

bizarre ce reboot ! oui en fait c'est vrai pour revenir au mode normal il faut éditer le boot.ini, ça aurait pu se faire en mode sans échec s'il avait voulu se lancer, désolé, j'avais oublié de le préciser...
Pour revenir à ton blème, j'ai trouvé ça sur un autre forum si ça peut t'aider
http://www.clubic.com/forum/lofiversion/index.php/t3908...
13 Juin 2007 20:48:51

He bien ça ne change rien car ça fait simplement ce que vistaboot pro fait.
Donc toujours pas de mode sans echec sous XP.
14 Juin 2007 11:27:51

laisse comme ça jusqu'au jour ou ça plante :D 
perso je ne vois pas d'autre chose.

UP ... a moins que quelqu'un entrevoit l'ombre d'une soluce
21 Février 2009 19:58:01

il faut d'abord installer XP sur D
ensuite installer VISTA sur C
et là , tout est en ordre
Ps: il bootera quand meme sur C

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS