Se connecter / S'enregistrer
Votre question

code blocks

Tags :
  • Ubuntu
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
23 Juin 2007 16:49:05

Bonjour, j'ai téléchargé code::blocks (un fichier .deb) et je n'arrive pas a l'installer

enfaite je connais pas la technique :p 

je suis sous ubuntu

Autres pages sur : code blocks

23 Juin 2007 16:54:16

alors pour installer un logiciel tu fait dans la console

sudo apt-get install code::blocks

ou sinon tu as se site qui et tres bien fait bon je ne retrouve pu la pages mais c'est le site du zero tout est expliquer c'est top ;) 
23 Juin 2007 16:59:37

j'ai télécharger le .deb et puis code::blocks n'est pas dans les packets disponible
Contenus similaires
23 Juin 2007 17:12:13

ha bon ta fait se que je t'ai dit sinon cherche sur google c'est ton ami oublie pas
23 Juin 2007 17:13:36

j'ai cherché sur google..
23 Juin 2007 17:14:42

Salut,

  1. sudo dpkg -i ton_fichier.deb


Je crois que sous Ubuntu, un simple double clique suffit...

Ensuite, si tu as des messages d'erreurs:
  1. sudo apt-get -f install


Et ça devrait rouler.
23 Juin 2007 17:18:32

j'y etait presque
23 Juin 2007 17:20:43

moi123 j'ai trouvé cette tecnic sur google et sa n'a pas marché

je réésais et jten dis plus
23 Juin 2007 17:29:49

sa fais la meme chose, sa dis que sa suprime codeblocks:
  1. sam@SL472:~$ sudo dpkg -i CB_20070622_rev4154_Ubuntu6.10+7.04_wx2.8.4.deb
  2. Sélection du paquet codeblocks précédemment désélectionné.
  3. (Lecture de la base de données... 109826 fichiers et répertoires déjà installés.)
  4. Dépaquetage de codeblocks (à partir de CB_20070622_rev4154_Ubuntu6.10+7.04_wx2.8.4.deb) ...
  5. dpkg : des problèmes de dépendances empêchent la configuration de codeblocks :
  6. codeblocks dépend de libwxbase2.8-0 (>= 2.8.4.0) ; cependant :
  7. Le paquet libwxbase2.8-0 n'est pas installé.
  8. codeblocks dépend de libwxgtk2.8-0 (>= 2.8.4.0) ; cependant :
  9. Le paquet libwxgtk2.8-0 n'est pas installé.
  10. dpkg : erreur de traitement de codeblocks (--install) :
  11. problèmes de dépendances - laissé non configuré
  12. Des erreurs ont été rencontrées pendant l'exécution :
  13. codeblocks
  14. sam@SL472:~$ sudo apt-get -f install
  15. Lecture des listes de paquets... Fait
  16. Construction de l'arbre des dépendances
  17. Lecture de l'information d'état... Fait
  18. Correction des dépendances... Fait
  19. Les paquets suivants seront ENLEVÉS :
  20. codeblocks
  21. 0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
  22. 1 partiellement installés ou enlevés.
  23. Il est nécessaire de prendre 0o dans les archives.
  24. Après dépaquetage, 22,8Mo d'espace disque seront libérés.
  25. Souhaitez-vous continuer [O/n] ? O
  26. (Lecture de la base de données... 110704 fichiers et répertoires déjà installés.)
  27. Suppression de codeblocks ...
  28. sam@SL472:~$
23 Juin 2007 17:34:36

C'est normal, Code::Blocks a besoin de dépendances plus vieilles que celle installées sur ton PC.

Faut chercher, si il n'éxiste pas dans les dépôts, mais n'ayant pas d'Ubuntu sous la main, va falloir attendre coca25, mydoom ou encore suseX. ^^
23 Juin 2007 17:39:58

bizard, merci de ton aide :) 
23 Juin 2007 19:58:36

sam@SL472:~$ sudo dpkg -i CB_20070622_rev4154_Ubuntu6.10+7.04_wx2.8.4.deb
Sélection du paquet codeblocks précédemment désélectionné.
(Lecture de la base de données... 109875 fichiers et répertoires déjà installés.)
Dépaquetage de codeblocks (à partir de CB_20070622_rev4154_Ubuntu6.10+7.04_wx2.8.4.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de codeblocks :
codeblocks dépend de libwxbase2.8-0 (>= 2.8.4.0) ; cependant :
La version de libwxbase2.8-0 sur le système est 2.8.1.1-0ubuntu4.
codeblocks dépend de libwxgtk2.8-0 (>= 2.8.4.0) ; cependant :
La version de libwxgtk2.8-0 sur le système est 2.8.1.1-0ubuntu4.
dpkg : erreur de traitement de codeblocks (--install) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
codeblocks

c kelle version que jdois installer la?
23 Juin 2007 23:16:20

essaye en ajoutant l'option --force-depends à la commande dpkg
24 Juin 2007 04:24:15

J'ai le même probleme. j'ai tenté en forrcant l'installation sans les dependances, code::blocks est installé mais inutilisable. Du coup, un sudo apt-get install -f à été cnecessaire...
Domage, code::blocks est un excelent IDE :( 
10 Juillet 2007 14:45:42

ok je crois que j'ai trouvé :
alors ouvre un terminal
-> sudo gedit /etc/apt/sources.list (sous gnome)
ou kdesu kate /etc/apt/sources.list (sous KDE)
et rajoute la ligne au fichier que tu viens d'ouvrir : deb http://apt.tt-solutions.com/ubuntu/ dapper main remplace dapper par feisty ou edgy suivant le ubuntu que t'as
la y'a deux possibilités soit t'arrive a télécharger la clé soit t'y arrive pas : pour ca tu tape dans la console après avoir enregistré le fichier :
->wget http://www.tt-solutions.com/vz/key.asc | apt-key add -
si tu es comme moi la clé ne se téléchargera pas mais pas de probleme tape
->sudo apt-get update
et enfin sudo apt-get install libwxgtk2.8-0
et sudo apt-get install libwxbase2.8-0
et reinstalle code blocks et voila
10 Juillet 2007 16:46:58

ou plutot:
wget -O - http://www.tt-solutions.com/vz/key.asc | sudo apt-key add -
;) 
10 Juillet 2007 17:59:54

C vrai comme ca en plus la clé est valide et donc il devrait plus y avoir de probleme pour installer codeblocks
11 Juillet 2007 18:03:49

le probleme est resolu sa fais un bout
11 Juillet 2007 18:18:34

ben si tu mettais un [resolu] dans le titre, tout le monde le saura
11 Juillet 2007 21:28:28

lol ouai merci ca aurai eviter que j'ecrive ca pour aider !
5 Mars 2009 14:54:19

esce qu'il serai posible d'avoir la solusion car j'ai beau essayé avec se qui est proposer je n'arrive pas a le faire fonctionner (en plus certaine adresse ne fonctionne plus

merci d'avance mais j'imagine qu'il peu en avoir d'autre comme moi qui aimerai avoir la solusion
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS