Se connecter / S'enregistrer
Votre question

[DEBIAN] Installation des pilotes NVIDIA [RESOLU]

Tags :
  • linux
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
31 Juillet 2007 03:53:56

Bonjour à tous, je suis un noobie de linux, et je veux installer les pilotes graphiques Nvidia, seulement je n'y comprends pas grand chose.

Merci mille fois de m'expliquer un peu... et lententement, je suis un peu lent à la détente ces temps ci ^^

Ps ma config :

7600GT
Carte mere ASUS M2N4SLI
amdx2 3800+
Debian 4.0

Autres pages sur : debian installation pilotes nvidia resolu

31 Juillet 2007 08:16:24

Installe le logiciel module-assistant :
# apt-get install module-assistant (on peut pas faire plus simple)

et ensuite lance le il va te proposer une liste de sources à compiler et tu descend tout en bas, je pense que nvidia est présent. Tu le lance et il fait tout.

@+
Contenus similaires
31 Juillet 2007 17:41:46

Bon je me lance, merci Vince et Lolotux

debian:/home/timmy# sudo apt-get install linux-headers-`uname -r`
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
linux-headers-2.6.18-4-486: Dépend: linux-headers-2.6.18-4 (= 2.6.18.dfsg.1-12 etch2) mais ne sera pas installé
Dépend: linux-kbuild-2.6.18 mais ne sera pas insta llé
Dépend: gcc-4.1 mais ne sera pas installé
wine: Dépend: libwine (= 0.9.25-2.1) mais 0.9.41~winehq0~debian~4.0-1 devra êt re installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
debian:/home/timmy# apt-get install module-assistant
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
wine: Dépend: libwine (= 0.9.25-2.1) mais 0.9.41~winehq0~debian~4.0-1 devra êt re installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
debian:/home/timmy#
debian:/home/timmy# apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
wine
Paquets suggérés :
msttcorefonts
Les paquets suivants seront mis à jour :
wine
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o/10,3Mo dans les archives.
Après dépaquetage, 40,6Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 80200 fichiers et répertoires déjà installés.)
Préparation du remplacement de wine 0.9.25-2.1 (en utilisant .../wine_0.9.41~win ehq0~debian~4.0-1_i386.deb) ...
Dépaquetage de la mise à jour de wine ...
Paramétrage de wine (0.9.41~winehq0~debian~4.0-1) ...

debian:/home/timmy# apt-get install module-assistant
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Paquets suggérés :
build-essential
Les NOUVEAUX paquets suivants seront installés :
module-assistant
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o/74,9ko dans les archives.
Après dépaquetage, 414ko d'espace disque supplémentaires seront utilisés.
Changement de support : veuillez insérer le disque
« Debian GNU/Linux 4.0 r0 _Etch_ - Official Multi-architecture i386/amd64/powerp c/source DVD #1 20070407-12:57 »
dans le lecteur « /cdrom/ » et appuyez sur la touche Entrée

Sélection du paquet module-assistant précédemment désélectionné.
(Lecture de la base de données... 80593 fichiers et répertoires déjà installés.)
Dépaquetage de module-assistant (à partir de .../module-assistant_0.10.8_all.deb ) ...


Je vais sans doute passer pour une cruche, mais ensuite, je dois faire quoi ??
31 Juillet 2007 17:49:05

bon j'ai réussi à avancer
mais voilà le bug :


Échec de l'installation des sources de nvidia-kernel-source. ↑
│ ▮
│ Paquet ignoré. Vous devez peut-être ajouter quelque chose à ▒
│ sources.list, comme les archives « contrib » et « non-free ». ▒
│ ▒
│ Échec de l'installation des sources de ▒
│ nvidia-kernel-legacy-source. ▒
│ 1
31 Juillet 2007 17:53:33

Pourquoi choisir une Debian pour debuter? Tu ferais aussi bien de t'installer une Ubuntu (qui est justement une petite soeur de debian, adaptée aux débutants). Les choses y sont simplifiée, la doc est trés complete, et installer tes drivers t'aurait pris 15 secondes chrono! :/ 
31 Juillet 2007 18:34:27

Merci, je sais bien :) 
Mais je pense qu'en commençant par la difficulté j'apprendrai plus vite.
Et même si je comprends pas ce que je fais (ce qui est normal, je me suis pas encore penché sur les lectures appropriées, mais je vous promet de m'y pencher cet été) je ne trouve pas que c'est excessivement compliqué.

Si j'ai viré XP de mon pc (j'ai même pas voulu de dual boot), c'est pour me plonger à fond dans linux et m'y faire coute que coute.
J'y arriverai ^^

Merci cependant de répondre à ma question :D 
31 Juillet 2007 19:48:01

Tu n'as pas touché au sources.list encore ?

Logiquement ce qu'il faut après c'est un coup de m-a update m-a prepare.

PS: Evites le sudo, penses à su...
31 Juillet 2007 20:08:23

Non je n'y ai pas touché, je suis vraiment comme le bébé pingouin qui sort de l'oeuf...

rien tripatouillé à ce niveau là...
31 Juillet 2007 20:16:48

Edites en rajoutant contrib non-free, ça devra être comme ceci:

Citation :
deb http://ftp.fr.debian.org/debian/ etch main non-free contrib
deb-src http://ftp.fr.debian.org/debian/ etch main non-free contrib

deb http://security.debian.org/ etch/updates main non-free contrib
deb-src http://security.debian.org/ etch/updates main non-free contrib


Ensuite pour reprendre tout à 0:

apt-get install nvidia-glx module-assistant
m-a update
m-a prepare
m-a build nvidia-kernel-source

J'aime bien les gens comme ça, pas de tralala, on vire Windows et on passe à Debian ;)  C'est la meilleure façon d'apprendre...
Puis tu vas dans /usr/src/ et tu dpkg -i le deb
31 Juillet 2007 20:32:18

Je trouve pas que ce soit la meilleure facon d'apprendre. Lorsque je suis passé sous Linux j'etais content d'avoir une partoche Windows de côté, parce que quand je devais faire un truc que je ne savais pas faire sous Linux il me suffisait de passer sous windows pour faire mes truc (montage video/photos essentiellement, car je ne maitrisais pas pas du tout ceux incluts dans ma distrib, et je ne connaissais pas encore l'excellentissime Kdenlive!)
Sans ca, je crois que ca aurait pu me degouter de Linux, parce que se sentir bridé dans ce qu'on fait... c'est pas le top, surtout quand Linux promet justement la liberté ^^

Ceci dit aujourd'hui il me reste une mini partoche windows pour jouer, et je ne pourrais pas m'en passer tant que CSS ne sera pas porté sous Linux :( 
31 Juillet 2007 20:42:12

ahaha j'arrive même pas a executer une commande DEB

>_< dieu que c'est compliqué, mais que c'est bon XD
31 Juillet 2007 20:44:06

m3ra a dit :
Je trouve pas que ce soit la meilleure facon d'apprendre. Lorsque je suis passé sous Linux j'etais content d'avoir une partoche Windows de côté, parce que quand je devais faire un truc que je ne savais pas faire sous Linux il me suffisait de passer sous windows pour faire mes truc (montage video/photos essentiellement, car je ne maitrisais pas pas du tout ceux incluts dans ma distrib, et je ne connaissais pas encore l'excellentissime Kdenlive!)
Sans ca, je crois que ca aurait pu me degouter de Linux, parce que se sentir bridé dans ce qu'on fait... c'est pas le top, surtout quand Linux promet justement la liberté ^^

Ceci dit aujourd'hui il me reste une mini partoche windows pour jouer, et je ne pourrais pas m'en passer tant que CSS ne sera pas porté sous Linux :( 



j'ai installé steam sur Debian, c'est le premier truc que j'ai fait ^^
(ok j'ai lutté, mais c'est installé)
Playonlinux is ur friend :) 
31 Juillet 2007 22:19:22

ouais mais les emulateurs donnent une qualité a chier et bouffent trop de ressources, c'est assez merdique, et moi j'aime bien quand c'est parfait ^^
31 Juillet 2007 23:06:42

Citation :
normalement, la ligne qui commence par "deb" que tu as du trouvé sur internet est à rajouter a la fin du fichier /etc/apt/sources.list

il s'agit de rajouter un "dépot" qui contient des packages que tu pourras installer....

ensuite,
sudo apt-get update
pour mettre a jour


j'ai fait ça mais j'ai toujours " bash: deb: command not found ".

je ne comprends pas ce passage :
Citation :
à rajouter a la fin du fichier /etc/apt/sources.list
31 Juillet 2007 23:12:34

tapes ceci en console;

su
gedit /etc/apt/sources.list

puis tu rajoute les lignes a la fin. Ce fichier est un fichier systeme donc editable uniquement en superutilisateur (ou root) d'ou le "su" et la demande de mot de passe qui en decoule
1 Août 2007 00:31:02

Merci bien pour ça, j'ai installé le paquet !

Maintenant, je dois activer l'accéleration materiele, merci de faire un dernier effort pour ça.

Citation :
Alors il te faut le mettre à jour. C'est pas bien compliqué ;) 
http://www.ac-creteil.fr/reseaux/s [...] quets.html
voici un petit lien qui t'expliquera ce que c'est et comment s'en servir. Bon courage et bienvenue chez les manchots!

j'ai vu ce post juste à l'instant (la conversation est dure à suivre même pour moi) et je t'en remercie.

Merci à tous pour les efforts que vous faites pour m'aider, en plus je suis un élève difficile.
Reste cette satanée acceleration materiele !!!
1 Août 2007 01:22:02

normalement si tu as installés les pilotes, tu as l'acceleration graphique :) 

Il faut juste que tu relance le serveur graphique en faisant ctrl+alt+backspace
1 Août 2007 01:33:12

m3ra a dit :
normalement si tu as installés les pilotes, tu as l'acceleration graphique :) 

Il faut juste que tu relance le serveur graphique en faisant ctrl+alt+backspace


J'ai suivi ce site à la lettre (je viens de le trouver)

oui j'ai fait Ctrl+alt+backspace, ça a reboot mon interface

à la derniere étape
Citation :
Ne vous reste plus qu%u2019à tester l%u2019installation à l'aide de mesa-utils:

aptitude install mesa-utils

et le test en lui même:

glxinfo | grep "direct rendering"

Si vous obtenez ceci, c%u2019est gagné !!!

direct rendering: Yes


voici le résultat :
Citation :

debian:/home/timmy# glxinfo | grep "direct rendering"
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".


Et quand je lance Steam (ou game on linux) il me dit que l'accel graphique semble desactivée.

Moi qui avait l'impression d'approcher de la réussite ;) 
1 Août 2007 02:01:35

peux tu nous donner le contenu de ton xorg.conf?
Pour le sortir tu tape en console:

su
gedit /etc/X11/xorg.conf


Attention, il faut que le X de X11 soit ecrit en majuscule :) 
Ca t'ouvrira le fichier, ne te reste plus qu'a nous faire un copier/coller.
1 Août 2007 02:14:07

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "nVidia Corporation G70 [GeForce 7600 GT]"
Driver "nv"
BusID "PCI:5:0:0"
EndSection

Section "Monitor"
Identifier "hp L1730"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G70 [GeForce 7600 GT]"
Monitor "hp L1730"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

et merci encore une fois... je sais pas ce que je ferais sans l'aide précieuse qui m'est apportée ici ^^
1 Août 2007 02:29:17

Là ou il y a ecrit driver "nv" (à la section device) tu remplaces "nv" par "nvidia"

Ensuite tu enregistres, tu fermes, et tu relances X
1 Août 2007 02:38:18

debian:/home/timmy# glxinfo | grep "direct rendering"
direct rendering: Yes


MERCIIIIIIIII Bordel de dieu que c'est bon (j'avais besoin d'etre grossier, désolé)
Bon. Ca c'est fait !
Je commençais limite à me demander combien de temps j'allais tenir avant de réinstaller XP :) 

Merci à vous tous de m'avoir aidé, et merci beaucoup à m3ra d'avoir déniché la solution dans tout ce bazard.
1 Août 2007 02:39:37

C'etait pas bien compliqué! ^^
Felicitations à toi d'avoir franchi le pas :) 

edit; un ptit [résolu] dans le titre? :) 
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS