Se connecter / S'enregistrer
Votre question

Supréssion de partition

Tags :
  • Ubuntu
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
21 Août 2007 19:51:32

Bonjour:

Il y'a 2 jours Ubuntu a planter:
-Je ne pouvais plus accéder au terminal
-Je ne pouvais plus accéder à mon poste de travaille.

Et je n'ai rien fais!
Vous allez sûrment pas me croire mais c'est vrai.
Ensuite on ma dit de taper sur ctrl-alt-f2 ou un truc du genre et la personne ma dit de faire autre chose mais je ne l'avais pas vu.

Ensuite j'ai fais ça j'ai du taper mon login et pass.
Ensuite je devais taper autre chose mais je ne savais pas quoi donc je ne pouvais rien faire.

Je le précise à se moment la je ne pouvais pas accéder au menu de ubuntu etc...

Je reboot et je dois taper mon pass et login et quand je met mon login il ne l'accepte pas.

Je ne veut pas réparer se problème car ça va prendre trop de temps.
Je voulais juste savoir si c'était possible de supprimer ma partition de ubuntu depuis windows pour la réinstallé après.

Sans perdre mes donné de windows.

Merci.

Autres pages sur : supression partition

21 Août 2007 20:46:41

salut,
djej68 a dit :

Et je n'ai rien fais!
Vous allez sûrment pas me croire mais c'est vrai.

y a des chances :p 

djej68 a dit :

Je voulais juste savoir si c'était possible de supprimer ma partition de ubuntu depuis windows pour la réinstallé après.

si tu vas le reinstaller par la suite, il suffit de laisser comme c'est, et le jour ou tu reinstalles, choisis les meme partitions!


par curiosité, c'est quoi qui marche pas exactement?
tu as accès au mode graphique ou pas?
c'est une fois que tu rentres ton login/mdp (en mode graphique) que ca foire?


21 Août 2007 21:00:53

bah oui j'ai erreurs je sais plus quoi et je n'ai plus accès au bureau et tout.
Enfin bon pas grave.

A donc
je n'ai que a formaté la ex3?

Merci
Contenus similaires
21 Août 2007 21:04:47

toi t'es vachement précis sur les symptomes :) 

si tu formates la partition ext3, le démarrage ne marchera plus!
répare d'abord le mbr, ensuite tu pourras formater ce que tu veux.

pour ce qui est de ton probleme avec ubuntu, t'avais les drivers proprio de la carte graphique?
21 Août 2007 21:08:40

Comment ça les driver proprio?
Tout se que je peut te dire c'est que j'ai installé les driver de ma carte graphique.

Ensuite comment je répare les mbr?
Tout-à l'heure je reboot je lance ubuntu et je te dit se que sa me met.
Je précise je ne peut pas accédé au bureau ubuntu etc...

Merci.
21 Août 2007 21:18:24

si t'as installé les drivers de ta carte, c'est que tu as du faire une mise à jour de ton noyau, et les drivers ne sont plus compatibles, il suffit de les réinstaller...

ati ou nvidia?

pour le mbr, il faut démarrer sur le cd windows, choisir réparer puis si c'est du xp (pour vista, c'est automatique):
fixmbr c:
fixboot c:
21 Août 2007 21:33:04

J'ai une nvidia.
Oui j'ai fais une mise à jour de mon noyau.

Donc je dois lancé le cd de windows mettre l'option réparé?
Mais c'est bizarre que je ne puisse plus accédé au terminal a mon poste de travaille etc...

Alors que j'allais taper une commande je lance le terminal marche pas.
J'essaye de l'ouvrir avec alt f2 pareil.

Ensuite je veut lancer le poste de travaille marche pas non plus :/ .
21 Août 2007 21:35:47

est ce que le mode graphique se lance?
si ce n'est pas le cas c'est tout à fait normal que le terminal ne se lance pas.


pour les drivers, si tu as gardé le fichier Nvidia.....run, il suffit de le relancer pour que tout rentre dans l'ordre.

21 Août 2007 21:38:40

Oui mais je le lance a partir de ubuntu?
Si oui je ne peut pas.


Car je ne peut pas lancé Ubuntu enfin pas accédé au bureau etc...

C'est quoi le mode graphique?:/
Merci.
21 Août 2007 21:46:41

:pt1cable: 
mode graphique, c'est par opposition au texte (le truc noir avec plein de texte ou alors le fond bleu avec le message d'erreur dans une fenetre grise!)

et si, tu peux le lancer depuis ubuntu, il suffit une fois le message d'erreur passé et qu'un message s'affiche sur l'écran avec
login:
à la fin, de taper ton login puis ton mot de passe (meme si ce dernier ne s'affiche pas)

ensuite:

sudo nano /etc/X11/xorg.conf

le X en majuscules est important
ensuite tu cherches la ligne:

Driver "nvidia"

et tu la remplaces par
Driver "nv"

ctrl+x pour sauver puis "entrer"

et finalement:

sudo /etc/init.d/gdm start

et la tu devrais avoir ton bureau!

et on verra pour reinstaller les drivers
21 Août 2007 22:24:13

Donc j'ai taper:

sudo nano /etc/X11/xorg.conf

Ensuite sa ma mis une autre fenetre avec modifier,quitter page suivante dans un menu en bas donc j'ai mis rechercher c'était "^w"

J'ai taper ^w ensuite j'ai fais entrer et j'ai taper driver nvidia rien ne se passe.

Je tape donc ^w driver nvidia je fais entrer pareil rien ne se passe.
je tappe driver nvidia tout seul rien non plus.

Je fais comment?

Merci
21 Août 2007 22:55:08

après
sudo nano /etc/X11/xorg.conf
tu devrais avoir ca:


sans le terminal bien sur

pour la recherche, tape plutot:
"nvidia"
car le nombre d'espace entre "Driver" et "nvidia" peut différer.
21 Août 2007 23:03:13

Ok j'ai tout ça sauf le textes mais sinon c'est ça.
Mais je tape donc ^w nvidia?
21 Août 2007 23:14:45

salut djej68, a mon avis, tu utilise un programme de formatage
ex(partition magique, partition commander, ...) tu formate tous
les partitions de linux tu laisse seulement les partitions NTFS. et puis sert toi de ton cd d'installation UBUNTU pour
le reinstaller. après tous marchera bien. :) 
21 Août 2007 23:15:51

Oui mais si il y'a un moyen de tout réparer sans formater c'est mieux.
21 Août 2007 23:17:46

oui avec les " autour
21 Août 2007 23:19:28

espir a dit :
salut djej68, a mon avis, tu utilise un programme de formatage
ex(partition magique, partition commander, ...) tu formate tous
les partitions de linux tu laisse seulement les partitions NTFS. et puis sert toi de ton cd d'installation UBUNTU pour
le reinstaller. après tous marchera bien. :) 

et pourquoi utiliser un logiciel (payant par dessus le marché) pour faire ca???
s'il choisit cette solution, il n'a qu'à recommencer l'install et aux choix des partitions, séléctionner celles qui existe déjà et cocher "formater"!
22 Août 2007 00:40:20

Donc j'ai essayer avec nvidia avec le ^w avec sans,sans espace etc...
Toujours rien.
22 Août 2007 00:44:49

djej68 a dit :
Ok j'ai tout ça sauf le textes mais sinon c'est ça.
Mais je tape donc ^w nvidia?

sans le texte, tu veux dire que c'est vide???
tu t'es pas trompé dans le nom du fichier?

tu peux taper:
grep -i nvidia /etc/X11/xorg.conf

si ca te sort une ligne
Driver "nvidia"

tu dois la trouver dans le fichier!

au cas ou, je rappelle que le X de X11 est en majuscules
22 Août 2007 00:47:20

Oui je l'avais mis en majuscules mais en majuscules ou pas il avait la même taille enfin bon.

Comment ça la trouver dans le fichier?
Désolé de mon incompréhension.

Merci.
22 Août 2007 00:51:15

bref, si tu n'as aucune ligne dans le fichier quand tu l'ouvres, c'est pas normal, ce fichier est nécessairement présent sauf si tu l'as effacé...

pour etre sur:

cd /
cd etc
cd X11
ls

et dis moi si une commande te retourne une erreur et si non, est que tu vois le fichier xorg.conf dans la liste qu'il te sort
22 Août 2007 00:56:26

Ok donc je dois taper ça:

grep -i nvidia /etc/X11/xorg.conf

Ou ça:
cd /
cd etc
cd X11
ls

Et je le tape ou? Pareil que avant?

Merci.
22 Août 2007 01:06:11

ben oui, tu veux le taper où sinon??

tu tapes la 2eme suite de commande
22 Août 2007 02:57:06

Donc j'ai taper:

grep -i nvidia /etc/X11/xorg.conf

Avec les espaces etc... je x en majuscules mais sa me met:
"grep -i nvidia /etc/X11/xorg.conf:Aucun fichier ou répertoire de ce type.
22 Août 2007 11:19:24

et les autres commandes?
22 Août 2007 13:37:03

Celle la:

cd /
cd etc
cd X11
ls

Il faut la taper après donc je ne peut pas encore la faire.

Et si je tape celle la:

sudo nano /etc/X11/xorg.conf et après celle la:

cd /
cd etc
cd X11
ls

Sa marche?

22 Août 2007 13:57:33

:pt1cable:  je comprends rien à ce que tu me dis...

But:
Ouvrir le fichier "xorg.conf" situé dans le répertoire "/etc/X11" pour y modifier une ligne.

Shell:
c'est ce qui te permet d'entrer une commande.
l'invite de commande est du genre:
user@host:~$


sudo
te permet d'exécuter une commande en tant que root (administrateur en quelque sorte)
"xorg.conf" n'est pas modifiable en tant qu'utilisateur normal.
si tu tapes
nano /etc/X11/xorg.conf
tu ne pourras pas le modifier.


nano
l'editeur de texte.
on lui donne comme argument le fichier à éditer.
si tu es dans le bon répertoire
nano fichier
suffit, sinon, il faut taper
nano /chemin_complet/fichier


cd
te permet de changer de répertoire.
"cd /" => change le répertoire vers la racine (le début du système de fichier)
"cd etc" => va dans le répertoire "etc"
...
en théorie, après un "cd xxx", l'invite de commande change en
host@user:xxx$


djej68 a dit :
Celle la:

cd /
cd etc
cd X11
ls

Il faut la taper après donc je ne peut pas encore la faire.

après quoi? je comprends pas!

vu que tu ne trouves pas le fichier, je t'ai demandé de taper ces commandes pour diviser la taches et voir où est qu'il y a une erreur.

22 Août 2007 14:00:53

Je comprend pas trop désolé je dois taper laquel de celle ci au début:

-grep -i nvidia /etc/X11/xorg.conf
-nano /etc/X11/xorg.conf

J'ai déja taper celle ci:

grep -i nvidia /etc/X11/xorg.conf

Et sa ma mis aucun fichier ni répertoire de ce type.

Merci.

22 Août 2007 14:02:50

:heink: 

cd /
cd etc
cd X11
ls

et dis moi ce que ca te sort
22 Août 2007 14:12:38

Je ne peut pas la taper comme ça:

cd /
cd etc
cd X11
ls

Mais comme ça oui cd/ cd etc cd X11 ls mais sa ne marchera pas.

22 Août 2007 14:14:32

:ange:  c'est 4 commandes, tu en tapes une, entrer, puis l'autre, ainsi de suite...
22 Août 2007 14:15:24

Oups ok je fais ça.
22 Août 2007 14:30:25

Donc sa ma mis ça en couleurs différentes:

20041030ubuntugzm.png
adeskels-0.61
amsn-0.97rc1-1.tlc 84.x 86 package
amsn-0.97rc1-1.tlc 84.x 86 package2

amn_received
Desktop
Exampler
Firefox_wallpaper.png
Hinsolite chat
Images.png
m63272-1.png
msfonts-config2.zip
22 Août 2007 14:34:26

:D  je sais pas comment tu fais ton truc, mais ce que tu m'as affiché la, c'est ton répertoire perso, alors à part si ca t'a mis une erreur sur une commande avant (en fait sur les 3), je vois vraiment pas (mais alors, meme pas un soupcon) comment tu arrives à ca!!

si ca t'as mis une erreur avant, ca serait bien de l'avoir
22 Août 2007 14:35:43

Non j'ai juste taper ta commande comme tu ma dit de faire et sa ma mis ça.
Anonyme
22 Août 2007 14:43:41

:ange:  j'ai bien rigolé (pardon) alors jme permet d'intervenir
Citation :
Mais comme ça oui cd/ cd etc cd X11 ls mais sa ne marchera pas

tu as noté qu'il y avait un espace entre cd et /
  1. cd /

est ce que le terminal t'a répondu ça :
  1. bash: cd/: Aucun fichier ou répertoire de ce type
22 Août 2007 14:43:48

c'est pas une seule commande.
exemple de ce que ca fait normalement:

test@host:~$ cd /
test@host:/$ cd etc
test@host:/etc$ cd X11
test@host:/etc/X11$ ls
app-defaults rgb.txt xorg.conf.backup Xsession.options
cursors X Xresources XvMCConfig
default-display-manager xinit xserver Xwrapper.config
fonts xkb Xsession
gdm xorg.conf Xsession.d
test@host:/etc/X11$

22 Août 2007 14:45:51

Oui ça ma mis aucun répertoire de ce type pour toute les commande enfin pour toute celle la:

cd /
cd etc
cd X11
ls

Non je n'ai pas mis en espace entre cd et /.
Anonyme
22 Août 2007 14:46:50

Voilà la source du problème !
22 Août 2007 14:47:21

djej68 a dit :

Non je n'ai pas mis en espace entre cd et /.

ben il le faut
et au passage, merci cart :p , je commencais à douter :D 

djej68 a dit :
Oui ça ma mis aucun répertoire de ce type pour toute les commande

pourquoi ceux qui veulent etre aidé retiennent les informations??!?
tu nous aurais mis le message d'erreur direct, ca aurait économisé pas mal de posts...
d'un autre coté, ca occupe :ange: 
22 Août 2007 14:48:08

Ok je fais ça.
22 Août 2007 15:17:21

Donc sa ma mis ça:

dpkg
emacs
enscript.cfg
esound
event.d
fdmount.conf
firefox
fonts
foomatic
fstab
fstab.pre-uuid
gaim
gamin
gconf
gimp
gnome
gnome-system-tools
gnome-vfs-2.0
gnome-vts-mime-magic
gre.d
groff
group
group-

manpoth.config
mediaprm
menu-methods
mime.types
m kefs.conf
modprobe.d
modules
modutils
mono
motd
modt.tal
m tab
musql
nonorc
net
netscsid.conf
network
network manager
networks
nsswitch.conf
openoffice
opt
pam.conf
sound
ssh
ssl
sudoers
sysctl.conf
terminfo
timezone
ucf.conf
udev
uninconf.conf
uptatedb.conf
usplash.conf
vim
vnc.conf
w3m
wgetrc
wodim.conf
x11
xdg
xml
zsh_command_not_fand

22 Août 2007 15:25:31

ca t'as mis un message d'erreur sur la commande
cd X11
... pourquoi tu as continué?
et surtout, pourquoi tu ne le postes pas?

ou tu le fais exprès, avoue ? :p 
22 Août 2007 15:27:25

A oui désolé je ferais attention la prochaine fois.
Je fais quoi maintenant tu vois un peut plus d'où vient le problème?

Merci.
22 Août 2007 15:46:21

à ce niveau, je dirai qu'il est entre la chaise et le clavier :p 

si tu me mets le message d'erreur, j'aurai plus d'infos.
mais je parierai que tu as mis le x en minuscules!!!

bref pour une derniere fois, il faut éditer le fichier /etc/X11/xorg.conf et modifier la ligne comme dit plus haut.
si tu n'y arrives pas en une seule ligne, fais pas à pas en allant d'abord dans le répertoire puis en faisant:
sudo nano xorg.conf

si ca marche toujours pas, achete toi une console, c'est beaucoup plus simple.

excuse mais après 40 posts sur la meme commande, ca use...
Anonyme
22 Août 2007 16:09:54

Patience avec les nouveaux manchots...
djej68 je te conseille de te documenter un minimum sur les commandes de bases ..
bon courage
24 Août 2007 00:19:00

Bonjour:

Y'a t-il un moyen que je supprime la partition de Ubuntu à partir de Windows?

Sans risque de plantage ou que je dois reformaté.

Merci.
25 Août 2007 19:06:55

Une réponse à mon post précedent s'il vous plaît.
Merci de votre aide.
25 Août 2007 19:49:13

si c'est xp:
va ici:http://www.zebulon.fr/dossiers/61-console-de-recuperati...
installe la console de récupération sur le disque puis répare le secteur de boot et enfin répare le mbr.

EDIT: j'oubliais, une fois ceci fait, bouton droit sur le poste de travail, gérer, gestion des disques, bouton droit sur la partition puis supprimer
26 Août 2007 23:55:07

Et si je les supprime avec gparted sur le livecd de Ubuntu,il y'a un risque de plantage?

Merci.
      • 1 / 2
      • 2
      • Dernier
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS