Votre question

[Debian]Probleme avec glib

Tags :
  • Debian
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
7 Octobre 2007 17:27:59

Salut,

Je dois installer gtk+ mais pour cela il me demande d'installer d'autres elements comme atk et glib.

J'ai donc choper une version de glib 2.14.1 et installer (en tar.gz).
Ensuite je veux installer atk 1.0.3 (en tar.gz aussi), mais durant le ./configure il me retourne cette erreur:

  1. checking for pkg-config... /usr/bin/pkg-config
  2. checking for GLIB - version >= 2.0.0...
  3. *** 'pkg-config --modversion glib-2.0' returned 2.14.1, but GLIB (2.12.4)
  4. *** was found! If pkg-config was correct, then it is best
  5. *** to remove the old version of GLib. You may also be able to fix the error
  6. *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
  7. *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
  8. *** required on your system.
  9. *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
  10. *** to point to the correct configuration files
  11. no
  12. configure: error:
  13. *** GLIB 2.0.0 or better is required. The latest version of
  14. *** GLIB is always available from <a href="ftp://ftp.gtk.org/" rel="nofollow" target="_blank">ftp://ftp.gtk.org/</a>.


Et la je suis un peu coincé, pkg-config est un fichier executable et dans /etc/ld.so.conf il y a juste une ligne.
Bref si il ne cherche pas glib au bon endroit, que faut-il changer pour que tout redevienne normal ?

Autres pages sur : debian probleme glib

7 Octobre 2007 17:55:41

salut, pourquoi tu n'utilises pas le gestionnaire de paquets?
apt-get install libgtk2.0-0
7 Octobre 2007 20:34:18

Ah
parce que dans les depot quand je cherche gtk+ je trouve pas, mais si le paquet est gtk2.0 je dois avoir sa.

:pt1cable: 

J'utiise synaptic sinon pour les depots.

edit:
Ah je viens de voir avec synaptic que libgtk2.0-0 etait deja installer....

En fait c'est pour installer xvidcap en tar.gz aussi car je ne le trouve pas sur les depots, sa me sort:
  1. checking for PACKAGE... configure: error: Package requirements (gtk+-2.0 >= 2.4.0 libglade-2.0 glib-2.0 gthread-2.0) were not met:
  2.  
  3. No package 'gtk+-2.0' found
  4. No package 'libglade-2.0' found
  5. No package 'glib-2.0' found
  6. No package 'gthread-2.0' found


Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS