Se connecter / S'enregistrer
Votre question

Linux:Probléme installation ( looking-glass )

Tags :
  • linux
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
8 Octobre 2007 18:18:44

Salut à tous,
Voilà il fallait que je poste ce message parti OS : j'ai un problème lorsque j'installe les 3 paquets de looking-glass ( un environnement de bureau super beau avec java ) qui sont lg3d-core lg3d-java3d lg3d-jdk ...
Voici le message d'erreur que je reçoit :

"E: /var/cache/apt/archives/lg3d-java3d_1.5.0_i386.deb: le sous-processus pre-installation script a retourné une erreur de sortie d'état 1" ...

Quelqu'un pourrait-il m'aider ???

Autres pages sur : linux probleme installation looking glass

8 Octobre 2007 18:48:06

tu les télécharges manuellement (d'où?), ou alors tu as rajouté un dépot dans sources.list (lequel?) ?

vu que tu as déjà le paquet, tu peux poster (seulement s'il n'est pas long)
/var/lib/dpkg/info/lg3d-java*.preinst
Contenus similaires
8 Octobre 2007 21:21:23

tu les installes depuis synaptics?
si c'est le cas, faut dérouler la zone des messages pour accepter la license.

ou pour etre sur, installe le depuis la ligne de commande:
sudo aptitude install lg3d-core lg3d-java3d lg3d-jdk


(c'est plus la peine pour le fichier, j'en ai une copie)
13 Octobre 2007 17:25:19

Bon voilà ce que j'obtiens en terminal :

"Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture de l'information d'état... Fait
Initialisation de l'état des paquets... Fait
Construction de la base de données des étiquettes... Fait
Les NOUVEAUX paquets suivants vont être installés :
lg3d-core lg3d-java3d
0 paquets mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0o/65,2Mo d'archives. Après dépaquetage, 0o seront utilisés.
ATTENTION : des versions non certifiées des paquets suivants vont
être installées.

Des paquets non certifiés peuvent compromettre la sécurité de votre
système. Vous ne devriez les installer que si vous êtes certain
que c'est bien votre intention.

lg3d-core lg3d-java3d

Voulez-vous ignorer cet avertissement et continuer quand même ?
Pour continuer, entrer « Oui ». Pour interrompre l'installation, entrer « Non » : Oui
Écriture de l'information d'état étendu... Fait
Préconfiguration des paquets...
Échec de la préconfiguration de lg3d-java3d, avec le code d'erreur 1
(Lecture de la base de données... 151940 fichiers et répertoires déjà installés.)
Dépaquetage de lg3d-java3d (à partir de .../lg3d-java3d_1.5.0_i386.deb) ...
dpkg : erreur de traitement de /var/cache/apt/archives/lg3d-java3d_1.5.0_i386.deb (--unpack) :
le sous-processus pre-installation script a retourné une erreur de sortie d'état 1
Sélection du paquet lg3d-core précédemment désélectionné.
Dépaquetage de lg3d-core (à partir de .../lg3d-core_1.0.0_i386.deb) ...
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/lg3d-java3d_1.5.0_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
dpkg : des problèmes de dépendances empêchent la configuration de lg3d-core :
lg3d-core dépend de lg3d-java3d (>= 1.5.0) ; cependant :
Le paquet lg3d-java3d n'est pas installé.
dpkg : erreur de traitement de lg3d-core (--configure) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
lg3d-core"
13 Octobre 2007 19:53:20

je viens de voir sur leur site qu'il te faut un autre paquet:
https://lg3d-core.dev.java.net/binary-builds.html
lg3d-jdk

sinon:

sudo gedit /var/lib/dpkg/info/lg3d-java*.preinst

et rajoute juste après
#!/bin/sh -e
exit 0
c'est pas très clean, mais les paquets datent, il y a peut etre eu des modifs depuis...
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS