Se connecter / S'enregistrer
Votre question

Lancer un script au démarrage

Tags :
  • Éditeur de texte
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
22 Février 2008 00:30:56

Bonsoir tout le monde petite question :
comment fait-on pour lancer un script au démarrage SVP?
Je suis sous Gutsy merci pour la réponse

Autres pages sur : lancer script demarrage

22 Février 2008 13:22:23

Personne pour m'aider? en fait j'aimerai que ce script se lance au démarrage de mon pc :

  1. #!/bin/bash
  2.  
  3. sleep 1
  4.  
  5. espeak -vfr -s100 "Bonjour nous sommes le `date +%A` `date +%d`
  6. `date +%B` `date +%Y` il est `date +%H` heure `date +%M`"
  7.  
  8. exit 0



(Script crée par diodio13fr)

EDit : au passage ,comment lancer un script avec les permissions root sous gutsy SVP merci
22 Février 2008 13:27:58

si c'est pour ta session:
- au démarrage de la session => il faut le rajouter dans systemes->preferences->session
- au démarrage de l'ordi:
crontab -e

et rajouter la ligne:
@reboot chemin_vers_ton_script


sinon, au niveau system, il y a /etc/rc.local mais j'aime pas cette méthode (parce que ca s'execute en root et c'est un avis perso :) )
Contenus similaires
22 Février 2008 14:05:23

merci coca25
J'ai ajouter le script dans system/preference/session mais il ne se lance pas au démarrage!
Dans le terminal je tape la commance crontab -e ,je rajoute la ligne : @reboot /home/Ch3mist/desktop/nom du script mais je n'arrive pas a sauvegarder ,comment faire svp?

22 Février 2008 14:50:25

ben ca dépend de l'éditeur de texte...
c'est nano?? si c'est ca, c'est ctrl+x
ou ":x" pour vi

pour etre sur que ton script se lance, crée une sortie vers un fichier...
22 Février 2008 17:54:42

oué nan sa ne marche toujours pas...je vais continuer a chercher puis si je trouve ,je viendrai poster la réponse ici.Merci beaucoup pour ton aide
22 Février 2008 18:18:45

euh juste pour vérif, c'est le script qui ne fonctionne pas ou il ne démarre pas du tout?
22 Février 2008 18:35:03

Si le script fonctionne, mais il ne veut pas se lancer automatiquement au démarrage :( 
22 Février 2008 18:47:04

comment tu vérifie s'il se lance ou pas? si c'est juste le fait que tu n'entends rien, c'est peut etre parce qu'il utilise le serveur de son qui n'est lancé qu'avec l'interface graphique...
met un
sleep 240
pour couvrir le démarrage de la session (4mn) pour voir...
et le mieux serait de rediriger sa sortie pour voir s'il n'y a pas d'erreur
parce qu'il n'y a pas de raison qu'il ne s'execute pas (à part si tu t'es trompé dans la syntaxe de cron...)
22 Février 2008 19:04:42

Oué ! C'est ok sa marche , il fallait changer la valeur de sleep.
Merci coca25 c'est Nikel.

Si il y a des personnes intéressés a développer ce script postez ici sa pourrait -etre sympa. :) 
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS