Votre question

Wifi sous Mandriva 2008

Tags :
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
22 Mars 2008 16:10:07

Bonjour, voila je viens d'installer Linux tout a l'heure sur mon PC et je n'arrive pas a me connecter en WIFI.

en lançant Mandriva en Live-CD tout marcher nikel (j'avais du wifi) et maintenant que je l'ai installer sur le disque dur il ne marche plus. Le bouton de ma carte Wifi est éteind, quand j'essaye d'aller configurer une connexion wifi ma carte est afficher mais kan je clique sur suivant il me dit que la carte est désactiver, de l'activer en appuyan sur mon boutton mais j'ai beau y appuyer maintenir appuyer et tout ya pas moyen d'activer ma carte.


Mon ordinateur est un acer 9411
ma carte wifi est une Intel 3945AGB
j'ai téléchareger les pilotes pour linux mais je ne sait pas comment les installés.


si quelqun a une solution...


Merci d'avance
@++

Autres pages sur : wifi mandriva 2008

23 Mars 2008 23:06:39

bon jen est parlé a un amis il dis ke le problème viens du fait que ma carte wifi ne démarre pas quand Mandriva démarre.

le truc c'est que sous la vertion Live CD le wifi marche et une foi installé sur le disque dur sa marche plus...

je c pas si c plus clair???
j'ai vrément besoin d'aide la alors si vous avez une petite idée...



merci d'avance
@++
Contenus similaires
25 Mars 2008 01:29:11

salut, tu actives ton wifi comment? avec une combinaison de touches ou avec un interrupteur spécifique? si c'est le 2eme choix, c'est logiciel ou mécanique?

tu peux poster la sortie des commandes suivantes (à taper dans un terminal):
  1. lspci | grep -i net
  2. lsmod | grep ipw
  3. ifconfig -a
25 Mars 2008 19:28:17

bon alors je vais te poster ce que tu me demande mais apparament on ma dis que j'ai besoin d'installer un driver.

alors j'aurais besoin d'aide pour l'installer mais tout de A à Z je ne sait pas ce qu'il faut télécharger, comment il faut faire j'ai chercher sur google ya pas moyen de trouver quelque chose en Français. (ma carte c'est une Itel PRO/wireless 3945AGB network connexion)


Si nn mon intérupteur c'est un bouton spécifique et c'est logiciel
25 Mars 2008 19:41:07

alors lé résultats :

1. y donne les références des cartes moi c Intel PRO/Wireles 345AGB Network Connexion
2. Bash : Comand not found
3. Bash : Comand not found
25 Mars 2008 20:54:02

pour les msg d'erreur, ca serait bien de poster le message exact, car la, tu as enlever le plus important... entre bash et command not found!
il faut les lancer en root (avec "su -" ) ou spécifier le chemin d'ailleurs je m'étais trompé, c'était iwl et non ipw (fais les 2, je me rappelle plus lequel est installé sur la 2008):
/sbin/lsmod | | grep "\(iwl\|ipw\)"
/sbin/ifconfig -a

la 1ère commande permet de voir si le driver est déjà installé et la 2eme de voir si la carte est reconnue
31 Mars 2008 19:56:56

voila je suis désolé pour ma réponse un peu tardive

alors les résultats pour la commande lsmod :

  1. Ipw3945 204324 1
  2. ieee80211 32392 1 ipw3945





résultat pour la commande Ifconfig :

  1. eth0 Link ethernet HWaddr: 00:16:D3:41:85:4E
  2. UP BROADCAST MULTICAST MTU:1500 Metric:1
  3. RX packets:0 error:0 Dropped:0 overnum:0 frame:0
  4. TX packets:0 error:0 dropped:0 overnum:0 carrier:0
  5. colision:0 lg file transmition:1000
  6. RX byte:0 (0.0b) TX byte:0 (0.0b)
  7. Interruption:16 adresse de base:0x4000
  8.  
  9.  
  10. lo Link encap:boucle locale
  11.  
  12. (la suite est elle nécessaire j'ai la flemme de tout me recopier. une boucle locale na rien a voir ac le wifi...)
31 Mars 2008 21:59:58

coca25 a dit :
salut, tu actives ton wifi comment? avec une combinaison de touches ou avec un interrupteur spécifique? si c'est le 2eme choix, c'est logiciel ou mécanique?


sinon, dans ce que tu as posté, le driver est déjà chargé...

pour ce qui est du recopiage, tu peux créer un fichier texte, y copier les sortie de commande et le mettre dans une clé usb ou sur le disque windows si tu as un dual boot!

sinon dans ce que tu n'as pas recopié, il n'y avait pas eth1 par hasard ?
1 Avril 2008 18:53:00

non justement il n'y a pas Eth1 il n'y a ke ces deux connections la

j'active mon wifi par un petit boutona gauche de mon clavier (c'est un PC portable) mais qu'est-ce que tu appelle mécanique ou logiciel?

c'est un bouton poussoir qui n'a qu'une seule position stable.

Mais le pilote doit-etre effectivement installer vus que quand je lance Mandriva avec le Live-CD j'ai le wifi. mais une fois installé sur le disque durs le wifi ne marche pas...

Il doit manqué quelque chose au moment ou mandriva démarre mais quoi????
1 Avril 2008 20:35:23

par logicielle/mécanique, je veux dire que si c'est une touche du clavier, ou un bouton qui ne change pas de position, il est peut etre pris en compte par un driver sous windows, et que le wifi est éteint par défaut (quoique, sur le livecd, ca marche !!)
alors que si c'est mécanique, ca revient à une insertion de clé usb par exemple...
regarde dans le bios, s'il n'y a pas d'option pour le mettre en activé par défaut.
2 Avril 2008 17:58:21

Bon j'ai regarder dans les options du boot et il n'y arien qui me permette de choisir si je veu ou pas activer le wifi au démarrage.

d'ailleur lorsque l'ordinateur démarre (sur le boot) le voyan du wifi est allumé. est c'est lorsque mandriva démarre (a l'étape "Starting udev" du démarrage trés exactement) que le voyan s'éteind.


y a t-il un réglage a faire sous mandriva? mais sa me parait bizare étant donné que sa marche avec le Live CD...

je n'y comprend plus rien la...

2 Avril 2008 18:13:16

tu peux poster la sortie de ces commandes:
cat /sys/bus/pci/drivers/ipw3945/*/rf_kill
echo 0 > /sys/bus/pci/drivers/ipw3945/*/rf_kill
cat /sys/bus/pci/drivers/ipw3945/*/rf_kill

(le echo est à faire en root)
2 Avril 2008 18:55:59

voila ben j'ai fait un copier coller comme tu m'avai dis dans un fichier txt donc j'ai pas pus me tromper et apparament la commande echo marche pas ou alors c'est normal ke sa n'affiche aucun résultat a l'écrant peut etre ?

enfin voila le copier collé du résultat :

  1. [legef@localhost ~]$ su -
  2. [root@localhost ~]# cat /sys/bus/pci/drivers/ipw3945/*/rf_kill
  3. 2
  4. [root@localhost ~]# echo 0 > /sys/bus/pci/drivers/ipw3945/*/rf_kill
  5. [root@localhost ~]# cat /sys/bus/pci/drivers/ipw3945/*/rf_kill
  6. 2
  7. [root@localhost ~]#
2 Avril 2008 22:04:16

tu dois avoir des commandes
ipw3945-stop
ipw3945-start

lance les 2 en root et regarde si le bouton pour activer le wifi fonctionne cette fois ci.
3 Avril 2008 14:18:31

non il me dit que les commandes n'existent pas ...

  1. bash:ipw3945-stop:command not found
3 Avril 2008 19:03:51

tu l'as fait depuis root?
geis007 n'est pas dans les parages,? il a mdv2008 lui... ;) 

sinon à défaut, kill le processus comportant ipw3945d dans le nom
killall ipw3945d

devrait faire l'affaire et de toute facon, la suppression du module devrait le faire --->

décharge et recharge le module:
rmmod ipw3945
modprobe ipw3945 disable=0

3 Avril 2008 19:49:21

coca25 a dit :
tu l'as fait depuis root?
geis007 n'est pas dans les parages,? il a mdv2008 lui... ;) 

Si, et je lis, mais je n'ai rien à dire sur le sujet. J'ai un poste fixe, en ethernet, et je ne connais rien au wifi (à vrai dire, je n'ai pas envie, il y a autour de nous suffisamment d'ondes électromagnétique non contrôlable pour que j'aie envie d'en rajouter).

Si je peux aider, tester des trucs, vérifier des paquetages, mais ici, la commande
/sbin/lsmod | | grep "\(iwl\|ipw\)"
ne retourne rien
25 Avril 2008 12:02:08

Salut j'ai le même et sa marche!

tu ajoute la ligne suivante dans modprobe.conf....

options acer_acpi wireless=1

le bouton reste inactif mais le wifi est activé au demarrage.


@+
7 Mai 2008 19:32:25

Salut, alors je veut bien te croire mais je n'y connais absolument rien a mandriva ...

ton fichier la y se trouve ou?
et la ligne a rajouter j'imagine que c'est a un endroi précis du fichier ?

Merci d'avance

@++
7 Mai 2008 22:12:18

le fichier est dans /etc/modprobe.conf
et la ligne est à rajouter à la suite de ce qui existe (d'ailleurs peu importe du moment qu'elle est seule sur une ligne)
7 Mai 2008 22:17:59

je vais essayer sa je vous direz ce que sa a donner


merci encore
@++
7 Mai 2008 23:17:11

Voila et bien c'été sa apparament vus que maintenant sa marche.

Un grand merci a tous pour cette aide plus que préceuse ...

merci encore
@++
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS