Votre question

ralink rt2560 + ubuntu + livebox.... wifi instable

Tags :
  • Ubuntu
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
21 Avril 2008 16:20:33

Bon voila hier j'ai installer la dernière version de ubuntu a partir d'un liveDVD. Tout marche super bien sauf... ma connexion wifi grrr

Ma configuration:

Multi OS: vista / ubuntu
carte pci wifi: Hercules Wireless G 802.11g PCI
chipset de cette carte: rt2560 (si je m'en souviens bien)

Problème: Au démarrage je me connecte a internet, puis après 5 a 10 min... je suis connecter a ma livebox mais je ne reçoit pas internet...
J'ai une sorte de page qui met beaucoup de temps a charger, puis elle ne charge pas :cry: 

La carte wifi semble détecter avec: lspci
dans le fichier interfaces (/etc/network/interfaces): lo inet looped

Bon voila, merci de m'aider a résoudre le problème, moi qui suit débutant sous linux.

PS: si vous avez besoin de plus de renseignements dites moi, j'essaierais de copier tout malgrès le peu de temps que ma connexion dure.

PS2: en passant vous pouvez me dire ce qu'est le raccourcit: <super>

Autres pages sur : ralink rt2560 ubuntu livebox wifi instable

21 Avril 2008 21:05:47

salut, c'est du à l'utilisation d'un module qui n'est pas encore tout à fait stable... (au fait, par dernière version, tu parles de la 7.10 ou la 8.04 (qui n'est pas encore sortie en stable d'ailleurs)
si tu n'as pas peur de la ligne de commande:

sudo -s
aptitude install rt2500-source
module-assistant auto-install rt2500
rmmod rt2x00pci
rmmod rt2x00lib
modprobe rt2500
iwconfig

ctrl+d pour sortir du root


regarde si ta carte est reconnue après les commandes, si c'est le cas, regarde si la connection est plus stable
et enfin si c'est le cas, il restera plus qu'à blacklister les autres modules pour valider le lancement de rt2500 au boot.
Contenus similaires
21 Avril 2008 21:17:55

J'ai la version stable 7.10.

J'ai pas peur de la liste de commande :) 

par contre, comment backlister les autres modules?
21 Avril 2008 21:23:04

faut les rajouter dans /etc/modprobe.d/blacklist, mais il faut déjà etre sur que ca fonctionne
22 Avril 2008 11:12:44

Toujours instable, mais: ERROR: Module rt2x00lib is in use by rt61pci,rt2x00pci
Voici tout ce qui est passé sur la commande


yohan@djyo-desktop:~$ sudo -s
[sudo] password for yohan:
root@djyo-desktop:~# aptitude install rt2500-sources
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Construction de la base de données des étiquettes... Fait
Impossible de trouver un paquet dont le nom ou la description correspond à « rt2500-sources »
Les paquets suivants ont été conservés automatiquement :
linux-restricted-modules-common
Les paquets suivants ont été conservés :
evince evolution-data-server evolution-data-server-common file-roller
foo2zjs gcalctool gdm gedit gedit-common gimp gimp-data gimp-python
gnome-about gnome-cards-data gnome-games gnome-games-data gnome-panel
gnome-panel-data gnome-session gnome-system-monitor gnome-system-tools
gthumb gtk2-engines gtkhtml3.14 hpijs hwdb-client-common
hwdb-client-gnome libavahi-client3 libavahi-compat-libdnssd1
libavahi-glib1 libecal1.2-7 libedata-book1.2-2 libedata-cal1.2-6
libedataserverui1.2-8 libegroupwise1.2-13 libexchange-storage1.2-3
libgimp2.0 libgtkhtml3.14-19 libgtksourceview2.0-0
libgtksourceview2.0-common libnm-glib0 libnm-util0 libtheora0
linux-restricted-modules-2.6.22-14-generic nautilus nautilus-data
network-manager network-manager-gnome nvidia-glx-new openoffice.org
openoffice.org-base openoffice.org-calc openoffice.org-common
openoffice.org-core openoffice.org-draw openoffice.org-evolution
openoffice.org-gnome openoffice.org-gtk openoffice.org-impress
openoffice.org-java-common openoffice.org-math openoffice.org-style-human
openoffice.org-writer poppler-utils python-uno sound-juicer
ttf-opensymbol ubufox xserver-xorg-video-intel
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 70 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 0o seront utilisés.
Écriture de l'information d'état étendu... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Construction de la base de données des étiquettes... Fait
root@djyo-desktop:~# module-assistant auto-install rt2500

Données de 1 paquets mises à jour
Récupération des sources du noyau de la version : 2.6.22-14-generic
En-têtes du noyau disponibles dans /usr/src/linux-headers-2.6.22-14-generic
Création du lien symbolique...
apt-get install build-essential
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
build-essential est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 70 non mis à jour.

Fait.
unpack
Extracting the package tarball, /usr/src/rt2500.tar.bz2, please wait...
Le fichier de paquet de destination
/usr/src/rt2500-modules-2.6.22-14-generic_1.1.0-b4-4ubuntu1+2.6.22-14.52_i386.d
eb existe déjà, pas de reconstruction.
(however, you could use the -f switch to ignore it)
dpkg -Ei /usr/src/rt2500-modules-2.6.22-14-generic_1.1.0-b4-4ubuntu1+2.6.22-14.52_i386.deb
Version 1:1.1.0-b4-4ubuntu1+2.6.22-14.52 de rt2500-modules-2.6.22-14-generic déjà installée, paquet ignoré.
root@djyo-desktop:~# rmmod rt2x00pci
ERROR: Module rt2x00pci is in use by rt61pci
root@djyo-desktop:~# rmmod rt2x00lib
ERROR: Module rt2x00lib is in use by rt61pci,rt2x00pci
root@djyo-desktop:~# modprobe rt2500
root@djyo-desktop:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:"Mon ssid"
Mode:Managed Frequency:2.412 GHz Access Point: 00:1C:26:8E:79:3E
Retry min limit:7 RTS thr:o ff Fragment thr=2346 B
Encryption key:Ma clée encryption [2]
Link Signal level=-70 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
22 Avril 2008 14:32:50

il faut décharger meme les autres:
rmmod rt61pci
rmmod rt2x00pci
rmmod rt2x00lib
22 Avril 2008 23:00:00

Wifi non reconnu.
22 Avril 2008 23:03:53

tu as chargé rt2500 après avoir déchargé les autres modules?
23 Avril 2008 09:37:35

Ben, j'ai taper ce que tu m'a dit...


modprobe rt2500
iwconfig

Dans le iwconfig, il n'y as plus le: wlan
23 Avril 2008 23:18:34

up

j'ai besoin d'aide svp
24 Avril 2008 22:17:23

ok je test ca.
26 Avril 2008 18:59:05

bon, je te poste le message de lsmod | grep rt:

parport pc 37412 1
parport 3 ppev, lp, parport_pc
agpgart 2 nvidia, intel agp
iTCO vendor support 1 TCO wdt

PS: grr franchement c'est galere
26 Avril 2008 21:00:58

ben il est pas dedans..., il doit donc te sortir une erreur lorsque tu le charges :??: 
depmod -a
modprobe -v rt2500
27 Avril 2008 10:33:53

ok, je vais faire ca, mais en passant.

Faut il que je retape tout le code a chaque fois :telecharger, charger ect...
( ce que je fais ) ?

Peut tu me passer un lien vers un site pour apprendre le langage de la commande linux?
3 Mai 2008 18:00:14

Bon je up ce post car j'ai toujours le meme probleme.

Vous avez, une solution, ndiwrapper peut etre?
5 Mai 2008 22:36:41

Je n'ai pas vu ma carte dans cette liste.
Je ne sais pas comment utiliser ndiswrapper puisque je suis débutant linux :) .

PS: On dirait que l'on vient de passer a la 8.0 de ubuntu, non?
6 Mai 2008 01:43:20

tu peux t'aider de la doc: http://doc.ubuntu-fr.org/ndisgtk
en gros, il te faut principalement le fichier .inf du pilote sous windows ainsi que tous les fichiers auquel il fait appel (si tu as un cd ou une archive pour le pilote, ca devrait etre dedans)
maintenant, si la carte n'est pas listé sur le site ndiswrapper, le résultat est loin d'être garanti.
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS