Se connecter / S'enregistrer
Votre question

Vista PE builder/Drive Image xml

Tags :
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
21 Mai 2008 19:14:15

Bonjour,
alors voila je souhaite faire des backup de mon disque dur et pour cela, j'utilise Drive Image xml qui est gratuit et très bien.
Je voudrais créer une version bootable de ce logiciel pour rstaurer en cas de crash. J'ai suivis les instructions et il est dit qu'il faut créer un version alléger de windows avec PE builder. Le problème est qu'il faut les dvd d'installation de vista et non ce de retauration que j'ai créer moi même avec un logiciel HP.
Donc je peux pas créer mon Widows vista "live" :( 
Comment pourrai je faire ?
merci

Autres pages sur : vista builder drive image xml

22 Mai 2008 10:22:53

Bonjour,
je n'ai que 1 mot à dire : MERCI!!!!
J'ai suivis le tuto, après de grosse frayeur (ordi qui ne s'arrêter plus...)
j'ai réussi à créer mon windows PE.
Par contre j'ai quelques questions.
Quand je boot sur le cd, j'arrive sur l'image de fond de vista avec seulement un invite de commande. Il manque rien ?
Ah oui aussi, il faut que je compile Drive Image xm, qui est sous forme d'un ".cab"

Dans la console, je tape :
1°)copype x86 c:\winpe_base
imagex /apply c:\winpe_base\winpe.wim 1 c:\winpe_base\mount

2°)xcopy /s/e/i "C:\Users\ludovic\Desktop\Backup tools\driveimage_xml.cab" c:\winpe_base\mount\util\easybcd

C:\Users\ludovic\Desktop\Backup tools\driveimage_xml.cab

3°)peimg /image=c:\winpe_base\mount /prep
imagex /capture /boot /compress max c:\winpe_base\mount c:\winpe_base\iso\sources\boot.wim" "winpe perso"

4°)oscdimg -n -bc:\winpe_base\etfsboot.com c:\winpe_base\iso c:\winpe_base\winpe_perso.iso


Mais ça ne marche pas :(  où est l'erreur ?
merci
Contenus similaires
22 Mai 2008 10:52:47

voilà ce qu'il se passe :



Updating path to include peimg, oscdimg, imagex

C:\Program Files\Windows AIK\Tools\PETools\
C:\Program Files\Windows AIK\Tools\PETools\..\x86


C:\Program Files\Windows AIK\Tools\PETools>copype x86 c:\winpe_base

===================================================
Creating Windows PE customization working directory

c:\winpe_base
===================================================

1 fichier(s) copié(s).
1 fichier(s) copié(s).
C:\Program Files\Windows AIK\Tools\PETools\x86\boot\bcd
C:\Program Files\Windows AIK\Tools\PETools\x86\boot\boot.sdi
C:\Program Files\Windows AIK\Tools\PETools\x86\boot\bootfix.bin
C:\Program Files\Windows AIK\Tools\PETools\x86\boot\etfsboot.com
C:\Program Files\Windows AIK\Tools\PETools\x86\boot\fonts\chs_boot.ttf
C:\Program Files\Windows AIK\Tools\PETools\x86\boot\fonts\cht_boot.ttf
C:\Program Files\Windows AIK\Tools\PETools\x86\boot\fonts\jpn_boot.ttf
C:\Program Files\Windows AIK\Tools\PETools\x86\boot\fonts\kor_boot.ttf
C:\Program Files\Windows AIK\Tools\PETools\x86\boot\fonts\wgl4_boot.ttf
9 fichier(s) copié(s)
C:\Program Files\Windows AIK\Tools\PETools\x86\EFI\microsoft\boot\bcd
C:\Program Files\Windows AIK\Tools\PETools\x86\EFI\microsoft\boot\fonts\chs_boot
.ttf
C:\Program Files\Windows AIK\Tools\PETools\x86\EFI\microsoft\boot\fonts\cht_boot
.ttf
C:\Program Files\Windows AIK\Tools\PETools\x86\EFI\microsoft\boot\fonts\jpn_boot
.ttf
C:\Program Files\Windows AIK\Tools\PETools\x86\EFI\microsoft\boot\fonts\kor_boot
.ttf
C:\Program Files\Windows AIK\Tools\PETools\x86\EFI\microsoft\boot\fonts\wgl4_boo
t.ttf
6 fichier(s) copié(s)
1 fichier(s) copié(s).
1 fichier(s) copié(s).

Success

Updating path to include peimg, oscdimg, imagex

C:\Program Files\Windows AIK\Tools\PETools\
C:\Program Files\Windows AIK\Tools\PETools\..\x86


c:\winpe_base>imagex /apply c:\winpe_base\winpe.wim 1 c:\winpe_base\mount

ImageX Tool for Windows
Copyright (C) Microsoft Corp. 1981-2005. All rights reserved.



Progress: 100%

Successfully applied image.



c:\winpe_base>xcopy /s/e/i "C:\Users\ludovic\Desktop\Backup tools\driveimage_xml
.cab" c:\winpe_base\mount\util\easybcd
Est-ce que C:\winpe_base\mount\util\easybcd spécifie un nom de fichier
ou un nom de répertoire de la destination
(F = fichier, D = répertoire) ? d
Est-ce que C:\winpe_base\mount\util\easybcd spécifie un nom de fichier
ou un nom de répertoire de la destination
(F = fichier, D = répertoire) ? f
C:\Users\ludovic\Desktop\Backup tools\driveimage_xml.cab
1 fichier(s) copié(s)

c:\winpe_base>peimg /image=c:\winpe_base\mount /prep
Outil d´installation d'images PE pour Windows
Copyright (C) Microsoft Corporation. Tous droits réservés.

La commande /prep modifiera définitivement une image Windows PE qui ne
pourra donc plus être traitée. Les opérations suivantes :

- Installation ou désinstallation de fonctionnalités optionnelles
- Application de correctifs ou d'autres packages de mise en service
- Installation de modules linguistiques

ne seront pas possibles sur l'image préparée.

Pour continuer, entrez « oui ». Toute autre entrée quittera le programme.

Voulez-vous continuer ? imagex /capture /boot /compress max c:\winpe_base\mount
c:\winpe_base\iso\sources\boot.wim" "winpe perso"yes

PEIMG n'a pas pu terminer l'opération, code d'état 0x80004005.

c:\winpe_base>
22 Mai 2008 12:21:25

ludoc a dit :
Bonjour,
je n'ai que 1 mot à dire : MERCI!!!!

de rien
ludoc a dit :

Quand je boot sur le cd, j'arrive sur l'image de fond de vista avec seulement un invite de commande. Il manque rien ?

non, c'est normal, c'est le truc de base.

ludoc a dit :

Ah oui aussi, il faut que je compile Drive Image xm, qui est sous forme d'un ".cab"

je sais pas trop comment fonctionne drivexml, j'ai juste testé avec des applications en mode texte, mais si drivexml se suffit de ses fichiers, tu n'as qu'à copier le repertoire où il s'installe
pour ne pas griller des cd, tu peux utiliser virtualbox par exemple pour tester les cd que tu construis

sinon, j'ai vu que sur leur site, il parlait de tuto bartpe:
http://www.runtime.org/peb.htm
24 Mai 2008 09:05:19

Bonjour,
j'ai fais xcopy /s/e/i "C:\Users\ludovic\Desktop\pe\*" c:\winpe_base\mount\util\easybcd

pour copier les fichier. J'ai compilé le ISO, je l'ai gravé, je boot dessus mais je ne sais pas quoi taper dans l'invite de commande pour lancer le logiciel.
Merci
24 Mai 2008 12:48:41

je vois pas trop ce que tu copies, par contre pour le lancer, il faut aller dans le répertoire et lancer le programme, ex:
cd repertoire
programme.exe

24 Mai 2008 13:08:39

ba en faut je copie les fichiers de drivexml version à inclure dans le cd Windows PE.

Mais pour le lancer je vois pas trop car quand j'ai l'invite de commande, je tape dir x:\
je vois un repertoire Windows, Users et Program FIles. Quand je fait dir x:\Program FIles, il me dit que le volume s'apelle Boot et il me dit qu'il peut pas accéder à system32 (je vois pas le rapport ^^)
je sais pas où est stoker le logiciel sur le cd une fois qu'il est compiler en ISO.

Une idée ?
24 Mai 2008 13:21:20

normalement, tu dois avoir un répertoire x:\util
tout ce qui est dans c:\winpe_base\mount\ se retrouve dans x:\
24 Mai 2008 13:28:18

je viens de rebooter il y a un 1 instant sur Winpe et j'ai réussi à ouvrir bloc note.
Je reteste...
24 Mai 2008 13:43:01

Bon alors j'ai regarder, il n'y à pas re répertoire "util". j'ai fouiller bien comme il faut avec l'ecplorer de bloc note et il n'y a pas ce répertoire. Mais il y a quelque chose de bizard, c'est que j'ai éssayé de lancer le logiciel directement depuis "C:\Users\ludovic\Desktop\pe\" mais sans réussite :( .
24 Mai 2008 13:58:29

je sais pas ce que tu as dans "C:\Users\ludovic\Desktop\pe\"
par contre, ce que je peux dire, c'est que la commande suivante qui ne peut etre lancé qu'une fois (il faut refaire le répertoire pour la relancer):
peimg /image=c:\winpe_base\mount /prep

crée un cd winpe identique à ce qui existe dans c:\winpe_base\mount
donc, si tu as mis un répertoire util dedans (avant de lancer la cde), tu dois l'avoir, si ce n'est pas le cas, t'as du t'embrouiller...
24 Mai 2008 14:08:39

dans "C:\Users\ludovic\Desktop\pe\" j'ai drivexmil version pour winpe mais quand j'éssai de le lancer à partir de Winpe l'invite de commande ne me dit rien mais il n'y a pas de fenêtre qui s'ouvre :( 
quand j'ai créer le cd, j'avais un message d"erreur quand je faisais peimg /image=c:\winpe_base\mount /prep.
Je vais ressayer depuis le début, sinon je chooisirai un autre logiciel; bien que celui là me semblait bien...
24 Mai 2008 14:16:58

j'ai réessayer en supprimant winpe-base. J'ai tout refait depuis le début mais voila ce qu'il se passe :
c:\winpe_base>peimg /image=c:\winpe_base\mount /prep
Outil d´installation d'images PE pour Windows
Copyright (C) Microsoft Corporation. Tous droits réservés.

La commande /prep modifiera définitivement une image Windows PE qui ne
pourra donc plus être traitée. Les opérations suivantes :

- Installation ou désinstallation de fonctionnalités optionnelles
- Application de correctifs ou d'autres packages de mise en service
- Installation de modules linguistiques

ne seront pas possibles sur l'image préparée.

Pour continuer, entrez « oui ». Toute autre entrée quittera le programme.

Voulez-vous continuer ? imagex /capture /boot /compress max c:\winpe_base\mount
c:\winpe_base\iso\sources\boot.wim" "winpe perso"yes

PEIMG n'a pas pu terminer l'opération, code d'état 0x80004005.


une idée ?
merci
24 Mai 2008 14:45:22

rajoute l'option /f :
peimg /image=c:\winpe_base\mount /prep /f
24 Mai 2008 15:39:20

merci je n'ai plu d'erreur maintenant :) 
Je reteste...
24 Mai 2008 16:00:05

nan il veut pas :( ... le répertoire util qui est pourtant placé ici : C:\winpe_base\mount\util n'apparait pas dans winpe...


De plus, normalement je devrais pouvoir ouvrir dixml situer sur c:\ depuis winpe ce que je ne peut pas faire :( 
Il n'y a pas de moyen pour utiliser PE builer ?

Merci
25 Mai 2008 19:26:38

up ! :) 
Anonyme
20 Décembre 2008 22:42:29

J'ai plus de chance, je crois. J'ai suivi la procédure décrite plus haut par coca25 le 21/05/08.
J'ai bien créé le CD et je l'ai rebouté. Winpe s'exécute.

J'obtiens bien l'arborescence suivante :
- 1 rep avec Program Files
- 1 rep avec Users
- 1 rep avec Windows
- 1 rep avec util

Dans le rep util je retrouve bien les fichiers créés, c'est à dire ceux utiles pour DriveImage XML soit :
- diskmagn.msc
- dixml.chm
- dixml.exe
- dixml.htm
- dixml.inf
- dixml_nu2menu.xml
- vssserv.dll
- vssvista.dll
- vssxp.dll

mais à l'invite je frappe : X:\util\dixml.exe et il ne se passe rien ????

Qui a une idée ?
Merci

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS