Se connecter / S'enregistrer
Votre question

[Résolu] [Ubuntu] Modif des droits d'un DD externe ne fonctionne pas

Tags :
  • Ubuntu
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
21 Mai 2008 21:44:21

Bonjour à tous, je suis débutant sur Ubuntu

J'ai un DD externe en USB, que j'ai récemment formaté en FAT32 sous Linux (pour ne plus être en NTFS). Depuis, ce disque est inaccessible à tout le monde, même depuis windows, sauf à moi (qui suis le propriétaire apparemment).

Bref, je suis allé dans un terminal, je me suis placé dans le répertoire /media/ (mon disque est apparemment dans /media/disk) et j'ai mis :

sudo chmod -R u=rwx,g=rwx,o=rwx disk

Tout se passe bien, sauf que lorsque je fais ls -l il me met que seul moi (le propriétaire) possède rwx...bref rien n'a changé...

J'ai essayé cette commande sur le Cd Rom qui se trouve dans /media/cdrom0 et j'ai fait exactement la même chose...mais là ca a marché...(donc ça en vient pas de la commande)

Je voulais savoir si quelqu'un saurait me conseiller.


Merci.

Autres pages sur : resolu ubuntu modif droits externe fonctionne

22 Mai 2008 14:43:26

salut, chmod permet de modifier les permissions des fichiers/repertoires au niveau du système de fichiers et ca n'a aucun effet que ce soit sur des fichiers sur cd (lecture seul) ou une partition en fat32 (ne gère pas les permissions)

sous gnome, par défaut, une partition FAT32, montée par l'utilisateur a seulement les droits en écriture pour cet utilisateur
pour modifier ca, il te faut modifier les options de montage avec applications->système->editeur de configurtion avec la clé /system/storage/default_options/vfat/mount_options
ou en lancant:
gconftool-2 -s /system/storage/default_options/vfat/mount_options -t list --list-type=string [shortname=mixed,uid=,utf8,umask=000,exec,flush]

(1 seule ligne)

si la partition est déjà montée, démonte puis remonte

par contre, en ce qui concerne windows, c'est un autre souci, parce que comme dit avant, FAT32 ne gère pas les permissions et tout ce que tu peux faire sous linux dessus (au niveau droit) n'a aucune influence sous windows
22 Mai 2008 18:08:39

Apparemment, il refuse toujours de changer les permissions (qui sont nulles même pour root)..J'ai aussi soumis le pb à un habitué de Linux, mais ça n'a rien donné.

De toutes façons, il se trouve que je dois graver mes données, donc je pourrais formater le disque de nouveau. Y a t il une option importante à ne pas oublier pour que les droits soient libres pour tout le monde ?

Merci pour ton aide.
Contenus similaires
Pas de réponse à votre question ? Demandez !
22 Mai 2008 18:22:07

je suis aller trop vite dans le copie/coller, c'était umask=000 qu'il fallait mettre!
j'ai réedité.
22 Mai 2008 18:36:37

Un grand merci !!!

Ca marche nickel :D 
22 Mai 2008 18:44:51

:jap: 
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS