Votre question

Hibernation sous Ubuntu

Tags :
  • Ubuntu
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
25 Juin 2008 21:11:40

Bonjour à tous,

petit souci avec Ubuntu (8.04 Hardy Heron).

Lorsque je souhaite mettre l'ordi (Acer Aspire 1650) en mode hibernation, cela ne fonctionne pas.
L'écran devient noir, mais tout continue de tourner.
Lorsque je bouge la souris, je suis immédiatement sur la page me demandant mon mot de passe (pour revenir sur le bureau).

C'est un peu embêtant car je suis sans cesse obligé d'éteindre et de rallumer l'ordi :-(

Merci d'avance,
Lolepops

Autres pages sur : hibernation ubuntu

26 Juin 2008 17:21:12

Infos complémentaires
J'ai poussé mon alayse et le problème demeure.
En fait, l'ordi se met en hibernation quelques secondes (20, 30 ?), puis redémarre totalement.


suseX a dit :
http://doc.ubuntu-fr.org/veille_et_hibernation

tu devrais pouvoir trouver quelques tuyaux ;) 

Salut suseX
Je suis bien allé sur la page "Veille & hibernation" et le problème n'étant pas résolu, je me suis orienté ici : http://doc.ubuntu-fr.org/uswsusp

J'ai bien tout fait comme on me dit de faire, , mais j'en arrive au stade où le terminal me dit :
"s2disk: Could not stat the resume device file. Reason: No such file or directory"
et après, impossible de résoudre ce problème en suivant la marche à suivre.
Contenus similaires
26 Juin 2008 18:39:54

Ca donne ça lorsque je tape sudo blkid :

/dev/sda1: LABEL="ACER" UUID="2629-16F0" TYPE="vfat"
/dev/sda5: LABEL="ACERDATA" UUID="4117-1BDC" TYPE="vfat"
/dev/sda6: UUID="b3149653-2e53-4eff-95b2-1b1e6bfd7fed" TYPE="ext3"
/dev/sda7: TYPE="swap" UUID="1acc6377-b7fc-4c88-a5c7-75736686e94e"



Si je comprends bien, c'est ok pour la swap.
C'est la suite que j'ai du mal à comprendre. On dit de taper "sudo gedit /etc/fstab" pour modifier l'uuid correspondant Puis redémarrer l'ordinateur.

Une fois que le fichier s'ouvre dans l'éditeur de texte, je dois faire quoi ?

27 Juin 2008 12:58:58

poste ici le contenu de ce fichier
27 Juin 2008 13:02:31

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda6
UUID=b3149653-2e53-4eff-95b2-1b1e6bfd7fed / ext3 relatime,errors=remount-ro 0 1
# /dev/sda7
UUID=1acc6377-b7fc-4c88-a5c7-75736686e94e none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
27 Juin 2008 13:07:07

la swap c'est bon.

tu as bien installé pm-utils ?
29 Juin 2008 11:35:06

suseX a dit :

tu as bien installé pm-utils ?


J'ai vérifié avec Synaptic et pm-utils est bien installé.
Je l'ai même désinstallé et réinstallé, mais hibernation toujours déficiente ...
29 Juin 2008 11:40:15

je sèche :( 
30 Juin 2008 12:07:11

tu peux poster la sortie de
free

pour voir si ta swap est activée ou pas.

de même la sortie de:
grep resume /etc/uswsusp.conf

pour voir si la config de la swap pour uswsusp est bonne.
2 Juillet 2008 12:13:32

Sortie de free

total used free shared buffers cached
Mem: 1033900 787780 246120 0 56824 383376
-/+ buffers/cache: 347580 686320
Swap: 1188768 0 1188768


Sortie de grep resume /etc/uswsusp.conf

resume device = UUID=1acc6377-b7fc-4c88-a5c7-75736686e94e
2 Juillet 2008 15:59:48

modifie la ligne de /etc/uswsusp.conf par
resume device = /dev/sda7

et reessaie
2 Juillet 2008 20:16:49

J'ai compris la manip, mais par contre je n'arrive pas à enregistrer la modif du fichier uswusp.conf.
J'imagine qu'il faut être en mode root. Je vais essayer de chercher la solution.
2 Juillet 2008 21:23:15

sudo gedit /etc/uswsusp.conf
29 Août 2008 10:15:16

Après une longue absence, je reviens vers vous, car je me suis finalement décidé à persévérer et à trouver une solution à ce problème !

J'ai donc bien suivi toutes les manips, notamment la modif de la ligne de /etc/uswsusp.conf , mais j'ai toujours le même souci :
après quelques secondes (entre 5 et 10 je pense) où je crois que mon PC hiberne, il se relance et revient sur le bureau :-(

D'autres propositions d'action ?
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS