Se connecter / S'enregistrer
Votre question

Redirection IP avec iptables

Tags :
  • Serveur
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
9 Mars 2009 19:02:32

Salut tout le monde :) 

j'ai un problème là ou je travaille :whistle:  ça fait une semaine que je cherche sur le net et sur les forums pour trouver une solution mais ... :cry: 

je vous explique mon problème :

j'ai installé dernièrement un serveur Linux Fedora 8, sur le quel j'ai activé le forwarding pour permettre les utilisateur à accéder vers le net (ça marche sans problème).

le serveur Fedora a 2 interfaces :

- eth1 = 192.168.1.107/24 vers le routeur ADSL Sagem fast@3304 avec adresse IP 192.168.1.1
- eth0 = 192.168.2.106/24 vers le switch

j'ai installé un serveur VNC sur un poste dans notre LAN, l'adresse de ce serveur est 192.168.2.35.

ma demande c'est comment je peux faire pour que je puisse accéder à ce serveur depuis l'extérieur ???? :??: 

je sais qu'il faut ajouter des règles iptables afin de rediriger tous les trafics venant de eth1 avec le port 1701/1703 (ports de VNC) tcp et udp vers le serveur VNC, mais je suis débutant sur Linux et j'ai besoin de votre aide pour mettre ces règles :cry: 

j'espère que j'étais clair, et merci d'avance pour votre aide.

:hello: 

Autres pages sur : redirection iptables

9 Mars 2009 21:33:33

Iptables gère le firewall, pas les redirections.

Si les connections viennent du net, il faut d'abord ouvrir les ports sur le routeur Sagem car lui possède très certainement un Firewall actif.
Dans ce même routeur tu pourras régler sur quelle adresse seront renvoyés les paquets reçu sur les port 1701 et 1703, adresse qui sera vraisemblablement 192.168.2.35

Maintenant si tu as réglé le routeur sans firewall ou avec une DMZ sur le serveur linux, alors c'est une autre histoire...
10 Mars 2009 10:03:12

Je vous remercie d'abord pour votre réponse Bmax14 :hello: 

Avant d'installer le serveur Fedora, j'avais la même configuration que tu m'as proposé sur le routeur Sagem, et ça marchait parfaitement la connexion à distance à partir du net vers le PC 192.168.2.35.

- Ouverture des deux ports 1701 et 1703 / tcp et udp
- Renvoyer les paquets reçus vers l'adresse 192.168.2.35

Mais aprés la mise en place du pare feu sur ce serveur Fedora et l'intégration de ce dernier dans la structure de mon réseau, l'accès à distance par VNC à la machine est devenu impossible. je vous donne la le schéma du réseau:

Internet
|
|
Sagem ADSL (192.168.1.1)
|
|
Pare feu (eth0:192.168.2.106 eth1:192.168.1.107)
|
|
Switch
|
|
PC (192.168.2.35)

J'ai pas touché la configuration du routeur Sagem, et je croix qu'il faut ajouté des règles sur le pare feu afin de rediriger les paquets reçu sur les ports 1702 et 1703 du réseau 192.168.1.0/24 vers le réseau 192.168.2.0/24, et précisément vers le PC 192.168.2.35.

je confirme que le routage est bien activé sur le pare feu, et les PC de LAN arrivent sans problème à accéder au net en passant par le passerelle 192.168.2.106.


Merci :hello: 

Contenus similaires
10 Mars 2009 18:27:01

En ce cas, les paquets n'ont pas à être redirigés car le routeur s'en occupe déjà. Il "suffit" d'ouvrir les ports sur le pare-feu.

Pour ce faire, utilise ces commandes:
  1. iptables -A INPUT -p udp -i eth1 --dport 1701 -j ACCEPT
  2. iptables -A INPUT -p tcp -i eth1 --dport 1703 -j ACCEPT
  3. iptables -A INPUT -p udp -i eth1 --dport 1701 -j ACCEPT
  4. iptables -A INPUT -p tcp -i eth1 --dport 1703 -j ACCEPT

sur le serveur Linux.

Mais d'un autre côté, on peux se demander l'utilité d'avoir 2 firewall (routeur et pare-feu) l'un derrière l'autre...
10 Mars 2009 21:12:22

Merci Bmax14 :) 

je m'excuse d'abord d'avoir donner des faux ports pour le VNC, le VNC utilise le port 5900 et pas 1701 !!! j'ai pas fais attention :whistle: 

j'ai fais ce que vous m'avez demandé, j'ai configué le routeur Sager pour qu'il redirige les paquets vers 192.168.2.35, et j'ai ajouteé les régles iptables suivantes :

# iptables -A INPUT -p udp -i eth1 --dport 5900 -j ACCEPT
# iptables -A INPUT -p tcp -i eth1 --dport 5900 -j ACCEPT

mais toujours pas d'accès à distance :( 

Normalement quand je me connetce à disatnce par VNC, le routour redirige tous les paquets sur le port 5900 vers le serveur VNC 192.168.2.35, mais je croix que le routeur ne trouve pas cette adresse parce que il sont de deux réseaux différents (Serveur:192.168.2.0/24 et Routeur:192.168.1.0/24).

Routeur
192.168.1.1
192.168.1.0/24

Pare feu
eth1 : 192.168.1.107-192.168.1.0/24
eth0 : 192.168.2.106-192.168.2.0/24

Serveur VNC
192.168.2.35
192.168.2.0/24

Donc, je crois qu'il faut ajouter une autre règle ou plus pour rediriger les paquets qui viennent du routeur sur les ports 5900 et qui ont la destination 192.168.2.35, de réseau 192.168.1.0/24 au réseau 192.168.2.0/24, puis vers les Serveur VNC 192.168.2.35.

Merci :hello: 

13 Mars 2009 14:15:31

Si il est possible d'accéder au réseau extérieur (par exemple un site WEB) alors le routage devrais être bon à moins que le PC Pare-feu soit aussi un NAT ce qu'il ne devrait pas être.

À ce stade il serait pour de faire un peu d'écoute sur le réseau, avec Wireshark par exemple afin d'analyser les paquets et de voir ou ils se bloquent.
15 Mai 2009 18:50:30


j'ai même problème, mais je veut juste ce connecter a un serveur VNC sur PC dans un réseau LAN avec un routeur sagem 3304 via internet.
quoi je doit faire pour autoriser cette connexion via internet, et quoi comme configuration je doit mettre dans l'option Firewall du routeur sagem 3304 :??: 
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS