Votre question

Problème dhcpd.conf relai dhcp

Tags :
  • Time
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
10 Juin 2009 14:01:11

Bonjour, j'ai un léger problème dans la réalisation d'un relai dhcp, dans le fichier dhcpd.conf.
J'ai 2 sous réseau: 192.168.1.* et 192.168.2.*

mon fichier:
Citation :

subnet 192.168.1.0 netmask 255.255.255.0 {
option routers 192.168.1.1
option subnet-mask 255.255.255.0;
option domain-name-servers 192.168.1.1;
range 192.168.1.50 192.168.1.100
default-lease-time 3600;
max-lease-time 7200;
}

subnet 192.168.2.0 netmask 255.255.255.0 {
option routers 192.168.2.1
option subnet-mask 255.255.255.0;
option domain-name-servers 192.168.2.1;
range 192.168.2.50 192.168.2.100
default-lease-time 3600;
max-lease-time 7200;
}


L'objectif du srv dhcp est le suivant:

1 machine srv sur 192.168.1.*. La machine est connecté à un switch qui est connecté à un nortel 2430, qui fait un simulateur de LS avec un autre nortel 2430. La sortie du nortel 2430 doit avoir comme sous réseau 192.168.2.*. le nortel est relié à un switch cisco 2960g sur lequel sont connecté 2 pc.

PROBLEME:

Quand je lance le serveur dhcp, j'ai des semicolon expected pour les lignes que j'ai souligné.
Je pense à un problème de syntaxe pour la déclaration des 2 sous réseaux, le serveur ne doit pas savoir quels paramètres choisir.
Quelles sont les modifications à apporter pour que cela fonctionne ? Je tiens à préciser que si je retire le sous réseau 192.168.2.* du fichier, le dhcp adresse correctement les pc sur son sous réseau.
Merci pour vos réponses.

Autres pages sur : probleme dhcpd conf relai dhcp

10 Juin 2009 19:13:06

personne ?
m
0
l
11 Juin 2009 07:55:13

up :) 
m
0
l
Contenus similaires
11 Juin 2009 10:41:22

toujours personne ? Complément d'informations:

si je rajoute un ; à chaque ligne qui n'en a pas sauf le subnet, c'est à dire un truc comme:

Citation :
subnet 192.168.1.0 netmask 255.255.255.0 {
option routers 192.168.1.1;
option subnet-mask 255.255.255.0;
option domain-name-servers 192.168.1.1;
range 192.168.1.50 192.168.1.100;
default-lease-time 3600;
max-lease-time 7200;
}

subnet 192.168.2.0 netmask 255.255.255.0 {
option routers 192.168.2.1;
option subnet-mask 255.255.255.0;
option domain-name-servers 192.168.2.1;
range 192.168.2.50 192.168.2.100;
default-lease-time 3600;
max-lease-time 7200;
}


je n'ai plus de message d'erreur de semicolon... mais quand je redémarre le serveur avec la commande

Citation :

/etc/init.d/dhcp3-server restart

j'ai une erreur pour le démarrer, il me dit "check syslog for diagnostics."

avec


Citation :
tail /var/log/syslog


j'accède au log syslog.
Il me dit:

Citation :
No subnet déclaration for 192.168.1.1 (0.0.0.0)
Ignoring request on 192.168.1.1. If this is no what you want, please write a subnet declaration in your dhcpd.conf file for the network segment to which interface 192.168.1.1 is attached
Not configured to listen on any interfaces
m
0
l
11 Juin 2009 11:52:21



Bon, j'ai réussi :D 
la conf:

shared-network reseau {
subnet 192.168.1.0 netmask 255.255.255.0 {
interface eth0;
range 192.168.1.50 192.168.1.100;
default-lease-time 6000;
max-lease-time 7200;
option subnet-mask 255.255.255.0;
option time-offset -3600;
}
subnet 192.168.2.0 netmask 255.255.255.0 {
#interface eth0;
range 192.168.2.50 192.168.2.100;
default-lease-time 6000;
max-lease-time 7200;
option subnet-mask 255.255.255.0;
option time-offset -3600;
}
}

Seul problème, quand je met un pc en 192.168.2.*, il ne prend pas d'adresse ip, j'ai l'ip de Windows quand il ne trouve rien (169.254.....)
Le serveur dhcp étant démaré et fonctionant pour le sous réseau en .1.*, je souhaiterai savoir si le fichier de conf est réellement bon: je n'ai pas assigné d'interface pour le .2.*.
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS