Se connecter / S'enregistrer
Votre question

Probleme de boot linux-xp

Tags :
  • Boot
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
7 Juillet 2009 21:03:11

salut,


voila , j'utilise mint7 et j'avais absolument besoin d'utiliser un soft sur windows
j'ai donc installer un dd supplementaire sur mon pc , et j'ai installer xp

j'ai 4 dd sur mon pc , j'ai du debrancher mon dd avec mint7 pour brancher un lecteur disk et installer xp
et des que j'ai rebrancher le dd avec mint7 , il boot directement sur mint et mon dd xp n'apparais pas

je sais que c'est pas tres claire j'en suis desole :p 

je sais que je doit rajouter une ligne de texte quelque part pour afficher xp au demarage mais j'ai complètement oublier ou
et je ne trouve rien sur la toile

pouvez vous m'aider svp , c'est assez urgent

merci d'avance pour vos attention

Autres pages sur : probleme boot linux

7 Juillet 2009 21:45:24

en gros , y a pas un mode graphique pour mettre xp dans la sélection de boot de mint7(ubuntu)


merci
m
0
l
7 Juillet 2009 22:55:23

personne vraiment ?
m
0
l
Contenus similaires
Pas de réponse à votre question ? Demandez !
7 Juillet 2009 23:21:46

Salut,

Si j'ai bien compris tu voudrais pouvoir configurer GRUB en interface graphique plutot qu'en console ?
Si oui, tu trouveras certainement ton bonheur ici.

Bon courage.
m
0
l
7 Juillet 2009 23:29:02

salut , ton programme semble ne plus etre disponible

mais y a pas un soft du genre deja installer ? avec gparted ca peu pas se faire ?

merci pour ta reponse
m
0
l
7 Juillet 2009 23:37:20

Desole pour le lien effectivement il est mort...

Celui ci fonctionne je viens de le tester.
Avec Gparted je ne crois pas que tu puisse configurer un multi-boot...
Sans rien installer, a part en ligne de commande je pense qu'il n'y a pas d'autres solutions.
m
0
l
7 Juillet 2009 23:41:56

okay raimana , j'vais essayer ton programme et si ca marche pas je tenterai via la console
je connait pas grand chose la dedans mais j'ai trouver plusieurs site qui explique la démarche.
merci pour ton aide raimana :) 
m
0
l
8 Juillet 2009 00:03:59

ce qu'il faut changer : /boot/grub/menu.lst

rajouter (en adaptant) :

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sdaX
title Microsoft Windows XP Professionnel
rootnoverify (hdX,X)
savedefault
makeactive
chainloader +1
m
0
l
8 Juillet 2009 00:08:29

salut navyn
j'ai essaye via la console ,

su
ls /boot
nano /boot/grub/menu.lst

la j'ai une liste qui apparait et je suis totalement perdu
0o
m
0
l
8 Juillet 2009 00:19:01

le disk xp ne s'affiche pas dans la liste

## ## End Default Options ##

title Linux Mint 7 Gloria, kernel 2.6.28-11-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.28-11-generic root=/dev/sda1 ro quiet splash
initrd /boot/initrd.img-2.6.28-11-generic
quiet

title Linux Mint 7 Gloria, kernel 2.6.28-11-generic (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.28-11-generic root=/dev/sda1 ro single
initrd /boot/initrd.img-2.6.28-11-generic

title Linux Mint 7 Gloria, memtest86+
root (hd0,0)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST


??
m
0
l
8 Juillet 2009 00:21:30

navyn a dit :
ce qu'il faut changer : /boot/grub/menu.lst

rajouter (en adaptant) :

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sdaX
title Microsoft Windows XP Professionnel
rootnoverify (hdX,X)
savedefault
makeactive
chainloader +1




comment je fait pour savoir adapte les lignes de commande a mon probleme ?

je suis vraiment novice dans c'est truc desolé
m
0
l
8 Juillet 2009 00:39:39

La manip proposer par Navyn est correcte, tu dois a present ajouter son bout de code a la fin du fichier (ie. sudo gedit /boot/grub/menu.lst).

  1. title Windows
  2. rootnoverify (hdX,X)
  3. chainloader +1
Save and Reboot.

X determine le HDD/partition ou se situe ton installation de Windows, tu dois "adapter"/indiquer la valeur X qui correspond au HDD/partition ou se situe ton installation de Windows.
m
0
l
8 Juillet 2009 00:59:43

ok ok , donc je rajoute cette ligne de code apres

## ## End Default Options ##

title Linux Mint 7 Gloria, kernel 2.6.28-11-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.28-11-generic root=/dev/sda1 ro quiet splash
initrd /boot/initrd.img-2.6.28-11-generic
quiet

title Linux Mint 7 Gloria, kernel 2.6.28-11-generic (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.28-11-generic root=/dev/sda1 ro single
initrd /boot/initrd.img-2.6.28-11-generic

title Linux Mint 7 Gloria, memtest86+
root (hd0,0)
kernel /boot/memtest86+.bin
quiet

c'est bien ca ?

et ensuite pour connaitre le n° de mon dd je peux m'y prendre comment ?

quand je regarde avec Gparted il indique mon disque avec se nom /dev/sb1 , c'est ca le n° ?

merci pour ta pacience :p 
m
0
l
8 Juillet 2009 01:09:03

Si malgres tout, tu ne parviens pas a configurer manuellement GRUB, il existe un autre soft qui te permet de configurer grub via GUI il s'agit de start up manager (ie. sudo apt-get install startupmanager), simple et intuitif.

Tu trouveras un tuto ici (en anglais)...
m
0
l
8 Juillet 2009 01:21:28

Pour le code oui c'est bien a la fin de ca.

Autrement pour connaitre le chemin de ton HDD ou est installer Windows, en console tape la commande suivante :

  1. fdisk -l
et si tu peux poster ici ce qui s'affiche.

m
0
l
8 Juillet 2009 01:41:50

okay , voila se qu'il me donne

Utilisation : fdisk [-l] [-b TAILLE] [-u] périphérique
i.e.: fdisk /dev/hda (pour le premier disque IDE)
ou: fdisk /dev/sdc (pour le 3e disque SCSI)
ou: fdisk /dev/eda (pour le 1er disque PS/2 ESDI)
ou: fdisk /dev/rd/c0d0 ou: fdisk /dev/ida/c0d0 (pour des périphériques RAID)

:) 
m
0
l
8 Juillet 2009 01:50:16

hmmm j'attendais quelques chose d'un peu different, chez moi fdisk -l me donne ca :


Disk /dev/sda: 100.0 GB, 100030242816 bytes
255 heads, 63 sectors/track, 12161 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System

/dev/sda1 * 1 1147 9213246 83 Linux
/dev/sda2 1148 4334 25599577+ 83 Linux
/dev/sda3 4335 4399 522112+ 82 Linux swap / Solaris
/dev/sda4 4400 12161 62348265 5 Extended
/dev/sda5 4400 12161 62348233+ 83 Linux


Tu n'aurais plutot quelque choses comme ca ?
Comme tu peux le voire il doit etre indiquer a quel type de system a device boot appartiens.
m
0
l
8 Juillet 2009 01:56:42

si je tape fdisk -1 ca ne donne :fdisk: invalid option -- '1'
je t'es donner le resulta que ca donne avec fdisk :) 

bon j'ai enfin window dans ma liste de boot , j'ai (pour essayer) donner le n) hd0,1 a mon dd mais ca ne semble pas etre ca




m
0
l
8 Juillet 2009 02:07:11

hmm juste pour etre certains, as tu effectuer la commande fdisk avec l'argument -1 ou -l (la lettre L)?
Le dernier arguments -l est le bon.

Sinon, oui tu as juste le titre Windows dans GRUB, mais le chemin d'acces a ton disque est incorrecte.

Sais tu sur quel disque tu as installer Windows ? IDE, SCSI... ?
m
0
l
8 Juillet 2009 02:11:05

okay , c'est moi qui suis con , j'ai oublier d'etre en root

voila le resulta ,

Disque /dev/sda: 81.9 Go, 81964302336 octets
255 têtes, 63 secteurs/piste, 9964 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0xee63ee63

Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 * 1 9553 76734441 83 Linux
/dev/sda2 9554 9964 3301357+ 5 Etendue
/dev/sda5 9554 9964 3301326 82 Linux swap / Solaris

Disque /dev/sdb: 40.0 Go, 40020664320 octets
255 têtes, 63 secteurs/piste, 4865 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0x1e3e28be

Périphérique Amorce Début Fin Blocs Id Système
/dev/sdb1 * 1 4864 39070048+ 7 HPFS/NTFS

Disque /dev/sdc: 81.9 Go, 81964302336 octets
255 têtes, 63 secteurs/piste, 9964 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0x38581246

Périphérique Amorce Début Fin Blocs Id Système
/dev/sdc1 1 9964 80035798+ 7 HPFS/NTFS

Disque /dev/sdd: 160.0 Go, 160041885696 octets
255 têtes, 63 secteurs/piste, 19457 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0x2725bf40

Périphérique Amorce Début Fin Blocs Id Système
/dev/sdd1 * 1 19457 156288321 7 HPFS/NTFS

Disque /dev/sde: 8086 Mo, 8086617600 octets
255 têtes, 63 secteurs/piste, 983 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0x91f72d24

Périphérique Amorce Début Fin Blocs Id Système
/dev/sde1 * 1 984 7897056 b W95 FAT32
La partition 1 a des fins physique/logique différentes:
phys=(982, 254, 63) logique=(983, 36, 12)

mon dd xp est un disk ata de 40go ide

Disque /dev/sdb: 40.0 Go, 40020664320 octets
255 têtes, 63 secteurs/piste, 4865 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0x1e3e28be

celui ci
m
0
l
8 Juillet 2009 02:36:44

Ok kwl on y arrive,

maintenant edit GRUB au final tu dois avoir quelques choses comme ca :

## ## End Default Options ##

title Linux Mint 7 Gloria, kernel 2.6.28-11-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.28-11-generic root=/dev/sda1 ro quiet splash
initrd /boot/initrd.img-2.6.28-11-generic
quiet

title Linux Mint 7 Gloria, kernel 2.6.28-11-generic (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.28-11-generic root=/dev/sda1 ro single
initrd /boot/initrd.img-2.6.28-11-generic

title Linux Mint 7 Gloria, memtest86+
root (hd0,0)
kernel /boot/memtest86+.bin
quiet

title Windows
rootnoverify (hd1,0)
makeactive
chainloader +1


Save and reboot.

Dis moi ce que sa donnes.

[Edit] : je viens de corriger la derniere partie ce n'est pas sdb mais hd1 excuse moi.
m
0
l
8 Juillet 2009 12:34:24

salut raimana , j'ai essayer avec (hd1,0)(hd2,0)(hd3,0) mais a chaque fois ca reste bloquer sur starting up ...
je sais pas si je peux continuer avec (hd 4 ......5...6 ... )

merci raimana
m
0
l
8 Juillet 2009 13:20:01

je sais pas si c'est le cas dans Linux Mint, mais dans Ubuntu en choisissant recovery mode on à un transfigurateur automatique de grub.

Sinon nicotelsa tu peut monter jusqu'à hd5; sda=hd0; sdb=hd1; etc...
si il y a un chiffre avec : sda1=hd0,0; sda2=hd0,1; etc...
m
0
l
8 Juillet 2009 13:21:07

je vais essaye ca navyn
m
0
l
8 Juillet 2009 13:25:51

y a bien se que tu dit mais ca remet juste le grub a se qu'il etait au debut navyn , windows a disparu de la liste :( 
m
0
l
8 Juillet 2009 14:03:10

navyn a dit :
je sais pas si c'est le cas dans Linux Mint, mais dans Ubuntu en choisissant recovery mode on à un transfigurateur automatique de grub.

Sinon nicotelsa tu peut monter jusqu'à hd5; sda=hd0; sdb=hd1; etc...
si il y a un chiffre avec : sda1=hd0,0; sda2=hd0,1; etc...



okay j vais tester merci navyn
m
0
l
8 Juillet 2009 22:29:49

okay , bon voila j'ai essayer toute les combinaisson possible mais rien
j'ai juste eu pour (hd3) un ecran grezzillant blanc 0o

mais j'ai trouver une solution alternative/con ,
via le bios avec le choix de dd de boot
j'appuie sur F11 au demarage et je selectionne mon dd xp , ca boot , c'est magnifique


un grand merci quand meme pour vos reponse et votre pacience a tout les deux ,

peace les gars
m
0
l
8 Juillet 2009 23:28:45

Salut, as tu essayer de configurer GRUB avec start-up manager ou kgrubeditor ?

Peux tu poster ici ce que te renvoi le fichier /boot/grub/device.map.

Bon courage.

[EDIT] : Ton disque IDE est il en Master ?
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS