Se connecter / S'enregistrer
Votre question

[HELP] Probleme avec commande robocopy

Tags :
  • Disque dur externe
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
30 Décembre 2009 15:00:28

Bonjour,

J'ai lancé le backup d'un disque dur externe, dont une partie des fichiers est partagé sur un réseau local, sur une autre DD externe, comme prévu, à l'aide de cette commande
Robocopy J:\SERVEUR K:\backup\serveur /MIR
et ça coince sur un fichier .jpg à 16%. Ça met "le délai de temporisation de sémaphore a expiré" et ça réessaye et réessaye. Ca tourne en boucle depuis une bonne heure! Que faire?

Merci d'avance pour votre aide.

Voir ci-dessous:

http://img96.imageshack.us/img96/1995/backupproblem.png..." alt="" class="imgLz frmImg " />

Autres pages sur : help probleme commande robocopy

30 Décembre 2009 15:04:30

Je n'ai pas accès à l'image (à cause du proxy du boulot...).
Tu arrives à recopier ce fichier manuellement dans les même conditions ?

Il se peut que ce fichier ait été verrouillé par un processus quelconque, ou bien qu'il soit sur un secteur défectueux du disque.
m
0
l
30 Décembre 2009 15:08:22

Je ne sais pas, tant que le backup tourne (en rond) je n'arrive pas à accéder aux fichiers du disque dur externe. Dois-je arrêter la sauvegarde? Si oui, comment?

Merci
m
0
l
Contenus similaires
30 Décembre 2009 15:11:47

Si il tourne dans le vide, oui. Il ya peut-être un moyen de bypasser ce fichier. Tu n'as pas d'options 'Arrêter' ou 'Ignorer' dans ton logiciel ?
m
0
l
30 Décembre 2009 15:18:33

Non, ce n'est pas un logiciel mais une commande windows type c:\tools\robocopy
A part éteindre le DD je ne vois pas comment arrêter la sauvegarde. Mais comme ce DD remplace un autre qui a cessé de fonctionner, et qu'on a failli perdre tous nos fichiers, je n'ai pas envie de risquer de tout perdre encore une fois. Si je l'éteins, ça craint ou pas pour les fichiers?

Merci
m
0
l
30 Décembre 2009 15:24:56

OK J'ai vu le tools.
A priori, pas grand chose à faire, à part tuer la tache dans le gestionnaire des tâches.
Auquel cas, la sauvegarde sera fort probablement inexploitable.
m
0
l
30 Décembre 2009 15:38:57

J'ai essayé mais impossible d'ouvrir le gestionnaire des tâches, ordi saturé. J'ai éteins le DD et rallumé. Tout est intact, ouf! Mais pour ma sauvegarde, tant pis. J'ai l'impression qu'un truc cloche avec la commande.
Une idée? Merci pour ton aide :) 
m
0
l
30 Décembre 2009 15:41:02

Il faudrait s'intéresser au fichier sur lequel ça a bloqué. Est-ce que tu peux le copier manuellement sans problème ? Est-ce que tu peux le sauvegarder avec l'outil de sauvegarde de base de Windows ?
m
0
l
30 Décembre 2009 15:48:11

Je l'ai copié sans probleme sur le bureau. La sauvegarde de base de Windows? Je connais pas, dsl, c quoi?
m
0
l
30 Décembre 2009 15:55:43

Démarrer - Programmes - Accessoires - Outils systèmes - Utilitaire de sauvegarde.

Dans l'assistant, tu demandes à sauvegarder uniquement les fichiers que tu choisis, puis tu sélectionnes uniquement ton fichier. Tu lui dis ensuite où placer la sauvegarde, et c'est bon.

En fait, cet outil est peut-être d'avantage adapté à tes besoins que Robocopy. A toi de voir...
m
0
l
30 Décembre 2009 16:09:33

Je fais la sauvegarde sur ce fichier sur le bureau, avec l'assistant, pas eu de problème.
m
0
l
30 Décembre 2009 16:16:01

j'ai fais une vérification d'erreur sur le DD, rien. Je fais une analyse pour la défragmentation.
En fait, mercredi dernier, le DD qui nous servait de serveur a planté. On a donc acheté un nouveau DD et copié la dernière sauvegarde dessus. Elle datait un peu et j'ai récupéré ou mis à jour ce qui manquait. Je voulais sauvegarder à nouveau pour avoir une version mise à jour. Peut-être y a-t-il eu un problème quand j'ai copié la dernière sauvegarde sur ce DD?
m
0
l
30 Décembre 2009 16:16:51

Et si te tentes le diable, et que tu refais un essai avec Robocopy ?

L'idée étant de vérifier si l'outil robocopy présente une faiblesse, ou si la tentative précédente était tombé sur un verrouillage ponctuel.
m
0
l
30 Décembre 2009 16:16:54

pas de défragmentation nécessaire. taille de cluster 4%
m
0
l
30 Décembre 2009 16:18:23

ok, je réessaye.
m
0
l
30 Décembre 2009 16:21:18

j'ai lancé l'outil robocopy depuis executer et non depuis le raccourci que j'avais sur le bureau et pour l'instant, ça a l'air de marcher nickel
m
0
l
30 Décembre 2009 16:33:47

OK on peut donc dire que le fichier incriminé était verrouillé ponctuellement par un process quelconque.

L'essentiel étant que tu aies une sauvegarde valide en fin de course.
m
0
l
30 Décembre 2009 16:37:00

C clair. Je n'utiliserai plus le raccourci, mais directement la commande. Au moins ça marche :) 
Mille merci !
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS