Votre question

XP endommagé, réparation ou formatage impossible

Tags :
  • Restauration système
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
21 Janvier 2010 11:08:10

Bonjour à tous :hello: 

Nouveau sur le forum, je viens susciter l'aide d'utilisateurs aguerris pour le néophyte que je suis.

Voici mon problème :

Depuis un certain temps (environ une semaine après l'installation d'un routeur Wifi pour le laptop de ma femme), mon PC de bureau accuse de gros dysfonctionnements, à savoir :

- Internet Explorer : Se ferme subitement (bien souvent avant même que la page se soit chargée complètement)

- L'ajout/suppression de programmes : inopérant, je reçois le message suivant "Impossible d'accéder au service windows installer. Ceci peut se produire si vous exécutez windows en mode sans échec. Contactez..."

- La restauration système : inopérante. S'affiche le message suivant "Aucune partition système n'a été trouvée"

- La répararation de windows XP (service pack 2 édition familiale) avec CD-Rom original : même message que pour la restauration système.

- Le boot(age?) sur le CD de windows en modifiant les paramètres du BIOS : le PC me demande quand même d'appuyer sur une touche pour démarrer du CD, ce que je fais mais le PC ne prend pas en compte mes ordres et démarre de façon habituelle.

Du coup, j'ai tenté un peu toutes les différentes options de démarrage qui s'offraient à moi mais tout reste inchangé sauf en mode "défaut optimisé" où là l'ordinateur n'affiche plus rien.

Tous les fichiers à sauvegarder sont à présent sur un disque dur externe :D  ,
j'espérais donc formater le disque dur C (qui est d'ailleurs partitionné, la partie D est à présent vide et je ne sais ni ne parviens pas à installer XP dessus).

J'ai donc essayé de plusieurs façons (par le poste de travail puis par l'invite de commandes comme cités dans certains posts).
Hélas, le formatage de C ne fonctionne pas, le message suivant s'affiche "Windows ne peut pas formater ce lecteur. Quittez tous les utilitaires sur disque ou tous les autres programmes utilisant ce lecteur et vérifiez qu'aucune fenêtre n'affiche le contenu du lecteur. Essayez de formater à nouveau"

Je m'en remets donc à vous tous qui savez sans doute remédier au problème et qui peut-être sauriez m'expliquer comment y pallier.

NB : Ce n'est évidemment pas moi qui ai partitionné mon disque dur en deux parties, je n'en aurais pas eu les compétences.

Je suis connecté depuis le PC portable, qui lui fonctionne encore à peu près...

Merci d'avance, ne serait-ce que d'avoir pris le temps de lire ce long post.

Ludo

Autres pages sur : endommage reparation formatage impossible

21 Janvier 2010 11:12:10

Salut,
Commence par vérifier l'intégrité des fichiers systèmes. Fais 'Démarrer - Executer', et sur la ligne de commandes, tapes : SFC /SCANNOW.

Ce type de comportement peut également être lié à une infection virale. Il serait bon que tu scannes ton disque avec un antivirus fonctionnel et à jour.
m
0
l
21 Janvier 2010 11:14:34

Bonjour,

Citation :
Aucune partition système n'a été trouvée"


Essaie ceci: Démarrer / clic droit sur poste de travail puis Gérer. Ensuite dans l'arborescence de gauche, repère gestion des disques et fait nous un imprim écran.

Bonne journée!
m
0
l
Contenus similaires
21 Janvier 2010 11:22:31

accessdenied a dit :
Salut,
Commence par vérifier l'intégrité des fichiers systèmes. Fais 'Démarrer - Executer', et sur la ligne de commandes, tapes : SFC /SCANNOW.

Ce type de comportement peut également être lié à une infection virale. Il serait bon que tu scannes ton disque avec un antivirus fonctionnel et à jour.



Merci, tu es super rapide !

J'ai lancé l'opération sfc /scannow mais il me semble que je l'avais déjà effectué hier ou avant hier et ça n'avait rien donné mais je te tiens au courant dès que c'est terminé. Quant à l'antivirus (je pense aussi que c'est un virus), j'ai analysé avec norton 2008 qui est à jour et Avast. Je voulais tenter avec d'autres programmes éventuels mais je ne peux plus hélas installer de nouveaux composants sur mon PC (toujours le problème de windows installer)
m
0
l
21 Janvier 2010 11:25:44

Citation :
j'ai analysé avec norton 2008 qui est à jour et Avast
ne me dis pas que tu utilises 2 antivirus?
m
0
l
21 Janvier 2010 11:26:07

tibo22 a dit :
Bonjour,

Citation :
Aucune partition système n'a été trouvée"


Essaie ceci: Démarrer / clic droit sur poste de travail puis Gérer. Ensuite dans l'arborescence de gauche, repère gestion des disques et fait nous un imprim écran.

Bonne journée!



Dès que le SFC /scannow sera terminé (oui je suppose que je ne peux pas tout faire en même temps), je ferai ce que tu m'as suggéré par contre pour le rapport comment je ferai pour l'afficher sur le forum ? Je suppose qu'il me faudra l'enregistrer sous un fichier paint mais après ? Je pourrai la joindre avec l'option insérer une image ? Merci
m
0
l
21 Janvier 2010 11:28:44

Pour l'image: effectivement avec Paint. Tu upload ton image sur un site qui le permet (ex: imageshack.us)
Tu copie-colle le lien sur le forum et nous y aurons accès
m
0
l
21 Janvier 2010 11:29:44

tibo22 a dit :
Citation :
j'ai analysé avec norton 2008 qui est à jour et Avast
ne me dis pas que tu utilises 2 antivirus?


Non je n'ai toujours eu que norton mais suite à ce problème j'ai réussi à faire un scan avec Avast car je ne savais franchement pas trop quoi faire... Est-ce une si grossière erreur ? Je pensais pourtant bien faire... dis-donc ça prend du temps ce SFC / scannow, c'est normal ? :) 
m
0
l
21 Janvier 2010 11:30:49

Essaye ceci : Fais un clic droit sur l'icône de ton poste de travail - gérer. Dans la MMC qui apparaît, va dans services et applications, puis dans services en dessous.

Repère le service Windows Installer. Il n'est pas nécessaire qu'il soit démarré, mais vérifie qu'il n'ait pas été désactivé. Si tel est le cas, repasse le en manuel. (C'est pas une recette miracle, juste un check).
m
0
l
21 Janvier 2010 11:31:48

SFC / scannow permet de vérifier et de réparer les fichiers systèmes endommagés, donc oui cela peut prendre du temps ;) 
m
0
l
21 Janvier 2010 11:34:10

tibo22 a dit :
Citation :
j'ai analysé avec norton 2008 qui est à jour et Avast
ne me dis pas que tu utilises 2 antivirus?


Oups, désolé, j'ai peut-être dit une bêtise, ça ne serait pas avast mais ad aware car je ne trouve pas avast sur mon ordi.
m
0
l
21 Janvier 2010 11:36:55

Je te propose un truc: télécharge Antivir sur un site quelconque et dégage moi ad-aware ainsi que norton. Install Antivir et fait un scan. Cet antivirus est gratuit et un des meilleurs
m
0
l
21 Janvier 2010 11:39:20

accessdenied a dit :
Essaye ceci : Fais un clic droit sur l'icône de ton poste de travail - gérer. Dans la MMC qui apparaît, va dans services et applications, puis dans services en dessous.

Repère le service Windows Installer. Il n'est pas nécessaire qu'il soit démarré, mais vérifie qu'il n'ait pas été désactivé. Si tel est le cas, repasse le en manuel. (C'est pas une recette miracle, juste un check).


Apparemment il était bien en manuel et démarré. Par contre là, mon ordi s'est éteint tout seul , je ne sais pas si il a eu le temp sd'effectuer le scan now en entier
m
0
l
21 Janvier 2010 11:43:03

tibo22 a dit :
Je te propose un truc: télécharge Antivir sur un site quelconque et dégage moi ad-aware ainsi que norton. Install Antivir et fait un scan. Cet antivirus est gratuit et un des meilleurs


Je ne pourrai pas car comme dit précédemment, je ne peux plus ni ajouter, ni supprimer d'autres programmes... Puis je dois d'avord relancer sfc/ scannow car l'ordi a planté et s'est éteint de manière inopinée. Il m'a fallu couper carrément la tension pour pouvoir le redémarrer.
m
0
l
21 Janvier 2010 11:43:52

Autant pour moi. Postes nous le lien de l'imprim ecran lorsque tu auras uploadé l'image :) 
m
0
l
21 Janvier 2010 11:56:29

Hé bien dites-donc, je ne sais pas trop à quoi sert sfc/scannow mais ça doit bouffer beaucoup de ressources, l'ordi mouline sacrément. Ca m'ennuie de vous faire attendre autant mais je n'ose pas trop lui demander quoi que ce soit d'autre de peur qu'il ne s'éteigne de nouveau... A ben, pas de bol, il vient de s'éteindre encore une fois, par contre, là, il redémarre tout seul... Est-il possible que ce soit un virus qui empèche le PC de mener à bien le scannow ?
m
0
l
21 Janvier 2010 12:10:27



Voilà donc l'imprim écran de la gestion des disques...

m
0
l
21 Janvier 2010 12:43:15

Petite précision, il ne se crée plus du tout de point de restauration, d'ailleurs, ils ont tous disparus.

De plus, quand je vais dans gestionnaires de périphériques, il me met un point d'exclamation sur le contrôleur SCSI et RAID suivant : APH84P25 IDE controller
fabricant (Standard mass storage controllers) sur bus d'E/S étendu.
Il me dit que Windows ne peut pas charger le périphérique de ce matériel. Ce pilote est peut-être endommagé ou absent.

Quant à SFC /scannow, l'ordi ne peut absolument pas l'exécuter, il s'éteint automatiquement durant le processus.
m
0
l
21 Janvier 2010 13:20:56

Pour info, la commande SFC permet de vérifier l'intégrité des fichiers systèmes. Il vérifie donc l'ensemble des fichiers systèmes afin de vérifier qu'ils sont tous présents et non corrompus. Le paramètre /scannow ordonne une execution immédiate. C'est donc normal que ça prenne du temps et de la ressource.
m
0
l
21 Janvier 2010 13:26:14

Oui je comprends cela, hélas comme dit précédemment, le PC refuse catégoriquement d'effectuer l'opération. Si c'est le seul moyen de rétablir mon système alors je crains d'être dans une impasse...
Est-il possible d'installer windows XP sur la deuxième partition de l'ordi et ainsi de faire fonctionr l'ordi sur cette dernière ? Ca pourrait simplifier les choses non ?
m
0
l
21 Janvier 2010 13:28:26

Oui, c'est toujours possible. L'install d'XP le permet. Tout comme il te permet d'effectuer une réparation de l'OS existant, ce qui peut être plus efficace qu'SFC qui ne fait que checker les fichiers systèmes.
m
0
l
21 Janvier 2010 13:34:48

ah intéressant, mais alors quelle serait alors la démarche à suivre ? Je ne sais pas si tu as vu mais dans la gestion des disques, les 2 partitions du disque dur (C et D) n'apparaissent pas. Est-ce normal ?
En fait il me faudrait la solution la plus potentiellement réalisable aux vues des problèmes déjà rencontrés merci.
m
0
l
21 Janvier 2010 15:34:13

Il te faudra booter depuis le CD de Windows, comme pour refaire l'install. Il verra qu'il y a une version déja installé et te proposera de la réparer.

Sinon, tu poursuis pour faire une nouvelle install. Au moment de la question sur le formatage du disque, tu demandes à ne pas formater. Il te faudra juste choisir un répertoire d'installation autre que \Windows.
m
0
l
21 Janvier 2010 15:44:56

accessdenied a dit :
Il te faudra booter depuis le CD de Windows, comme pour refaire l'install. Il verra qu'il y a une version déja installé et te proposera de la réparer.

Sinon, tu poursuis pour faire une nouvelle install. Au moment de la question sur le formatage du disque, tu demandes à ne pas formater. Il te faudra juste choisir un répertoire d'installation autre que \Windows.



Malheureusement, j'ai déjà tenté ça or, le cd se met bien à tourner au démarrage mais le PC me demande de taper sur une touche pour démarrer par le CD. Or, il ne capte rien quand j'appuie sur les touches. Du coup il continue à démarrer comme si aucun cd n'était dans le lecteur. :( 
Il ne me propose donc jamais de réparer. Quant à faire une nouvelle installation, on a vu plus haut que le PC était dans l'impossibilité de l'effectuer (pas de partition système trouvée) On tourne en rond lol :pt1cable: 
Je commence à désespérer sniff...
m
0
l
21 Janvier 2010 15:47:29

Euh, la j'avoue c'est dur... Dans la console tapes format c: tu seras tranquille comme ca...si ça marche...
m
0
l
21 Janvier 2010 15:47:47

Oups... Et au démarrage de la machine, tu arrives à accéder au bios ou aux autres fonctions ? Si tu appuies sur Verr Num ou la touche de blocage des majuscules, les leds s'affichent ? Parce que si à ce niveau là ça répond pas, il faut envisager un problème de clavier.
m
0
l
21 Janvier 2010 15:56:31

accessdenied a dit :
Oups... Et au démarrage de la machine, tu arrives à accéder au bios ou aux autres fonctions ? Si tu appuies sur Verr Num ou la touche de blocage des majuscules, les leds s'affichent ? Parce que si à ce niveau là ça répond pas, il faut envisager un problème de clavier.


Au démarrage j'ai effectivement accès au bios. Le clavier n'est pas un clavier d'origine , c'est un clavier microsoft. Il fonctionne parfaitement mais on dirait que le PC ne reconnait les appuis sur les touches que pour le bios lors du démarrage... mais je me demande bien quoi faire dans le bios, y aurait-il un moyen de gruger par ce biais ?
m
0
l
21 Janvier 2010 16:01:47

accessdenied a dit :
Oups... Et au démarrage de la machine, tu arrives à accéder au bios ou aux autres fonctions ? Si tu appuies sur Verr Num ou la touche de blocage des majuscules, les leds s'affichent ? Parce que si à ce niveau là ça répond pas, il faut envisager un problème de clavier.



Bon je viens de refaire un test, le clavier semble ne pas fonctionner précisément à l'unique moment où le pc me demande de taper sur un touche pour démarrer du cd... avant ça il fonctionne, après aussi mais pas pendant... Croyez-vous vraiment que ça puisse venir du clavier ?
m
0
l
21 Janvier 2010 16:03:03

C'est fort possible et ce serait très ***! Essaies donc un clavier différent :) 
m
0
l
21 Janvier 2010 16:06:00

tibo22 a dit :
Euh, la j'avoue c'est dur... Dans la console tapes format c: tu seras tranquille comme ca...si ça marche...


pour ce qui est de formater en passant par la console, j'ai eu un bref message du style : pour formater utiliser /(3 lettres comme SFC ou je ne me souviens plus) et la fenêtre s'est fermée. Si je réessaie de lancer l'opération, la fenêtre se ferme aussitôt ouverte sans que je ne puisse rien y lire
m
0
l
21 Janvier 2010 16:08:55

tibo22 a dit :
C'est fort possible et ce serait très ***! Essaies donc un clavier différent :) 



Normalement ma femme devrait me ramener un clavier du boulot pour un essai ce soir, je vous tiendrai au courant mais je pencherais plus pour ce satané virus que pour un problème de clavier. En tout cas si ça ne fonctionne pas, je devrais sans doute jeter l'éponge. Merci quand même et si qqn à une autre idée, qu'il me la fasse savoir, sait-on jamais :sol: 
m
0
l
21 Janvier 2010 22:11:15

Me revoici donc. Après essai avec un autre clavier, je parviens maintenant à booter sur le cd de windows XP family. L'ennui est que j'ai tenté de réparer ma version de windows et que l'ordi s'est arrêté comme lors des tentatives de récupération avec SFC /scannow.

Que faire à présent ? Tenter d'installer XP sur la 2nde partition (D:)  du disque dur ? Je me dis que si je fais ça, je serai peut-être plus tranquille si j'ai à formater a 1ère partition (C:) . Par contre comment fait-on pour que l'ordi démarre à partir de D ? Ca se fait pas tout seul je présume... Si vous pouviez m'indiquer la marche à suivre, ce serait super sympa de votre part. Merci
m
0
l
21 Janvier 2010 22:22:03

Salut,
Effectivement, tu peux tenter l'install sur D: ça ne posera aucun problème.
Une fois l'OS installé, tu risques d'avoir un menu de démarrage te demandant de choisir sur quel OS démarrer. Choisis celui qui t'es proposé par défaut, c'est forcément le dernier installé.
m
0
l
21 Janvier 2010 22:35:49

accessdenied a dit :
Salut,
Effectivement, tu peux tenter l'install sur D: ça ne posera aucun problème.
Une fois l'OS installé, tu risques d'avoir un menu de démarrage te demandant de choisir sur quel OS démarrer. Choisis celui qui t'es proposé par défaut, c'est forcément le dernier installé.


Hé bien voilà, j'ai installé xp sur D par contre, au démarrage, l'ordi ne m'a rien demandé et j'ai retrouvé la configuration que j'ai sur C. A mon avis ça n'a rien changé du coup.

Ah ! Je viens de parvenir à supprimer ad aware alors que je ne pouvais pas auparavant. c'est cool !
par contre j'ai toujours le même souci avec internet explorer... C'est à n'y rien comprendre.
m
0
l
21 Janvier 2010 22:43:52

Juste par curiosité, tu pourrais faire 'Démarrer, Executer', là tu tapes : notepad c:\boot.ini

Et nous dire ce que ce fichier te raconte de beau ?

boot.ini, c'est le fichier de config qui détermine quel OS utiliser, celui qui doit faire apparaître le menu dont je te parlais plus haut.
m
0
l
21 Janvier 2010 23:09:47

accessdenied a dit :
Juste par curiosité, tu pourrais faire 'Démarrer, Executer', là tu tapes : notepad c:\boot.ini

Et nous dire ce que ce fichier te raconte de beau ?

boot.ini, c'est le fichier de config qui détermine quel OS utiliser, celui qui doit faire apparaître le menu dont je te parlais plus haut.


voici donc ce que nous dit boot.ini :

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP dition familiale" /noexecute=optin /fastdetect


Pour moi, c'est du chinois... Mais je suppose que ça va te parler beaucoup plus qu'à moi. :D 
m
0
l
21 Janvier 2010 23:14:39

Je voulais juste vérifier. C'est comme si il n'y avait qu'un seul Windows d'installé. Tu es sûr d'être sur D: ?
m
0
l
21 Janvier 2010 23:17:35

accessdenied a dit :
Je voulais juste vérifier. C'est comme si il n'y avait qu'un seul Windows d'installé. Tu es sûr d'être sur D: ?


Ben non, moi je ne suis sûr de rien, au contraire, j'ai des doutes d'être sur D puisque j'ai retrouvé toute mon ancienne configuration. En tout cas j'ai toujours le virus parce que je ne peux toujours pas ouvrir internet explorer... Mais je ne sais pas comment faire pour passer sur D:
m
0
l
27 Janvier 2010 09:24:23

Salut à tous, me revoilà après plusieurs jours de tentatives plus ou moins fructueuses.

Après avoir emprunté le clavier d'une amie, j'ai enfin pu tenter une réinstallation de XP sous "D" donc. Malheureusement ça n'a pas fonctionné, par contre ça a dû apporter des améliorations à ma version actuelle sous "C" qui est cependant toujours daubée. J'ai suite à cela eu de nouveau accès à "ajout/suppresion de programmes". J'en ai profité pour supprimer "bit defender" et installer "avast". Après scan (3 virus trouvés puis supprimés) j'ai eu de nouveau accès à internet sans que la page se ferme toutes les 2 secondes. Cependant les autres fonctionnalités de windows précitées en début de post étaient toujours inopérantes. Après une mise à jour windows automatique hier, voilà qu'aujourd'hui, je n'ai plus accès à internet comme 2 jours auparavant >>> retour à la case départ. J'ai tenté de faire une restauration système (car à présent j'ai quand de nouveau des points de restauration, hélas à la fin de la restauration, l'ordi me dit qu'aucune action n'a été effectuée car il ne peut pas restaurer à une date antérieure.

Je tourne donc en rond (moi qui ai rendu le clavier qui m'a dépanné, c'est bien ma veine).
Quelqu'un aurait-il une idée, mais là je crois que je vais avoir besoin d'un pur informaticien pour ce casse-tête windowsien...
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS