Se connecter / S'enregistrer
Votre question

[Résolu] Debian, rien à http://localhost/phpmyadmin

Tags :
  • MySQL
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
5 Février 2010 23:37:09

Salut,

J'ai installé phpmyadmin sur ma machine debian, mais rien n'écoute à l'adresse (http://localhost/phpmyadmin) spécifiée... Sur le net pourtant les tutos n'indiquent rien de particulier à configurer...

Si quelqu'un peut m'aider je débute dans le monde Linux.

Bonne soirée!

Autres pages sur : resolu debian rien http localhost phpmyadmin

6 Février 2010 11:32:33

# apt-get install apache2 php5 phpmyadmin

les dépendances te seront automatiquement proposés, comme mysql-php5, etc.
m
0
l
6 Février 2010 13:56:24

Salut et merci pour ta réponse,

Ces paquets étaient déjà installés, et leur réinstallation n'a rien apporté :(  ...
Faut il faire un lien avec apache2 ou mysql, par exemple dans les fichiers de conf ?...
m
0
l
Contenus similaires
6 Février 2010 16:51:29

ben déjà est-ce que http://localhost fonctionne ?
m
0
l
6 Février 2010 16:57:57

Bon déjà c'est un PC sans écran je le configure via SSH depuis une autre machine.

Apache tourne nikel, j'y ai déjà configuré des sites par exemple sur :
http://192.168.0.10:50080/ j'ai une page php, qui s'affiche et fonctionne parfaitement

mais si je vais sur :
http://192.168.0.10/phpmyadmin j'ai la belle réponse 404 :

  1. Not Found
  2.  
  3. The requested URL /phpmyadmin was not found on this server.
  4. Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny4 with Suhosin-Patch Server at 192.168.0.10 Port 80
m
0
l
6 Février 2010 20:39:55

:pfff:  Bon enfait j'avais oublié une démarche plutôt super importante. j'explique pour d'éventuel visiteurs :

il faut rajouter dans le fichier de configuration de son site
/etc/apache2/sites-available/SONSITE

les directives contenues dans le fichier :
/etc/phpmyadmin/apache.conf

qui sont les suivantes :
  1. # phpMyAdmin default Apache configuration
  2.  
  3. Alias /phpmyadmin /usr/share/phpmyadmin
  4.  
  5. <Directory /usr/share/phpmyadmin>
  6. Options Indexes FollowSymLinks
  7. DirectoryIndex index.php
  8.  
  9. # Authorize for setup
  10. <Files setup.php>
  11. # For Apache 1.3 and 2.0
  12. <IfModule mod_auth.c>
  13. AuthType Basic
  14. AuthName "phpMyAdmin Setup"
  15. AuthUserFile /etc/phpmyadmin/htpasswd.setup
  16. </IfModule>
  17. # For Apache 2.2
  18. <IfModule mod_authn_file.c>
  19. AuthType Basic
  20. AuthName "phpMyAdmin Setup"
  21. AuthUserFile /etc/phpmyadmin/htpasswd.setup
  22. </IfModule>
  23. Require valid-user
  24. </Files>
  25. <IfModule mod_php4.c>
  26. AddType application/x-httpd-php .php
  27.  
  28. php_flag magic_quotes_gpc Off
  29. php_flag track_vars On
  30. php_flag register_globals Off
  31. php_value include_path .
  32. </IfModule>
  33. <IfModule mod_php5.c>
  34. AddType application/x-httpd-php .php
  35.  
  36. php_flag magic_quotes_gpc Off
  37. php_flag track_vars On
  38. php_flag register_globals Off
  39. php_value include_path .
  40. </IfModule>
  41. </Directory>
(donc faire un simple copier/coller entre les balises <VirtualHost>)

Merci pour ton soutien Freemaster :)  et désolé pour le dérangement @++
m
0
l
5 Mai 2011 14:59:44

excuser moi mais moi je n'arrive pas a aller sur la page "phpmyadmin"
il me dise que cette page n'existe pas . je ne sais pas comment faire ? je regard sur de multiple site mais je ne comprend pas . si quelqu'un pourais me donner un lien qui marche bien ou une aide que je comprenne bien parce-que je galere .
merci
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS