Votre question

Problème serveur dns bind

Tags :
  • Serveur
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
13 Février 2010 17:29:53

Je possède un serveur dédié (kimsufi) et un nom de domaine tous deux chez OVH.
Mon nom de domaine : http://www.cfr-arma.net

Je n'arrive pas à rediriger mon domaine pour tomber sur le serveur (sur le site et forum qui s'y trouvent).

J'ai pourtant lu pas mal de tutos divers sur internet, j'ai utilisé bind9 et aussi essayé maradns.
Les guides en ligne d'OVH ne m'ont pas aidé non plus.

J'ai mis en dns principal ks310258.kimsufi.com et en DNS secondaire j'ai ks.kimsufi.com.


Voici mes fichiers de configuration :

name.conf
db.cfr-arma.net
named.conf.options

Je pense que beaucoup par ici s'y connaissent plus que moi :wink: .
Avez-vous une idée de ce qui ne va pas ?

Merci.

Autres pages sur : probleme serveur dns bind

13 Février 2010 18:50:38

le problème vient du nom kimsufi.com

fait la modif suivant

  1. $ttl 86400
  2. cfr-arma.net. IN SOA ns.cfr-arma.net. postmaster.cfr-arma.net. (
  3. 2010021001
  4. 21600
  5. 3600
  6. 604800
  7. 86400 )
  8. IN NS ns.cfr-arma.net.
  9. IN MX 10 mail.cfr-arma.net.
  10. ns A 188.165.192.226
  11. *.cfr-arma.net. CNAME ns
  12. mail A 188.165.192.226
  13. mail PTR mail
  14. MX 10 mail


et là tu es en wildcard, tous les sous domaines pointent sur la même ip
et n'oublies le fichier reverse 226.192.165.188.in-addr.arpa

et comme dns primaire de ton nom de domaine, tu indiques ns.cfr-arma.net
le serpent ne se mords pas la queue, si le reverse est bien présent...
m
0
l
13 Février 2010 20:57:00

Si je comprend bien, je remplace complètement le fichier que j'ai par ce que vous m'avez donné ?

Ensuite pour le dns primaire du nom de domaine, je dois mettre ça sur le site dans le manager ovh ? Si oui il me demande une adresse IP j'ai mis celle du serveur. Est ce bon ?

En ce qui concerne le fichier inverse j'ai fais ça :

Dans named.conf :

  1. zone "226.192.165.188.in-addr.arpa" {
  2. type master;
  3. file "/etc/bind/db.cfr-arma.net.inv";
  4. forwarders{};
  5. };


Dans db.cfr-arma.net.inv :


  1. $TTL 604800
  2. @ IN SOA pgdebian.cfr-arma.net.
  3. root.cfr-arma.net. (
  4. 20100213
  5. 604800
  6. 86400
  7. 2419200
  8. 604800 )
  9.  
  10. NS pgdebian.cfr-arma.net.
  11.  
  12. 1 PTR pglinux.cfr-arma.net.
  13. 2 PTR pg-cao.cfr-arma.net.
  14. 3 PTR pgdebian.cfr-arma.net.
  15. 9 PTR plgmao.cfr-arma.net.
  16. 10 PTR cpi.cfr-arma.net.
  17. 100 PTR prod.cfr-arma.net.
m
0
l
Contenus similaires
13 Février 2010 21:56:40

teste et tu verras ;) 

dns primaire pgdebian.cfr-arma.net avec son ip 188.165.192.226 oui
m
0
l
13 Février 2010 22:19:58

Justement j'ai testé et ça ne fonctionne pas..

Je me demande pourquoi pgdebian.cfr-arma.net ?
m
0
l
13 Février 2010 23:06:25

ok dans ce cas effectivement tu remplaces complètement ton fichier par ce que j'ai donné, et tu corriges l'autre fichier reverse

  1. $TTL 604800
  2. 226.192.165.188.in-addr.arpa. IN SOA ns.cfr-arma.net. postmaster.cfr-arma.net. (
  3. 20100213
  4. 604800
  5. 86400
  6. 2419200
  7. 604800 )
  8.  
  9. NS ns.cfr-arma.net.
  10.  
  11. 1 PTR ns.cfr-arma.net.
  12. 2 PTR mail.cfr-arma.net.


n'oublies pas de redémarrer ton serveur bind9

et pour tester depuis ton poste client, rajoutes ton ip dans allow-recursion, et ensuite mets le dns primaire l'ip de ton serveur...
car bind9 prend du temps pour la propagation dns, avant que cela fonctionne pour tout le monde
m
0
l
13 Février 2010 23:33:59

Oui j'ai mis éxactement la ce que tu m'as dis de mettre.

par contre j'ai modifié le fichier db.cfr-arma.net .inv :

  1. $TTL 604800
  2. @ IN SOA cfr-arma.net.
  3. root.cfr-arma.net. (
  4. 20100213
  5. 604800
  6. 86400
  7. 2419200
  8. 604800 )
  9.  
  10. NS ns.cfr-arma.net.
  11.  
  12. 226 PTR .cfr-arma.net.


C'est bon ? Qu'est ce qui peux coincer sinon ?
En tout cas merci de ton aide ça avance un peu !
m
0
l
14 Février 2010 10:27:52

mets exactement ce que je mets :

  1. $TTL 86400
  2. cfr-arma.net. IN SOA ns.cfr-arma.net. root.cfr-arma.net. (
  3. 2010021401
  4. 8H
  5. 1H
  6. 1W
  7. 1D )
  8. IN NS ns.cfr-arma.net.
  9. IN MX 10 mail.cfr-arma.net.
  10.  
  11. ns A 188.165.192.226
  12. ns PTR ns
  13. *.cfr-arma.net. CNAME ns
  14. mail A 188.165.192.226
  15. mail PTR mail
  16. MX 10 mail


  1. $TTL 86400
  2. 226.192.165.188.in-addr.arpa. IN SOA ns.cfr-arma.net. root.cfr-arma.net. (
  3. 2010021401
  4. 8H
  5. 1H
  6. 1W
  7. 1D )
  8. NS ns.cfr-arma.net.
  9. 1 PTR ns.cfr-arma.net.
  10. 2 PTR mail.cfr-arma.net.


tu as bien une ip, et non pas un pool ip !!!

puis # /etc/init.d/bind9 restart
m
0
l
14 Février 2010 12:02:26

Jai mis éxactement ce que tu as mis.
J'ai qu'une adresse ip

Quand je redemarre bind j'ai une erreur :

  1. Stopping domain name service...: bind9rndc: connect failed: 127.0.0.1#953: connection refused
  2. .
  3. Starting domain name service...: bind9.



Mais il a l'air de se lancer quand même non ?



m
0
l
14 Février 2010 13:24:22

le rndc n'est pas important... par contre je n'ai pas de réponse sur aucun alias... y a que le ns qui répond... c'est comme ci le wilcard n'était pas activé chez toi...

tu es bien sur que tu as mis exactement ce que j'ai mis ? pas de @ dans le reverse...

dans ce cas modifies ton fichier named.conf.options

  1. options {
  2. directory "/var/cache/bind";
  3.  
  4. // If there is a firewall between you and nameservers you want
  5. // to talk to, you may need to fix the firewall to allow multiple
  6. // ports to talk. See http://www.kb.cert.org/vuls/id/800113
  7.  
  8. // If your ISP provided one or more IP addresses for stable
  9. // nameservers, you probably want to use them as forwarders.
  10. // Uncomment the following block, and insert the addresses replacing
  11. // the all-0's placeholder.
  12.  
  13. auth-nxdomain no; # conform to RFC1035
  14. listen-on-v6 { any; };
  15. allow-recursion { 127.0.0.1; 188.165.192.226; };
  16. };


redémarres le bind9, puis un test avec dig je verrais si c'est mieux...
m
0
l
14 Février 2010 16:41:41

Voilà j'ai modifié le fichier named.conf.options avec ton code et redémarrer bind.
Pas de @ dans le fichier c'est vraiment exactement le même que tu m'as donné.

Pas d'améliorations on dirait... :??: 
m
0
l
14 Février 2010 18:01:49

alors une dernière chose, supprimes le allow recursion au niveau des zones

zone "cfr-arma.net" { type master; file "/etc/bind/db.cfr-arma.net"; };

et aussi pour le reverse... pour voir !
m
0
l
14 Février 2010 18:56:03

c'est fait par contre pour la zone de reverse j'ai pas allow recursion j'ai ça :

  1. zone "226.192.165.188.in-addr.arpa" {
  2. type master;
  3. file "/etc/bind/db.cfr-arma.net.inv";
  4. forwarders{};
  5. };
m
0
l
14 Février 2010 19:02:52

vire le forwarder{};

ceci dit cela ne semble pas marcher... t'as bien redémarrer bind ?
m
0
l
14 Février 2010 19:10:46

c'est fait.
Oui je redémarre bind à chaque modification.
m
0
l
14 Février 2010 20:13:58

ben écoute niko, j'ai vérifier ton serveur dns principal et il pointe bien sur ns.cfr-arma.net

soit il faut attendre que la propagation dns soit faite...
soit le wilcard ne veut pas fonctionner... mais vu que l'alias mail aussi ne marche pas, je pense qu'il faut attendre un peu...

pas de firewall en entrée/sortie qui bloquerait les requêtes dns j'espère ?
m
0
l
14 Février 2010 20:21:21

Il faut attendre combien de temps ?

En ce qui concerne le firewall , il y a pas de raison j'ai rien touché à ça. Comment je vérifie si j'en ai un ou si il bloque quelquechose ?

Merci de ta patiente en tout cas :) 
m
0
l
16 Février 2010 11:37:02

Il n'y a pas d'amélioration.
Une autre idée ?
m
0
l
17 Février 2010 12:53:18

ben moi je fais comme ça pour mes noms de domaines... donc...

si tu veux je peux jetter un oeil à ton serveur via ssh, si tu me fais confiance :p 
jcworld@asrun.eu

m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS