Votre question

[Résolu]Debian Lenny + ATI 4850 + Drivers = aie aie

Tags :
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
2 Mars 2010 12:16:34

Bonjour,

Il y a longtemps que je n'ai pas posté ici, faut dire, ca fait longtemps que j'ai pas eu de soucis qui me bloquaient autant...

Avant tout je tiens à dire que j'ai fais pas mal de recherche, et je continus d'en faire, je post ici en parallèle au cas où, si je trouve une solution je la posterai..

Alors déjà ce qu'il s'est passé.
J'avais un PC sous Debian.
Le disque dur a lâché.
J'ai changé de disque, et j'ai ré-installé la même version de Debian, avec le même DVD, c'est à dire Debian Lenny.

Je me souviens que j'ai eu quelques soucis la première fois avec les drivers ATI, mais cette fois je n'arrive pas à les résoudre...

Voilà ce qu'il se passe.

Lors de l'installation des drivers ATI, les officiels, au reboot, j'ai un écran noir.
Je démarre en single user, je fais un dpkg-reconfigure xserver.xorg
La il me pose des questions (sur le clavier rien sur les résolutions d'écran ou autre) et ca repart, mais sans le pilote graphique installé...

j'ai tenté avec ca http://wiki.debian.org/ATIProprietary mais le résultat est un bureau avec une résolution.... digne d'un téléphone portable, a tel point que j'ai pas accès au menu système en haut pour aller dans "résolution de l'écran".

A propos de ça d'ailleurs, le menu résolution de l'écran, avant les install, ou après un dpkg-reconfigure etc.. ce menu est totalement vide, aucun choix de résolution, et la résolution de mon bureau n'est pas la bonne (je n'ai pas le bas du bureau)

Personnellement il me faut du 1680x1050..


Tout ce que j'ai pu trouver sur le net n'a jamais marché.
Soit l'écran noir.
Soit un message comme quoi le serveur X n'a pas démarré et hop je dois le rétablir ^^ (ca c'est quand je touchais le Xorg.conf)
Soit un bureau rikiki ^^ d'ailleurs j'en suis là, là... un bureau rikiki, heureusement que y'a le 2ème pc pour faire les recherche... je peux rien faire là...

J'aurai voulu vous poster le Xorg.conf mais vu le bureau de ma Debian ca va pas être possible, si je reviens à une résolution d'écran normal, je posterai a la suite mon Xorg.conf.


J'espère trouver ici l'aide dont j'ai besoin.

Merci d'avance

Leank

Autres pages sur : resolu debian lenny ati 4850 drivers aie aie

2 Mars 2010 12:33:49

Alors en virant l'horloge j'ai pu faire apparaitre le menu systeme et configurer la resolution (oui oui maintenant j'ai un choix de résolutions :) 

Voici le Xorg.conf :
Spoiler
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "ATI"
Driver "fglrx"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1680x1050"
EndSubSection
EndSection


Par contre quand je veux tester que la 3D marche voilà ce quej 'obtiens :

Spoiler
debian:/home/leank# fgl_glxgears
Using GLX_SGIX_pbuffer
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 144 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 15
Current serial number in output stream: 15
debian:/home/leank# glxinfo
name of display: :0.0
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 144 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 15
Current serial number in output stream: 15


Et si je lance l'utilitaire ATI..... il ne se lance pas^^
Any Idea ? :) 
m
0
l
2 Mars 2010 13:40:54

Problème résolu, apres toutes ces manips, je suis passé en ligne de commande j'ai coupé le serveurX, j'ai lancé l'install du driver ati et oh merveille ca marche :) 

Merci à ceux qui ont pris le temps de me lire, j'espere que ce message servira à d'autres..
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS