Votre question

Désinstaller "proprement" PhpMyadmin, Apache etc. sous Ubuntu...

Tags :
  • Ubuntu
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
18 Août 2010 21:51:20

Bonsoir à tous*,

Ayant quelques problèmes -encore- lors de l'installation d'un CMS (Drupal) sous Ubuntu, j'ai interrogé sur le forum Drupal où on m'a indiqué
Citation :
e fait que /phpmyadmin ne soit pas accessible veut simplement dire qu’il n’y a pas d’alias qui a ete cree dans apache, donc il faudrait reviser la configuration d’apache voir desinstaller et reinstaller phpmyadmin pour que cette etape soit bien prise en compte.
. Sur le coup, j'ai trouvé génial que ce soit aussi simple et puis...

- pour "créer des alias sous Apache", j'ai bien trouvées quelques pistes sur le net mais elles se terminent en voies sans issue pour moi :( 
- j'ai joliment "tout cassé" l'autre soir en voulant désinstaller PhpMyadmin... Au moins, ça m'a conforté dans ma passion naissante pour Linux qui a de super garde-fou et permet de "réparer un paquet cassé" en guidant le néophyte pas à pas.

Donc ce soir, après avoir réparé tout ça, je me redemande si je dois chercher à créer des alias ou désinstaller et réinstaller. Décidée à ne pas refaire les bêtises de l'autre nuit, je commence par potasser ce que je peux trouver sur le net et... je suis trop nulle comme vous allez le voir (je n'ose même plus poser mes questions de noob ailleurs qu'ici !) :pt1cable: 

1ère question (un peu générale et a priori complètement c* :ouch:  ) : comment trouver l'équivalent de l'arborescence de Windows :/ ? Dans plusieurs guides, je constate qu'il faudrait aller modifier telle ou telle ligne dans tel ou tel fichier, mais... Il doit y avoir un truc ! Dans le navigateur de fichier, je n'ai quasiment rien dans la partition dédiée à Linux et si je lance une recherche, même plus large -HDD & Cie-, avec "apache" par exemple, la réponse est 0 élément(je suis à peu près sûre de passer à côté d'une évidence là mais... ras-le bol)

2ème question : sauriez-vous dans quel ordre (ou quelle autre manip faire) pour désinstaller proprement, via le gestionnaire de paquets Synaptic ces quatre logiciels étroitement liés
- PhpMyadmin
- Apache2
- MySQL
- php5

Merci d'avance !


*et à TGV en particulier - à moins que ce soit Guigui qui me réponde ayant démarré Linux un peu après moi mais étant bien moins "brêle" :o 




Edit tardif (histoire de prouver que je cherche quand même un peu :/ ) une commande trouvée sur le net me renvoie ça
Citation :
tcm@tcm-laptop:~$ /etc/init.d/apache
bash: /etc/init.d/apache: Aucun fichier ou dossier de ce type
alors que apache est bien activé si j'en crois Synaptic :fou:  Je vais finir par balancer mon ordi par la fenêtre...

Autres pages sur : desinstaller proprement phpmyadmin apache ubuntu

19 Août 2010 13:07:38

Salut,

prem's !!!!!!

Pour installer tes paquets, comment as-tu procédé ?

Tu as installé dans quel ordre ?
Désinstalles alors dans l'ordre contraire.

Il me semble qu'il est possible de désinstaller juste le paquet lamp-server^ en faisant
Citation :
sudo apt-get remove lamp-server^


A+
m
0
l
19 Août 2010 13:20:50

Hello, deu's !

Citation :
à moins que ce soit Guigui qui me réponde ayant démarré Linux un peu après moi mais étant bien moins "brêle"


:D  Oh, rassure-toi, je suis aussi "brêle comme tu dis" que toi pour Linux pour l'instant :D  Aucune idée pour ton problème ! :) 

Euh TGV, si tu pouvais passer par là : http://www.infos-du-net.com/forum/280989-10-linux-mise-...

Besoin d'aide aussi :) 

Bonne chance TCM pour ton histoire d'apache... :) 

:hello: 
m
0
l
Contenus similaires
Pas de réponse à votre question ? Demandez !
19 Août 2010 22:36:32

guigui0001 a dit :
Bonne chance TCM pour ton histoire d'apache... :) 
Yeah, la cavalerie débarque donc ça devrait le faire ! :lol: 

Alors, comment j'ai fait et dans quel ordre : en fait, j'ai bêtement recopié une commande trouvée sur un bouquin d'installation de Drupal
Citation :
sudo apt-get install apache2 apache2-doc mysql-server php5 libapache2-mod-php5 php5-mysql phpmyadmin php5-gd

L'installation avait semblé bien se passer -pas exactement comme dans le bouquin (un peu plus de demandes de mp, pas avec la fenêtre figurant dans le livre etc., mais comme les écrits datent vite dans ce domaine, ça ne m'a pas inquiétée). A la fin de l'install, l'auteur recommande de vérifier si le serveur Web fonctionne en tapant http://localhost -> Zut ! "It works"
Puis de vérifier si phpMyadmin fonctionne en ajoutant /phpmyadmin -> 404 :( 

C'est là que j'ai posté sur le forum Drupal car j'ai l'impression d'avoir déjà eu ce "it works" quand je l'avais installé sous Windows (mais pas moyen de retrouver la solution) et qu'on m'a répondu ce que j'ai cité plus haut.

Désinstaller dans l'ordre inverse... C'est ce que j'ai fait (non ?) en commençant par phpMyadmin et c'est là que j'ai mis la zone avec des paquets cassés et tout ça

Je vais tenter cette désinstallation de lamp-server et te /vous tiens au courant

Merci dans tous les cas [:mary]
m
0
l
19 Août 2010 23:13:12

Linux s'trop nul, installe Win95 en Dual boot avec MacOS X.6 :o 
m
0
l
19 Août 2010 23:23:08

Dafen@IDN a dit :
Linux s'trop nul, installe Win95 en Dual boot avec MacOS X.6 :o 
:heink:  Dafen, si tu es capable de me donner toute la marche à suivre, pas à pas, avec Drupal sous MacOS, je reverrai peut-être mon opinion mais là -pour le moment- je te sens pour une fois complètement out :na: 
m
0
l
20 Août 2010 13:12:36

TCM@IDN a dit :


Edit tardif (histoire de prouver que je cherche quand même un peu :/ ) une commande trouvée sur le net me renvoie ça
Citation :
tcm@tcm-laptop:~$ /etc/init.d/apache
bash: /etc/init.d/apache: Aucun fichier ou dossier de ce type
alors que apache est bien activé si j'en crois Synaptic :fou:  Je vais finir par balancer mon ordi par la fenêtre...

Tu as dû suivre un vieux tuto alors, parce que la plupart des distributions actuelles fonctionnent avec apache2.

/etc/init.d/apache2 start <- Lancer apache2
/etc/init.d/apache2 restart
/etc/init.d/apache2 stop
etc.

Est-ce que désinstaller lamp-server a fonctionné ?
Sinon, un bête sudo aptitude remove --purge apache2* php* devrait fonctionner, et te supprimer apache2, ses dépendances etc.

Pour installer phpMyAdmin, je te conseille, si tu ne comprends rien aux Vhost, de récupérer directement le package en .tar.gz ou .zip sur le net, et de le configurer à la main en modifiant les fichiers de conf présent dans cette archive.
m
0
l
20 Août 2010 15:36:12

Tiens Moi123, ça faisait longtemps ! [:mary]

Alors, la désinstallation de lamp-server, non -> 'E: impossible de trouver le paquet lamp-server'
Et le --purge apache2 etc. c'est une commande que j'avais essayé, je viens de la refaire et elle m'enlève effectivement 1 paquet (et un seul). En retournant voir dans le gestionnaire de paquets, un certain nombre de Apache 2 (apache2-mpm-prefork, apache2-utils, apache2.2-bin etc.) restent actifs... Donc, à mon avis, je vais encore avoir droit aux messages d'erreur si je réinstalle par-dessus ça :/ 

Moi123@IDN a dit :
Tu as dû suivre un vieux tuto alors, parce que la plupart des distributions actuelles fonctionnent avec apache2.
Oups, même pas vu que ça parlait d'apache et non d'apache 2 :sarcastic: 

Moi123@IDN a dit :
si tu ne comprends rien aux Vhost
Comment as-tu deviné ? [:_tom_:6] . Bon, au moins ça me donne le mot-clé à chercher sur mon ami Google ;) 

Moi123@IDN a dit :
de récupérer directement le package en .tar.gz ou .zip sur le net, et de le configurer à la main en modifiant les fichiers de conf présent dans cette archive.
Huummm, la config à la mano vu mon niveau sous Linux [:hakan:2] Bah, je ne perds rien à essayer au point où j'en suis...
Juste une précision si j'en arrive au stade où je pourrai installer : c'est dans cette config que je suis censée créer les alias manquant dans phpMyadmin ? (1er post) ?

Merci en tout cas
m
0
l
20 Août 2010 15:59:55

Est-ce que tu as bien mis les étoiles après apache2 et php ?

Je prendrai le temps de répondre ce soir plus en détail, je vais partir là, en rentrant je te détaillerai la marche à suivre avec les alias etc. si j'ai le temps.

Bon courage.
m
0
l
20 Août 2010 16:15:03

Merci Moi123,

Oui, j'avais mis les étoiles, là il ne trouvait rien :(  (j'ai fermé la fenêtre mais c'était un message du type de celui que j'ai eu pour Lamp Serveur)
J'ai ensuite essayé sans les étoiles et c'est là qu'1 fichier a été supprimé...

Quand tu peux ;) 
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS