Votre question

probleme windows pour les detections de peripherique

Tags :
  • Matériel
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
Anonyme
10 Avril 2005 21:30:05

bonjour ^^
voila j'ai un chtit probleme a chaque fois que je branche un peripherique dans un port usb windowsXP me dit "materiel detecté usb device"
en fait pour pas que j'ai se message faut obligatoirement que j'install les drivers mais le probleme c que sa me le fait pour tout les connections usb y compris les clé usb qui demande pourtant aucun drivers
et aussi par exemple
j'install un peripherique avec les drivers tout marche impec
si je debranche le cordon usb de mon ordi il faut obligatoirement reinstallé le driver sinon sa me sort encore le message "materiel detecté usb device"

comment faire pour que windows XP me detecte mes peripherique (me dites pas de formaté svp)
merci d'avance

Autres pages sur : probleme windows detections peripherique

17 Avril 2005 14:32:47

Il existe un problème sur les machines intégrant Windows XP SP2 et l’installation de périphériques.
En temps normale, Windows installe automatiquement certains périphériques, parce qu’il les a déjà (comme une clé USB), Ou parce que vous avez installé le pilote avant (comme une imprimante HP par exemple).
Dans le cas présent, Windows ne trouve pas les pilotes automatiquement, même si vous lui indiquez
le cd-rom d’installation où il se trouve. C’est d’autant plus compliqué, car certains périphériques comme des clés USB n’ont pas de pilote.
J’ai pu constater que c’est souvent après l’installation d’un kit ADSL que le soucis survient.
Il y a pourtant plusieurs solutions à ce problème.

La première solution est assez radicale :
Restauration système…. ! Certains utilisateurs n’accepteront pas cette solution.

La deuxième est moins pratique pour un novice :
Lors de la détection du périphérique Windows vous demande d’insérer le pilote qu’il ne trouve pas. Il suffit tout « simplement » de refuser l’installation automatique et de faire installation manuelle.
Cochez la casse « spécifier un emplacement » et indiquez lui le répertoire « c:\windows\inf »
Le problème c’est qu’il faut le faire tout temps : pour d’autres périphériques et plusieurs fois pour un périphérique. Cela devient plus complique s’il y a une interface d’installation qui fait tout tout seul. Il faut alors penser aller voir en arrière plan « ALT+TAB ».

La troisième solution est plus simple :
Il suffit de lance le patch que j’ai crée à partir d’une machine saine. Les installations se dérouleront sans problème. mail à ripnet@wanadoo.fr pour avoir le patch

Pour rappel :
Sachez que vous pour aussi retirer dans la base de registre l’historique des périphériques déjà branchés sur le port USB. (Périphériques inconnus compris).
Lancer l’éditeur de la base de registre : REGEDIT
Allez dans le répertoire : « HKEY_LOCAL_MACHINE »
« SYSTEM »
« CurrentControlSet »
« ENUM »
cliquez sur le répertoire « ENUM » avec le bouton droit de la souris et choisir « Autorisation… »
Sélectionnez comme nom d’utilisateur ou de groupe « Tout le monde »
Sélectionnez dans Autorisations pour tout le monde « contrôle total » et « Autoriser »
Cliquez sur « OK »
Allez dans le répertoire « USB »
Et supprimez tous les répertoires « Vid_xxxxxxxx_xxxx)
Fermez l’éditeur
Et branchez vos périphériques…
ripnet
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS