Se connecter / S'enregistrer
Votre question

Architecte 3D - Problème base de donnée

Tags :
  • Base de registre
  • Logiciels
Dernière réponse : dans Logiciels
26 Août 2005 21:57:43

Lors du chargement d'un projet, il m'affiche :

"Paramètres d'initialisation de la base de données" :
"Aucune base de données n'a été sélectionnée"

Pourtant tout les fichiers mdb sont en places

Ensuite un fenêtre s'ouvre :
"Activer/désactiver les bases de données" :
lorsque j'essaye d'ajouter les bdd manquantes, il m'affiche :
"La base de données n'a pas pu s'ouvrir ou n'est pas une base de données d'objets complète."

Même topo, si je passe ensuite par le "catalogue architecture", catalogue / base de donnée

J'ai essayé de désinstaller puis de réinstaller : nada

Précisions :
- Je viens de réinstaller complétement deux ordi, ca marche sur 1 et pas sur l'autre.
- Il a déjà fonctionné sur celui qui pose problème aujourd'hui ...
- système windows XP
- Architecte 3D version 2 (2004)

Merci d'avance pour tout aide.


Autres pages sur : architecte probleme base donnee

8 Juin 2006 20:41:43

salut,
as-tu finalement trouvé la cause de ton problème. Je suis intéressé.
8 Juin 2006 21:30:10

Hélas non ... :-(
Contenus similaires
30 Octobre 2006 13:45:35

Salut,

J'ai exactement le meme problème avec la version 2005 !!! Ca marchait très bien, et depuis quelques jours ça ne marche plus... La seule cause que j'ai pu identifier, c'est que j'ai installé Microsoft access (dont les bases de données sont en .mdb, comme A&C 3D). Je suis sous Windows 2000.

Désinstallations, réinstallation, purge de la base de registre, rien n'y fait !!! La hotline est incapable de m'aider, leur seul conseil est de réinstaller Windows :fou: 

Bref, si quelqu'un a ne serait-ce que le début de commencement d'une idée pour résoudre le problème, je suis preneur.

Willy
30 Novembre 2006 09:27:58

Idée : Mettre A3D à la poubelle .... :pt1cable: 

Ils sont gentils la h:o tline, réinstaller le système !...... :non:  Je ne vais pas perdre 1 journée complète à refaire toute la machine pour un truc comme ça .... :fou: 

En plus sans aucune garantie que ca fonctionne, ou pire que ca replante plus tard ....

Est-ce qu'ils conseillent de retenter la réinstallation 1, 2 ou 3 fois ?
Faut-il croiser les doigts en installant ??
Faut-il attendre la Ste Catherine ???

Désolé .... :bounce: 

21 Décembre 2006 12:24:54

J'ai exactement le même problème. :fou: 
Jeter A3D à la poubelle OK, mais les 50 heures passées à dessiner des projets, ça fait mal ....
J'ai désinstallé Access, ça ne suffit pas.
Si quelqu'un a trouvé comment faire pour résoudre cette histoire d'accès aux bases de données, ça me fera un joli cadeau de Noel !
22 Janvier 2007 23:49:54

J'ai le meme problem sur un de mes ordis que je viens de refaire avec XP SP1. Ai mis tous les patchs Microsoft. Par contre je l'ai installe sur 3 autres ordi, XP, SP1 et SP2, avec Access d'installe, et ca marche tres bien.

J'ai meme copie tel quel le fichier Program files\Anuman interactve d'un ordi qui marche bien, helas avec le meme resultat.
Le logiciel est Architecture 3d v.2

En resume, le probleme ne depend pas :
- du HW (avec le meme HW des fois ca marche, des fois pas)
- SP1 ou SP2
- patches ou pas
- access ou pas

La seule constatation un peu irrationnelle : ca ne plante pas avec un PC tres mature, avec beaucoup de softs installes.

Si quelqu'un a trouve la solution, je suis tres interesse.

On pourrait demander a Anuman de nous mettre a jour tous avec Architecture 3D system D 2007 ?

P
6 Février 2007 20:11:17

En fait, il semblerait que Architecte 3D a besoin de trois dll pour charger les bases de données.
Il s'agit de MSJET35.dll, MSJTER35.dll et MSJINT35.dll.
Il suffit de les récupérer sur le net et de les copier dans le répertoire racine de Architecte 3D pour ne plus avoir le message.
25 Septembre 2007 12:22:20

moi aussi probleme identique sur 2 pc avec xp sp2 je suis en train d'essayer de l'installer sur 1 troisième pc et j'espère que cela va fonctionner .
pour ce qui est des fichiers dll ou doit on les mettre pour achitecte 3d 2004?
merci pour votre aide

Y...
12 Avril 2008 13:46:00

Bonjour,
c'est quoi la manip. en fait ? Ou faut il copier les DLL ?
Merci....
5 Mai 2008 22:51:16

Bonjour,

Le problème de chargement des bases de données dans Architecte 3d (je travaille avec la version 2001, mais le phénomène peut être identique sur les version supérieures) est lié au composant DAO utilisé pour accéder aux bases access.

Architecte 3D doit utilise le composant DAO350 non présent sur les dernières versions de Windows. Le problème a donc été résolu ainsi :

1. Récupérer le fichier DAO350.dll (http://www.dll-files.com/dllindex/dll-files.shtml?dao35...)
2. Copier le fichier DAO350.dll dans le répertoire C:\Program Files\Fichiers communs\Microsoft Shared\DAO
3. Ouvrir une invite de commande DOS, et lancer la commande suivante :
regsvr32 "C:\Program Files\Fichiers communs\Microsoft Shared\DAO\dao350.dll"
4. Le chargement des Bases de données dans Architecte doit s'effectuer correctement.

En espérant que cette manipulation fonctionnera également chez vous.

Cordialement
6 Mai 2008 22:15:03

Bonjour,

Voici la procédure complète pour faire fonctionner les bases de données sur Architecte 3D. Testé sur :
Windows XP SP1 + MAJ SP2
Windows XP SP2
Vista

1. Récupérer le fichier DAO350.dll (http://www.dll-files.com/dllindex/dll-files.shtml?dao35...)
2. Copier le fichier DAO350.dll dans le répertoire C:\Program Files\Fichiers communs\Microsoft Shared\DAO
3. Ouvrir une invite de commande DOS, et lancer la commande suivante :
regsvr32 "C:\Program Files\Fichiers communs\Microsoft Shared\DAO\dao350.dll"
4. Récupérer les dll MSJET35.dll, MSJINT35.dll, MSJTER35.dll et les copier sous C:\Windows\system32\
5. Redémarrer Architecte 3D
6. Les bases de données doivent être accessibles.

Cordialement.

K.
13 Septembre 2008 17:58:02

koobaya a dit :
Bonjour,

Voici la procédure complète pour faire fonctionner les bases de données sur Architecte 3D. Testé sur :
Windows XP SP1 + MAJ SP2
Windows XP SP2
Vista

1. Récupérer le fichier DAO350.dll (http://www.dll-files.com/dllindex/dll-files.shtml?dao35...)
2. Copier le fichier DAO350.dll dans le répertoire C:\Program Files\Fichiers communs\Microsoft Shared\DAO
3. Ouvrir une invite de commande DOS, et lancer la commande suivante :
regsvr32 "C:\Program Files\Fichiers communs\Microsoft Shared\DAO\dao350.dll"
4. Récupérer les dll MSJET35.dll, MSJINT35.dll, MSJTER35.dll et les copier sous C:\Windows\system32\
5. Redémarrer Architecte 3D
6. Les bases de données doivent être accessibles.

Cordialement.

K.


Bonjour,

Je suis nouveau venu sur ce forum, c'est d'ailleus la première fois que je suis membre d'un forum, je tiens à vous remercier des directives que vous donnez pour solutionner ce problème. je vous expose mon cas: je viens de formater mon Pc, j'avais: Architecte 3D 2001 (réf 3339) et 3D Architecte Pro 2008 (réf 9206) 'de Mico Application' d'installé qui fonctionaient corectement après avor formaté installé Windows, Avast en protection, Sysboot, Microsoft Office 2003, Msn et Skype en messagerie, PhotoShop CS, PaintShopPro 9, IE 7, SolisWorks, FireFox et quelques autres, vérifié le fonctionnement correcte de tout celà et paramétrer chacun, voulant installer 3D 2001, problème de base de donnée, cela m'était déjà arrivé mais durant ces dernières années, je m'en suis toujours sorti (je ne sais comment exactement) mais de façon très simple, ce jour impossible et avec votre solution qui me semble très professionnelle ègalement après environ 15 heures d'acharnement en dernier recours je tente d'installer 2008, là c'est beaucoup plus simple et rapide, erreur avant le début de l'installation (6001) fermez tous vos programmes, videz vos fichiers temporaires, tentez d'installer, rien à faire. J'avoue que je ne suis capable que d'utiliser l'outil informatique et certainement avec un faible pourcentage de ce que les logiciels que je possède sont capable de donner. C'est un véritable calvair pour moi de formater, j'ai tenu sans formater 2 ans, il me faut beaucoup de temps pour mettre au point ne serais ce que Word et Excel, Microsoft Outloock, solidWorks au niveau des options, barres d'outils ect..Concernant Architecte ce sont certainement des milliers d'heures de travail perdues ces dernières années et je n'arrive à pas grand chose avec la version plus récente. Je n'ais qu'une explication peut être valable, quand j'ai installé sur ce dernier PC, j'étais avec le même XP mais en pack 2, aujourd'hui je suis en pack 3, je suis à 10 000 km de chez moi avec un seul PC jusqu'à fin décembre. Voilà environ 20 ans j'ai commencé avec du matériel sans disque dur, je suis passé au PC disquette 5 1/4, le premier Windows version 3 je crois. A cette èpoque je surveillais mon Pc à l'octet près. Je n'ais que 2 ans de pratique avec Internet. Pour réalisez la procédure que vous préconisez j'ai bien passé 4 heures, je me suis séparé du Dos à la version 6.21 je crois, à la suite de la ligne d'instruction sous Dos que vous donnez, j'ai eu un message disant que l'instruction avait été bien prise en compte. J'ai mis beaucoup de temps pour l'une des 3 *.DLL qui n'était pas sur le même site que les 2 autres. Voilà cher monsieur à nouveau remerciement pour l'aide que vous apportez, je remercie également toute les personnes qui consacrent du temps à donner leurs compétances et savoir.
Bernard.
15 Septembre 2008 14:25:07

koobaya a dit :
Bonjour,

Voici la procédure complète pour faire fonctionner les bases de données sur Architecte 3D. Testé sur :
Windows XP SP1 + MAJ SP2
Windows XP SP2
Vista

1. Récupérer le fichier DAO350.dll (http://www.dll-files.com/dllindex/dll-files.shtml?dao35...)
2. Copier le fichier DAO350.dll dans le répertoire C:\Program Files\Fichiers communs\Microsoft Shared\DAO
3. Ouvrir une invite de commande DOS, et lancer la commande suivante :
regsvr32 "C:\Program Files\Fichiers communs\Microsoft Shared\DAO\dao350.dll"
4. Récupérer les dll MSJET35.dll, MSJINT35.dll, MSJTER35.dll et les copier sous C:\Windows\system32\
5. Redémarrer Architecte 3D
6. Les bases de données doivent être accessibles.

Cordialement.

K.


Bonjour !

J'ajoute ceci, Micro Application me répond aujourd'hui:

Pour la référence 3339, le problème vient du SP3.Pour l'autre référence veuillez suivre la manipulation suivante:



1- Ouvrez le "Poste de Travail".

2- Cliquez sur votre disque dur local (c:)  à l'aide du bouton
droit de la souris, puis sur la ligne "Explorer" à
l'aide du bouton gauche de la souris.

3- Double-cliquez sur le dossier "Program Files" ou "Programmes" sous Vista.

4- Double-cliquez sur le dossier "Fichiers communs" ou "Common Files" sous Vista.

5- Double-cliquez sur le dossier "InstallShield".
6- Double-cliquez sur le dossier "Professional".
7- Double-cliquez sur le dossier "RunTime".
6- Cliquez sur le dossier "0701" , à l'aide
du bouton droit de la souris, puis sur "supprimer"
à l'aide du du bouton gauche de la souris .

Vous pouvez, ensuite, relancer l'installation.

Je souhaite que celà puisse aider quelqu'un, et je pose la question suivante:
Croyez vous qu'en repassant sous pack 2, j'ai une chance pour l'installation de Archicte 3D 2001 (réf: 3339), sachant que je suis ignorant de tous ces problèmes, je pense tout de même que c'est vraiment de la corde raide de tenter. Merci de votre compréhension, de votre réponse.

Sincères salutations.
26 Décembre 2008 01:00:42

Bonjour à tous.
Je subis le même probleme suite à un formatage. Je suis sous XP SP3, ai tout essayer, impossible d'ouvrir un projet cause bases de données non activées. Impossible de les charger (message idem pas ouverte ou pas complète).
merci d'avance pour votre aide
9 Janvier 2010 09:46:37

Bonjour à tous

j'ai un probleme de base de données au démarage d'architecte 3d 2003.
j'ai le message suivant "une base de donnée utilisant l'ID 2300 existe déjà" avec l'emplacement de la base objet2 ach...3d 2003.mdb. idem pour la base objet1.......mdb. alerte que ces bases de donnees ne seront pas chargées.
Malgé ces 2 messages d'erreurs, le logiciel fonctionne.
ce probleme est apparu après que j'ai desinstallé architecte 3d de mon ordi pour laisser uniquement architecte 3d 2003. Les 2 cohabitaient tres bien.

bien entendu j'ai essayé de desinstaller ensuite completement 3d 2003 et de le réinstaller . probleme toujours present

Je suis sous xp .

Comment supprimer ces 2 alertes

Yades
Anonyme
a b 6 Logiciels
11 Septembre 2010 06:36:31

Bonjour à tous.

En bidouillant archi 3d 2001, j'ai endommagé ma base de données
il me dit "la base de données n'a pas pu etre ouverte ou est endommagé"

donc ma question : sur ce forum, y aurait il une personne assez sympa pour m'envoyer sa db.mdb ou m'expliquer comment recuperer la mienne

Merci d'avance

Cédric
28 Septembre 2010 14:54:04

Bonjour,

J'ai pas la réponse mais plutôt le même problème

Même souci, avec architecte 3D version 2001 et windows 7 qui ne trouve pas les
dbDB.dll alors que ça marchait très bien sur mon pc bureau avec XP pack

Probleme résolu, j'avais une version copie avec l'original ça fonctionne
2 Octobre 2010 14:59:31

re bonjour,

c'est re moi (le post précédent) problème non résolu même avec CD original

"enregistrement OLE échoué" pouvez m'aider merci d'avance.



Uploaded with ImageShack.us



Anonyme
a b 6 Logiciels
11 Octobre 2010 14:49:58

koobaya a dit :
Bonjour,

Voici la procédure complète pour faire fonctionner les bases de données sur Architecte 3D. Testé sur :
Windows XP SP1 + MAJ SP2
Windows XP SP2
Vista

1. Récupérer le fichier DAO350.dll (http://www.dll-files.com/dllindex/dll-files.shtml?dao35...)
2. Copier le fichier DAO350.dll dans le répertoire C:\Program Files\Fichiers communs\Microsoft Shared\DAO
3. Ouvrir une invite de commande DOS, et lancer la commande suivante :
regsvr32 "C:\Program Files\Fichiers communs\Microsoft Shared\DAO\dao350.dll"
4. Récupérer les dll MSJET35.dll, MSJINT35.dll, MSJTER35.dll et les copier sous C:\Windows\system32\
5. Redémarrer Architecte 3D
6. Les bases de données doivent être accessibles.

Cordialement.

K.


Je confirme : testé avec Architect 3D 2001 sous Windows 7 (64bits) , avec les nuances suivantes :

OK pour points 1. et 2.

KO au point 3.
- il faut impérativement préciser "exécuter en mode administrateur" avant d'ouvrir la fenêtre DOS (sinon on prend une erreur 0x80004005)
- Il faut aussi adapter le chemin d'accès et la langue selon le Windows employé (dans mon cas : "C:\Program Files (x86)\Common Files\...")

Au point 4.,
les éléments MS Jet 3.5 sont récupérables ici : http://support.microsoft.com/kb/172733
ou plus directement ici : http://download.microsoft.com/download/office97pro/sp/1....
L'exécutable fait l'installation, donc rien à ajouter sur ce point.

Au point 5. OK ça marche !

Un grand merci car ça ne s'invente pas par hasard, ce genre de solutions.

PAA.

Anonyme
a b 6 Logiciels
20 Octobre 2010 02:42:22

Bonsoir à tous!

Je suis dans le cas de beaucoup j'ai l'impression... J'ai Architecte 3D Expert Autocad 2010 et suis sous windows 7 avec un sony VAIO VPC, tout fonctionnait très bien jusqu'à ce soir...

Je lance le logiciel et:

Paramètres d'initialisation de base de données
Aucune Base de données n'a été sélectionnée.
Base de données descriptible
*.mdb

Annuler, second message d'erreur, Annuler et mon projet s'ouvre. Mais là!!! Plus aucun meuble, plus de textures... Bref plus grand chose... juste une ossature...

J'ai réalisé la manip préconisée par koobaya ok à toutes les étapes...

J'ai tenté de mettre des meubles, enregistrer le projet, de quitter le logiciel puis réouvrir le projet. Ok les objets sont là.

Merci koobaya!!! Le logiciel fonctionne de nouveau!!!

MAIS... Tous mes projets sont vides... :( 

1ère Question: Puis-je retrouver mes projets à l'état initial ou dois je tout recommencer?

2ème Question: Cela risque-t-il de se reproduire? Cela voulant dire qu'il se peut que je rebosse 100heures sur un projet et qu'il plante?

Merci par avance à tous pour votre aide!!!
10 Novembre 2010 15:48:20

Bonjour,

Je confirme également:

Configuration: Windows 7 édition Familiale prémium 64 bits.
J'avais perdu toutes mes bases de données dans 3 logiciels de Micro Application:
_ réf: 3339 (Architecte 3D 2001),
_ réf: 9006 (Architecte Pro 2008),
_ réf: 1257 (Architecte Expert CAD 2009).
Un grand MERCI à Koobaya pour sa procédure et Merci à PAA pour son complément d'information et confirmation.
Pour moi ça fonctionne à nouveau, ces 3 logiciels sur le même poste sous cette configuration.
Pour les novices dont je fais parti, les 2 points délicats dans la procédure de Koobaya sont:
la décompression de la dll DAO350.dll et la commande DOS.
Avec de la patience, de la persévérance, un peu de réflexion, un peu d'expérience, de la chance, de la volonté, des directives de personnes qui ont le savoir, on peut parvenir au résultat, la preuve, merci à tous.
En souhaitant que ce soit utile à quelqu'un, je signale que les 3 *.dll MSJ*35.dll sont présentent dans le répertoire C:\Windows\SysWOW64, je les ai copiées de ce répertoire et collées vers C:\Windows\system32.
toujours pour les novices, Penser toujours à sauvegarder tous ce que l'on cré (textures, meubles, portes et fenêtres, vérandas, décorations de plinthes et corniches ect..), ces éléments restent internes aux logiciels, en cas de formatage ou de désinstalation, sans sauvegarde c'est perdu, ne pas jeter les logiciels Architecte de Micro Application à la poubelle, pas de problèmes pour trouver plus cher dans la concurence, mais je ne crois pas que c'est mieux ou équivalent en qualité. (Ce n'est que mon avis).
à nouveau Merci et félicitations!!

Bernard Fèvre.
16 Juin 2011 10:29:46

Bonjour,

Le post date légèrement :whistle: 

Je ne dois pas être très douée vu qu'apparemment ça a marché pour tout le monde sauf pour moi.

J'ai donc la version architecture d'intérieur 3D 2005. Sur mon vieux PC, tout marché nickel. Mais depuis que j'ai le nouveau PC, plus moyen d'avoir les objets. Sur les deux PC j'ai la même version de windows (2003).

J'ai bien réalisée la manip de Koobaya mais je n'arrive toujours pas à avoir mes objets. Si quelqu'un a une idée d'où ça peut venir ou d'une étape que j'aurais ratée.

Merci d'avance à tous
16 Juin 2011 12:47:22

Bonjour,

Malheureusement, je ne peux pas vous donner la solution, je n'en suis pas capable.
Je peux seulement vous dire comment je me suis pris pour réaliser cette manipulation.
J'ai imprimé les 2 marches à suivre afin de n'en faire qu'une seule, pour pouvoir suivre au plus près l'application des directives.
Avant tout assurez-vous que votre logiciel soit bien de chez Micro Application, que le problème que vous rencontrez est bien celui qui est décrit.
Que vous avez sur votre machine un OS Windows XP ou ViSTA ou Windows 7. Enfin que votre machine soit en état normale, c'est à dire sans virus, que votre base de registre est bien propre. La manip est quand même assez délicate si on ne connait pas bien et si l'on pratique peu dans ce domaine. D'une machine à une autre les résultats peuvent être très différent. Comme j'ai dit dans mes remerciements aux personnes qui ont travaillé sur ce problème et qui ont donné la solution, j'ai eu certainement une part de chance qui est intervenue. Donc patience, réflexion, Persévérence, calme pour nous qui n'avons la maîtrise de cet outil peut conduire au résultat. l'entre aide entre personnes peu également faire aboutir, seul avec une seule machine ce n'est pas facile. il est certain que si l'une des étapes n'a pas été réalisée ou n'a pas aboutit, ça ne fonctionne pas. le mieux est de s'adresser à une personne qui travaille dans ce domaine qui va sous dos pratiquement tous les jours, à qui la base de registre n'a pas de secret.
Je me suis adressé directement au service technique de Micro Application en disant que j'étais d'accord pour me procurer un nouveau logiciel, la réponse a été: votre configuration n'est pas compatible (Windows 7 64 bits) avec nos logiciels.
Je suis désolé, je vous souhaite bon courage, bon travail, L'informatique à ce niveau est un puit sans fond, pour de simples utilisateurs de l'outil, c'est l'inconu.

Bernard.
25 Août 2012 17:02:23


PROBLEME D'OUVERTURE DES BASES DE DONNEES D'ARCHITECTE 3D 2001 (Version n°3339) POUR WINDOWS SEVEN

Installer ARCHITECTE 3D 2001 normalement

Copier la dll "dao350.dll" dans C:\Program Files (x86)\Common Files\microsoft shared\DAO

Copier les dll "msjet35.dll", "msjter35.dll" et "msjint35.dll" dans le dossier "Architecte 3D 2001"contenant le programme "TDesign4Pro.exe"

-> Ces quatre fichiers peuvent se télécharger facilement sur Internet

Ouvrir une invite de commandes DOS en tant qu'administrateur (clique droit sur l'icône d'invite de commande et choisir "Exécuter en qu'administrateur"

Taper la commande : regsvr32 "C:\Program Files (x86)\Common Files\microsoft shared\DAO" et lancer (enter)

Si tout est correct un message apparait : "DLLRegisterServer dans C:\Program Files (x86)\Common Files\microsoft shared\DAO\dao350dll réussi"

Ouvrir ARCHITECTE 3D 2001 et vérifier que tout est rétabli
1 Septembre 2012 19:49:39

ERRATUM
La ligne de commande de mon message précédent est incomplète
Il faut taper : regsvr32 "C:\Program Files (x86)\Common Files\microsoft shared\DAO\dao350.dll" (avec les ")
En fait, il faut taper exactement le chemin partant de C: pour aller jusqu'à l'emplacement où vous avez mis la bibliothèque "dao350.dll". Vous pouvez le vérifier dans l'explorateur et je vous le recommande car selon les systèmes il peut y avoir quelques différences. Par exemples "Fichiers communs" à la place de "Commun Files"
Mille excuses
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS