Se connecter / S'enregistrer
Votre question

Algorithme toujours pas resolu

Tags :
  • Sec
  • Programmation
Dernière réponse : dans Programmation
29 Mai 2011 19:53:31

Bonjour à tous ,
en ce moment je travaille sur un algorithme permettant la conversion seconde ou minute en heure-minute-seconde.


voici l'algo , le problème qui se pose cest que par exemple lorsque j'entre une valeur 3600 et jmet seconde comme unite au lieu de mettre 1h il me met 60 min et 60 seconde ( double erreur : deja il y a le faite qu'il ne devrait pas afficher 60 minute mais une heure et ensuite il y a le faite qu'il y a toujours des secondes qui se promennent le résultat est donc faut " il calcule mal" voila si vous pouviez m'aidez merci

ps : c'est le meme problème pour les secondes et les minutes

convertir seconde ou minute en heure-minute-seconde.

1 VARIABLES
2 Seconde EST_DU_TYPE NOMBRE
3 minute EST_DU_TYPE NOMBRE
4 heure EST_DU_TYPE NOMBRE
5 Durée EST_DU_TYPE NOMBRE
6 UNITE EST_DU_TYPE CHAINE
7 DEBUT_ALGORITHME
8 AFFICHER "entrez votre valeur"
9 LIRE Durée
10 AFFICHER "entrez l'unité (seconde ou minute)"
11 LIRE UNITE
12 SI (UNITE=="seconde" ) ALORS
13 DEBUT_SI
14 Seconde PREND_LA_VALEUR Durée%60
15 minute PREND_LA_VALEUR floor(Durée/60)
16 Seconde PREND_LA_VALEUR minute+Seconde
17 AFFICHER "le resultat est "
18 AFFICHER minute
19 AFFICHER " min "
20 AFFICHER Seconde
21 AFFICHER " sec"
22 SI (Seconde >= 3600) ALORS
23 DEBUT_SI
24 Seconde PREND_LA_VALEUR heure+minute+Seconde
25 heure PREND_LA_VALEUR minute*60
26 AFFICHER "le resultat est "
27 AFFICHER heure
28 AFFICHER "h"
29 AFFICHER minute
30 AFFICHER "min"
31 AFFICHER Seconde
32 AFFICHER "sec"
33 FIN_SI
34 FIN_SI
35 SI (UNITE=="minute" ) ALORS
36 DEBUT_SI
37 minute PREND_LA_VALEUR Durée%60
38 heure PREND_LA_VALEUR floor(Durée/60)
39 minute PREND_LA_VALEUR heure+minute+Seconde
40 AFFICHER "le resultat est "
41 AFFICHER heure
42 AFFICHER "h"
43 AFFICHER minute
44 AFFICHER "min"
45 AFFICHER Seconde
46 AFFICHER "sec"
47 FIN_SI
48
49 FIN_ALGORITHME

Autres pages sur : algorithme resolu

3 Juin 2011 17:12:04

  1. 13 DEBUT_SI
  2. 14 Seconde PREND_LA_VALEUR Durée%60 => ligne 16, Seconde est écrasée. Donc ligne 14 inutile
  3. 15 minute PREND_LA_VALEUR floor(Durée/60)
  4. 16 Seconde PREND_LA_VALEUR minute+Seconde
  5. 17 AFFICHER "le resultat est "
  6. 18 AFFICHER minute
  7. 19 AFFICHER " min "
  8. 20 AFFICHER Seconde
  9. 21 AFFICHER " sec"
  10. 22 SI (Seconde >= 3600) ALORS
  11. 23 DEBUT_SI
  12. 24 Seconde PREND_LA_VALEUR heure+minute+Seconde =>heure Jamais initialisée
  13. 25 heure PREND_LA_VALEUR minute*60
  14. 26 AFFICHER "le resultat est "
  15. 27 AFFICHER heure
  16. 28 AFFICHER "h"
  17. 29 AFFICHER minute
  18. 30 AFFICHER "min"
  19. 31 AFFICHER Seconde
  20. 32 AFFICHER "sec"
  21. 33 FIN_SI
  22. 34 FIN_SI
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS