Se connecter / S'enregistrer
Votre question

Besoin d'une formule pour excel 2003

Tags :
  • Microsoft Excel
  • Logiciels
Dernière réponse : dans Logiciels
10 Janvier 2011 14:09:45

Bonjour,
j'ai créer une formule sur deux dates pour savoir le nbre de jours entre les 2 dates. dans le cas où il n'y a qu'une date, il faut que le calcul se fasse par défaut et mettre -1
=NB.JOURS.OUVRES($E24;$C24);
=SI(ESTVIDE($E24);"";"-1")
mais cela ne marche pas, merci de votre aide !
verolyde

Autres pages sur : besoin formule excel 2003

a b 6 Logiciels
10 Janvier 2011 15:23:26

tu ne peux pas mettre deux "=" dans une formule, il faut les combiner.

exemple :
=SI(ESTVIDE($E24);"-1" ;NB.JOURS.OUVRES($E24;$C24))
m
0
l
10 Janvier 2011 16:12:26

Merci de cette 1ère solution, mais je dois y inclure plusieurs autres conditions :

si A2 est vide, ne rien inscrire nulle part
si A2 est rempli et dans C2 il y a une seule date, calculé en J2 mettre résultat = -1
si A2 est rempli et dans C2 et E2, il y a 2 dates, calculé en J2 mettre résultat =SI(ESTVIDE($E24);"-1" ;NB.JOURS.OUVRES($E24;$C24))

A2 B2 C2 D2 E2 F2 G2 H2 I2 J8

CP DU 06/01/11 AU 17/01/11 10/01/11 S. GOURDON -8
RTT DU 06/01/11 10/01/11 S. GOURDON -1
1/2 RTT DU 06/01/11 10/01/11 S. GOURDON -0,5

Merci de ton aide !

Verolyde
m
0
l
Contenus similaires
10 Janvier 2011 16:15:40

Peut on envoyer une piece jointe ou une image pour voir mieux le pb ?
m
0
l
a b 6 Logiciels
10 Janvier 2011 16:38:33

Et bien tu combines, dans excel 2003, tu peux combiner jusqu'à 7 formules.
m
0
l
10 Janvier 2011 17:19:33

Merci mais comment les imbriquer, j'ai essayé mais cela ne marche pas !

=SI(ESTVIDE($A24);"";NB.JOURS.OUVRES($E24;$C24));(($A24);"½ RTT";"-0,5");

S'il y a une seule date en C24 on considère une seule journée -1

Voilà, j'espère être assez claire.

Merci d'avance

vérolyde
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS