Se connecter / S'enregistrer
Votre question

[Résolu]La commande Start ne démarre pas l'application.

Tags :
  • Copier coller
  • Windows 7
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
5 Novembre 2011 21:55:07

Bonjour

J’ai installé un logiciel qui démarre très bien, soit avec son icône, soit en le lançant depuis son exécutable dans C:

Par contre, quand j’essaie de le lancer avec un Batfile, la fenêtre de l’invite de commande s’ouvre normalement mais le logiciel n’est pas lancé, avec :
  1. "C:\Program Files (x86)\Handicap International\ClavicomNG\ClavicomNG.exe"

qui est exactement ce qui se trouve dans les Propriétés de l’icône, qui lance bien le logiciel.

J’ajoute que je lance sans problème d’autres logiciels avec un Batfile exactement de cette manière.

Merci par avance de votre aide.

Francois

Autres pages sur : start demarre

5 Novembre 2011 22:30:57

Bonsoir,

La commande pour lancer des .exe depuis un fichier batch est : Start

Essaye donc avec :
Sart "C:\Program Files (x86)\Handicap International\ClavicomNG\ClavicomNG.exe"

Laisse bien les guillemets, ils sont nécessaires à cause des espaces dans le chemin d'accès au programmes.

Au plaisir !
6 Novembre 2011 12:33:24

bonjour et merci de ton message.

J'ai essayé en ajoutant start et en laissant les guillemets: ça a ouvert une deuxième fenêtre de l'invite de commande mais ça n'a pas lancé le logiciel.

Le sujet reste entier.

Francois
Contenus similaires
6 Novembre 2011 13:19:54

Bonjour, :hello: 

Vérifie le chemin d'accès.
Le "Program files x86" ne serait pas "Program files" tout court ?
Quel est ton système ? (XP, Vista, Seven ....)
6 Novembre 2011 14:23:06

J'utilise exactement (copier / coller) ce qui se trouve dans les Propriétés de l'icône.

Je suis en Win7.

Francois
6 Novembre 2011 15:20:57

Re,

On va y arriver :) 

Essaye en enlevant les guillemets.
Voici une page listant les paramètres de la commande Start : Commande Sart

Allez, allez, on ne désespère pas, il y a un solution ! ;) 
6 Novembre 2011 17:53:57

J'ai essayé sans guillemets: ça plante, sans surprise.

Je fais mes essais sur 2 PC, l'un en WinXP et l'autre en Win7 pour le même résultat = la commande est bien exécutée dans l'invite de commande mais le logiciel n'est pas démarré.

De plus, je lance très bien d'autres logiciels, comme Skype, de cette manière, sans souci.

Je suspecte que ce logiciel a une propriété qui empêche le lancement par un batfile.

Francois
6 Novembre 2011 18:57:08

Re,

Peut-être en utilisant le paramètre /separate , la commande devient donc :
Sart /separate "C:\Program Files (x86)\Handicap International\ClavicomNG\ClavicomNG.exe"
ou le paramètre /shared et donc :
Sart /shared "C:\Program Files (x86)\Handicap International\ClavicomNG\ClavicomNG.exe"

Vli, vlou, vlà, après, je ne sais pas !

PS :je me renseigne quant au programme ClavicomNG ;) 

Autre idée : il faut peut-être un répertoire d'exécution, donc avoir comme commande :
Sart /"C:\Program Files (x86)\Handicap International\ClavicomNG" "C:\Program Files (x86)\Handicap International\ClavicomNG/ClavicomNG.exe"
6 Novembre 2011 20:36:11

J'ai essayé tes 3 propositions mais:
- les 2 premières ouvrent une deuxième fenêtre DOS sans lancer le programme
- la 3e proposition provoque un message d'erreur: Invalid option

Merci de ton aide.

Francois
6 Novembre 2011 21:13:23

Bonsoir,

Je suis désolé pour toi mais là, je ne vois pas de solution !
Si une idée me venait, je viendrais te la proposer ici.
Mais pour le moment, je suis à court.

J'en suis autant désolé que j'ai l'impression que c'est pour une bonne cause que tu cherches à réaliser ce Batchfile !

Je te souhaite de trouver la solution.

Au plaisir.
6 Novembre 2011 22:33:28

Merci encore de ton aide.
Oui, j'essaie de permettre le lancement de ce bon clavier virtuel de manière simple pour une personne handicapée.
S'il te venait une idée, je serais naturellement preneur.
Francois
7 Novembre 2011 13:54:10

Blup,

Hop, j'ai une idée, essaye ce batchfile :
Citation :

echo off
cd "C:\Program Files (x86)\Handicap International\ClavicomNG\ClavicomNG.exe"
start ClavicomNG.exe

Pas sûr que ça marche, mais si on essaye pas ....
Il faudra peut-être enlever les guillemets de la ligne cd
et/ou enlever le start devant ClavicomNG.exe
A essayer donc...

Au plaisir !
7 Novembre 2011 14:02:02

salut,

Tu peux toujours vérifier la syntaxe en essayant avec un autre .exe . Sinon essayes de démarrer ton .bat à la main en mode administrateur pour voir si ça vient de la.
7 Novembre 2011 22:31:18

J'ai essayé en 2 lignes dans le batfile avec cd comme tu le proposes: sans succès.

Par contre, quand je passe par Démarrer / Exécuter / cmd pour ouvrir l'invite de commande et que je fais exactement la même chose, en deux lignes avec cd: ça fonctionne.

Une question: pourquoi Non en batfile et Oui en invite de commande?

Francois
8 Novembre 2011 18:14:55

Bonsoir,

As-tu essayé comme le dit tom hoogata de lancer le fichier .bat avec les doits administrateur (clic droit, exécuterr en tant que) ?

Ou de désactiver l'UAC (temporairement) : Désactiver UAC
Au cas où tu serais tenté de ne pas remettre l'UAC: Pourquoi ne pas désactiver l'UAC

Tiens nous au courant.

Au plaisir.
8 Novembre 2011 22:06:21

L'essai qui marche:
cd /d "C:\Program Files\Handicap International\ClavicomNG\"
start ClavicomNG.exe

Merci de votre aide obstinée, pour la bonne cause.

Francois
9 Novembre 2011 14:08:04

Whaouuuu ! :bounce: 

Super cool ! Enfin au bout de tes peines !

Merci à toi aussi !

PS : tu peux mettre [Résolu] au titre de ton sujet en :

  • Editant ton 1er message
  • ou en choisissant "une meilleure réponse"

  • :hello: 
    9 Novembre 2011 18:06:16

    Voila, j'ai édité le titre de mon 1er message.

    Merci encore de ton aide.

    Francois
    9 Novembre 2011 23:31:01

    Bonsoir, :hello: 

    Met plutôt ce titre (avec les crochets ;) ):

    [Résolu]La commande Start ne démarre pas l'application.

    Ce sera plus facile à retrouver la solution plustard pour un autre internaute ;) 

    Au plaisir
    11 Novembre 2011 13:56:53

    Ta remarque est très judicieuse, voila, c'est fait.

    Francois
    12 Novembre 2011 12:41:06

    Parfait ;) 
    Tom's guide dans le monde
    • Allemagne
    • Italie
    • Irlande
    • Royaume Uni
    • Etats Unis
    Suivre Tom's Guide
    Inscrivez-vous à la Newsletter
    • ajouter à twitter
    • ajouter à facebook
    • ajouter un flux RSS