Se connecter / S'enregistrer
Votre question

[RESOLU]Problème ajax et internet explorer

Tags :
  • Ajax
  • Internet Explorer
  • Php
  • Programmation
Dernière réponse : dans Programmation
6 Mars 2012 09:04:11

J'ai 2 pages .php

-index.php
-accueil.php

Les liens js vers une fonction ajax de la page index.php fonctionnent
mais le même lien à peu de chose près sur accueil.php ne fonctionne pas.

Fonction sur index.php
  1. //<![CDATA[
  2. function init(tables)
  3. {
  4. $.get("accueil.php",{"rub":tables},processResult);
  5. }
  6. function init2(rub,nbre)
  7. {
  8. $.get("accueil.php",{"rub":rub,"nbre":nbre},processResult);
  9. }
  10. function panier(commande,id,prix,u)
  11. {
  12. $.get("cmd.php",{"commande":commande,"id":id,"prix":prix,"u":u},processResult2);
  13.  
  14. }
  15. function processResult(data, textStatus)
  16. {
  17.  
  18. $('#visit').hide();
  19. $('#visit').fadeIn("slow");
  20. $("#visit").html(data);
  21. }
  22. function processResult2(data, textStatus)
  23. {
  24.  
  25. $('#panier').hide();
  26. $('#panier').fadeIn("slow");
  27. $("#panier").html(data);
  28. }
  29.  
  30.  
  31. //]]>


Lien index.php vers fonction index.php==>Marche
  1. <ul id="menu">
  2. <li class="li1"><a href="">Accueil</a></li>
  3. <li class="li2"><a href="#" onclick="init('epice');">Épices</a></li>
  4. <li class="li1"><a href="#" onclick="init('melange');">Mélange</a></li>
  5. <li class="li2"><a href="#" onclick="init('tout_pret');">Tout prêt</a></li>
  6. <li class="li1"><a href="#" onclick="init('the');">Thés</a></li>
  7. <li class="li2"><a href="#" onclick="init('tisane');">Tisanes</a></li>
  8. <li class="li1"><a href="aff_recette.php">Recettes</a></li>
  9. <li class="li2"><a href="#" onclick="init('composition');">Compositions</a></li>
  10. <li class="li1"><a href="#" onclick="init('fleur');">Fleurs de Bach</a></li>
  11. </ul><br />


Lien accueil.php vers index.php==>Marche pas
  1. <tr>
  2. <td colspan="5" align="center"><a href="#" onclick="init2('<?php echo $_GET['rub']; ?>',15)" target="_parent">Suivant</a></td>
  3. </tr>


Sur les autres navigateurs sa tourne sans problème mais sur I.E. Sa me ramène à l'index original.

Autres pages sur : resolu probleme ajax internet explorer

a c 232 L Programmation
a b , Internet Explorer
6 Mars 2012 09:31:43

Hello,

J'ai pas bien compris ton problème là...
Tes fonctions JS tu les as bien dans ta page accueil.php aussi ?
6 Mars 2012 09:45:32

OmaR a dit :
Hello,

J'ai pas bien compris ton problème là...
Tes fonctions JS tu les as bien dans ta page accueil.php aussi ?


Non mais la page accueil est chargée sur la page index dans un div

Contenus similaires
a c 232 L Programmation
a b , Internet Explorer
6 Mars 2012 09:56:56

Si tu enlèves le target="_parent" ??
6 Mars 2012 10:13:50

OmaR a dit :
Si tu enlèves le target="_parent" ??


Sa marche nikel,

Merci.
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS