Se connecter / S'enregistrer
Votre question

Probleme avec Easy php

Tags :
  • Php
  • Apache
  • MySQL
  • Easyphp
  • Programmation
Dernière réponse : dans Programmation
30 Avril 2012 09:34:29

Bonjour

Voilà j'ai un gros souci avec Easy php qui ne veut pas marcher pour moi

Apache et Mysql sont bien en marche mais quand je tape l'adresse 127.0.0.1 ou localhost une petite icone surgit dans l'onglet de la page marquant le chargement de la page, peu importe le temps que j'attend ça n'affiche rien du tout, c'est comme si ça cherchait sans trouver rien du tout !

J'ai essayer de le reinstaller et avec wamp serveur aussi & J'ai beau essayer de changer le numéro de port de le fichier httpd.conf genre de 127.0.0.1:80 vers 127.0.0.1:8086 puis la taper sur la barre d'adresse mais tous mes efforts partent en vain

J'ai vérifié le fichier log (error apache) et ça donne ça :

[Mon Apr 23 12:34:46 2012] [notice] Parent: Received restart signal -- Restarting the server.
[Mon Apr 23 12:34:46 2012] [notice] Child 5128: Exit event signaled. Child process is ending.
[Mon Apr 23 12:34:46 2012] [notice] Apache/2.2.21 (Win32) PHP/5.3.9 configured -- resuming normal operations
[Mon Apr 23 12:34:46 2012] [notice] Server built: Sep 10 2011 11:34:11
[Mon Apr 23 12:34:46 2012] [notice] Parent: Created child process 3420
[Mon Apr 23 12:34:46 2012] [notice] Child 3420: Child process is running
[Mon Apr 23 12:34:47 2012] [notice] Child 3420: Acquired the start mutex.
[Mon Apr 23 12:34:47 2012] [notice] Child 5128: Released the start mutex
[Mon Apr 23 12:34:47 2012] [notice] Child 3420: Starting 64 worker threads.
[Mon Apr 23 12:34:47 2012] [error] (OS 10038)Une opération a été tentée sur autre chose qu'un socket. : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Mon Apr 23 12:34:48 2012] [notice] Child 5128: All worker threads have exited.
[Mon Apr 23 12:34:48 2012] [notice] Child 5128: Child process is exiting



et avec error mysql :

120423 12:34:46 [Note] C:\PROGRA~2\EASYPH~1.9\MySql\bin\mysqld.exe: Arrêt normal du serveur

120423 12:34:46 [Note] Event Scheduler: Purging the queue. 0 events
120423 12:34:46 InnoDB: Starting shutdown...
120423 12:34:46 InnoDB: Shutdown completed; log sequence number 1595675
120423 12:34:46 [Note] C:\PROGRA~2\EASYPH~1.9\MySql\bin\mysqld.exe: Arrêt du serveur terminé

120423 12:34:47 [Note] Plugin 'FEDERATED' is disabled.
120423 12:34:47 InnoDB: The InnoDB memory heap is disabled
120423 12:34:47 InnoDB: Mutexes and rw_locks use Windows interlocked functions
120423 12:34:47 InnoDB: Compressed tables use zlib 1.2.3
120423 12:34:47 InnoDB: Initializing buffer pool, size = 128.0M
120423 12:34:47 InnoDB: Completed initialization of buffer pool
120423 12:34:47 InnoDB: highest supported file format is Barracuda.
120423 12:34:47 InnoDB: Waiting for the background threads to start
120423 12:34:48 InnoDB: 1.1.8 started; log sequence number 1595675
120423 12:34:48 [Note] Event Scheduler: Loaded 0 events
120423 12:34:48 [Note] C:\PROGRA~2\EASYPH~1.9\MySql\bin\mysqld.exe: ready for connections.

Autres pages sur : probleme easy php

a c 232 L Programmation
30 Avril 2012 11:54:51

Salut,

Est-ce que ça viendrait pas de ta page qui a une boucle infinie par exemple ?
Essaie de mettre une page toute simple au départ qui a juste par exemple:
  1. <? echo "ça marche"; ?>


Et tu vois si ça marche déjà avec une page toute simple. Si ça marche pas, c'est que c'est certainement le serveur qui a un problème oui.
m
0
l
30 Avril 2012 12:03:56

J'ai testé mais ça ne marche pas :( 

NB : Effectivement comme tu l'a dis, lors du chargement de la page c'est comme s'il y'avait une boucle infini qui empechait la page de finir son chargement, mais vu que la seul page existante dans le répertoire www ne comprend qu'une seule page dont le contenu est le code que vous m'avez proposé, dans ce cas là on peut exclure la controverse de la boucle infini !
m
0
l
Contenus similaires
a c 232 L Programmation
30 Avril 2012 13:58:47

Hmm, il faut aussi noter que pour afficher la page par défaut, il faut qu'elle s'appelle index.php ta page, sinon il ne va pas l'afficher par défaut.
Si tu veux afficher la page accueil.php, il faut mettre http://localhost:8086/accueil.php
m
0
l
1 Mai 2012 08:33:09

j'avais déjà une page nommé index.php dans mon ancien répertoire, mais après lu votre suggestion j'ai supprimer le répertoire contenant toutes mes pages & essayer votre méthode avec une seule page index.php ne comprenant qu'un message d'echo. Mais ça n'a malheureusement pas marché !

Quand à l'url http://localhost:8086/index.php ça me donne une erreur dans la page, genre google chrome n'a pas pu ouvrir cette page, et je soupçonnait le numéro de port comme cause de l'erreur, donc j'ai décider de changer de 8086 vers 80 et ça a retourné à l'ancien état, une page blanche avec l'icone d'actualisation dans l'onglet de la fenêtre :( 

m
0
l
a c 232 L Programmation
1 Mai 2012 11:37:40

J'ai plus EasyPHP sous la main, mais tu dois pouvoir faire un clic droit sur l'icône et afficher le serveur normalement.
m
0
l
2 Mai 2012 04:25:37

J'ai déjà essayé ça aussi :( 
m
0
l
2 Mai 2012 12:11:00

Non, mais je viens tout de même de l'essayer et ça n'a pas marché pour moi !!

Ceci dis je ne comprend pas pourquoi mettre 8086 vu que j'ai le numéro de port 80 pour le serveur ?
m
0
l
a c 232 L Programmation
2 Mai 2012 12:36:42

Remplace 8086 par ton port bien évidemment... Vu que tu l'as déjà changé plusieurs fois, je sais plus c'est quoi, alors je met au pif...
L'important étant de mettre 127.0.0.1 au lieu de localhost
m
0
l
3 Mai 2012 04:43:41

ça ne marche pas non plus :(  le même problème on dirait comme si la page était entrain de boucler d'une façon infini !
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS