Votre question

Excel : formule SI + RECHERCHEV

Tags :
  • element
  • Logiciels
Dernière réponse : dans Logiciels
29 Avril 2005 14:21:57

Hello !
Comment libellez-vous la formule suivante :

=RECHERCHEV(A7;'Résultat SAP 01-03.2005'!$A$1:$E$800;4;0)

en y ajouter un SI... J'aimerais que si la recherche n'aboutit pas, excel mentionne 0, sinon, le résultat de la recherche et non pas #N/A, élément qui ne s'additionne évidement pas....

Heu... ça serait super sympa de me répondre parce que ma base fait "juste" 4800 cellules... ;-)

D'ores et déjà un grand merci et coucou à Sylvain2 !!!

Autres pages sur : excel formule recherchev

29 Avril 2005 14:35:19

Slt ,

Ta formule
recherche la cellule A7 dans le fichier Excel
'Résultat SAP 01-03.2005' (SAP ??? l'ERP?? )
dans les cellules A1 à E800 , s'il il trouve une correspondance il récupère la cellule de la 4ème colonne. sinon 0

essaye de mettre dans ton sinon '0' ou "0" .
29 Avril 2005 14:39:20

Bon, directement j'y arrive pas :(  Mais je te propose une solution

créer une colonne à coté de ton résultat et utiliser la fonction
disons que ton résultat se trouve en B2

=si(estnum(B2);B2;0)
Contenus similaires
29 Avril 2005 14:41:18

pareil , en fait j'y arrive pas en direct ,
les '0' et "0" dans le sinon ne marche pô ...


j'essaye de checher quand même un peu
29 Avril 2005 14:48:08

Bon ,

sinon tu peux ajouter une ligne à ton fichier qui fera donc 801 ligne et en cellule E801 tu met la valeur 0
puis dasn ta formule tu ne pas de test sinon ce qui te donne comme formule
=RECHERCHEV(A7;'Résultat SAP 01-03.2005'!$A$1:$E$801;4)

et là , à chaque fois qu'il ne trouve pas l'info il mettra 0
29 Avril 2005 15:00:06

Très bonne idée, mais si dans ses cellules de référence, il y a un zéro, çà risque de lui envoyer #N/A . Le test a quand même son importance...
29 Avril 2005 15:04:15

Oui , tu as raison,

il à pas l'air de s'impliquer beaucoup TINKER

Allo Tinker ....
29 Avril 2005 15:26:09

Je suis là !!!! J'essaie de rechercher des infos sur Google, mais pour le moment, rien trouver qui fait mon affaire....
29 Avril 2005 15:29:01

Hello,

Le si il faut le mettre au début et imbriquer le résultat de la recherv.

Donc tu poses comme condition si la valeur recherchée se trouve dans la colonne en question.

:-D :-P :-D :-P :-D
29 Avril 2005 15:39:45

yendis : j'aimerais que si excel NE trouve PAS une valeur, il me mentionne 0...
Pour le moment, quand il ne trouve pas il met par défaut #N/A...

En admettant que je crée une colonne supplémentaire, je mets ma fonction RECHERCHEV. J'ai donc soit des chiffres, soit #N/A. Dans la colonne qui doit être additionnée, je mets la fonction SI... mais dès que la cellule de référence est #N/A, je n'arrive pas à "lui dire de mettre" 0...

Pfff... Excel c'est génial...quand ça fonctionne ;-)

Chui pas sûr que vous me suivez sur ce coup... :-o
29 Avril 2005 15:59:01

Tinker, la solution que je t'ai proposé ci-dessus fonctionne !
29 Avril 2005 16:08:36

Ari59... t'es un Chef !!!

Je vais faire tout mon tableau, et je contrôlerais les totaux...

Pfff...merci Excel...et merci Ari59 !
22 Août 2005 15:26:55

Alors je te propose d'utiliser la fonction: esterreur, fonction qui renvoie vrai ou faux.

=si(esterreur(RECHERCHEV(A7;'Résultat SAP 01-03.2005'!$A$1:$E$800;4;0));"0";RECHERCHEV(A7;'Résultat SAP 01-03.2005'!$A$1:$E$800;4;0));

;-)

Voila, ça t'évite d'utiliser 2 colonnes.

++
22 Août 2005 15:30:43

Je traduit vite fait ma formule:

Si, il y a une erreur dans la fonction recherchev, alors j'affiche "0" sinon, je calcule ma fonction recherchev ...

a ce propos, enléve les guillemets autour de 0 car sinon, il va l'écrire en texte et pas en chiffre (a priori mais je suis pas sur, dans le doute ...) ;-)
12 Février 2007 18:58:31

Pour ceux qui tombent encore sur ce sujet, et que la solution citée précédemment ne satisfait pas, il existe la fonction ESTNA(valeur) qui renvoie VRAI si valeur est #N/A et FAUX sinon.
31 Mai 2007 14:44:28

sinon tu peux essayer la fonction ESTNA ca marche tres bien


la formule est la suivante: =SI(ESTNA(RECHERCHEV(A7;'Résultat SAP 01-03.2005'!$A$1:$E$800;4;0);"0";RECHERCHEV(A7;'Résultat SAP 01-03.2005'!$A$1:$E$800;4;0)))

ca va surement marcher

la fonction esterreur n'est pas approprié car il n'y a pas d'erreur dans la formule n/a correspond a une valeur non trouvée dans le tableau de reference...

ciao
25 Juillet 2007 11:21:26

Besoin d'aide.....
Ayant passé pres d'une heure à me mordre les ongles avec une formule.. jaurai besoin de votre precieuse aide
Jai besoin d 'une formule si avec 5 conditions décrites ci dessous

TEST LOG OUI NON
1 eme cond Si j et k = rien Rien (J8-K8)/K8
2 eùe cond Si j>0 et k<0 1-(J8-K8)/K8 Rien
3 eme cond Si j<0 et k>0 (J8-K8)/K8 Rien
4 eme cond Si j et k <0 1-(J8-K8)/K8 Rien
5 eme cond Si j et k >0 (J8-K8)/K8 rien



Jai une formule pour linstant qui fonctionne mais qui neffectue pas les taux de variations négatif

SI(NBCAR(L8)=0;"";SI(ET(L8>=0;L8<=1);"J";SI(L8<0;"N";SI(L8>1;"JJ"))))....

Merci de m'aider
26 Novembre 2007 18:54:43

Bonjour,
je ne sais pas si vous pouvez m'aider mais je suis bloqué sur la recherche v jai une facture à établir et j'ai un client qui a un animal j'ai réussi à faire la recherche v mais elle est basé par rapport au n° de la chambre et moi je le voudrais faire par rapport au nom du client mais quand je l'ai fais excel me dit que c'est faux si vous comprenez pas tout je peux vous envoyer le fichier merci de votre aide à bientot Maelys
2 Avril 2009 17:58:36

slt, Alors pour supp le N/A mettre la valeur 0 dans la Recherche V et lui donner comme valeur un nombre proche de 0 (0.000000001) puis mettre dans le sinon 0 et voila plus de N/A
18 Juin 2009 11:56:08

"Hello !
Comment libellez-vous la formule suivante :

=RECHERCHEV(A7;'Résultat SAP 01-03.2005'!$A$1:$E$800;4;0)

en y ajouter un SI... J'aimerais que si la recherche n'aboutit pas, excel mentionne 0, sinon, le résultat de la recherche et non pas #N/A, élément qui ne s'additionne évidement pas....

Heu... ça serait super sympa de me répondre parce que ma base fait "juste" 4800 cellules... ;-)

D'ores et déjà un grand merci et coucou à Sylvain2 !!! "


Bonjour,
Il faut faire : =SI(ESTERREUR(TA FORMULE);0;FALSE) =>> tous les mesages d'erreur sont remplacés par 0.

Bon courage,
Mamix
5 Septembre 2016 10:43:53

Tinker a dit :
Hello !
Comment libellez-vous la formule suivante :

=RECHERCHEV(A7;'Résultat SAP 01-03.2005'!$A$1:$E$800;4;0)

en y ajouter un SI... J'aimerais que si la recherche n'aboutit pas, excel mentionne 0, sinon, le résultat de la recherche et non pas #N/A, élément qui ne s'additionne évidement pas....

Heu... ça serait super sympa de me répondre parce que ma base fait "juste" 4800 cellules... ;-)

D'ores et déjà un grand merci et coucou à Sylvain2 !!!


Bonjour Tinker!
je crois qu'avec cette formule t'aura le resultat rechercher:

=SI(ESTNA(RECHERCHEV(A7;'Résultat SAP 01-03.2005'!$A$1:$E$800;4;0));0;RECHERCHEV(A7;'Résultat SAP 01-03.2005'!$A$1:$E$800;4;0))

Cette formule permet d'afficher le chiffre 0, à chaque fois que le résultat de la recherche correspondra a #N/A et donnera un résultat si la recherche aboutit.
:D 

:bounce: 
5 Septembre 2016 10:58:35

Tinker a dit :
Hello !
Comment libellez-vous la formule suivante :

=RECHERCHEV(A7;'Résultat SAP 01-03.2005'!$A$1:$E$800;4;0)

en y ajouter un SI... J'aimerais que si la recherche n'aboutit pas, excel mentionne 0, sinon, le résultat de la recherche et non pas #N/A, élément qui ne s'additionne évidement pas....

Heu... ça serait super sympa de me répondre parce que ma base fait "juste" 4800 cellules... ;-)

D'ores et déjà un grand merci et coucou à Sylvain2 !!!


Bonjour à tous!
Par rapport au probleme qu'a rencontrer "Tinker" avec #N/A; je propose ici une solution generale qu'on peut adapter pour soi.

=SI(ESTNA(RECHERCHEV(valeur_cherchée;table_matrice;n°_index_col;valeur_proche));0;RECHERCHEV (valeur_cherchée;table_matrice;n°_index_col;valeur_proche))

PS: le 0 peut être remplacé par un mot spécifique comme "Pas de résultat" ou autre, on peut aussi mettre à la place un vide " ". l'essentiel c'est de ne pas oublié de mettre le commentaire entre guillemet.
;) 
5 Septembre 2016 11:21:24

macni_8 a dit :
Besoin d'aide.....
Ayant passé pres d'une heure à me mordre les ongles avec une formule.. jaurai besoin de votre precieuse aide
Jai besoin d 'une formule si avec 5 conditions décrites ci dessous

TEST LOG OUI NON
1 eme cond Si j et k = rien Rien (J8-K8)/K8
2 eùe cond Si j>0 et k<0 1-(J8-K8)/K8 Rien
3 eme cond Si j<0 et k>0 (J8-K8)/K8 Rien
4 eme cond Si j et k <0 1-(J8-K8)/K8 Rien
5 eme cond Si j et k >0 (J8-K8)/K8 rien



Jai une formule pour linstant qui fonctionne mais qui neffectue pas les taux de variations négatif

SI(NBCAR(L8)=0;"";SI(ET(L8>=0;L8<=1);"J";SI(L8<0;"N";SI(L8>1;"JJ"))))....

Merci de m'aider


voici une formule qui devrait marcher:

SI(ET(J>0 ;K>0) ;(J8-K8)/K8;SI(ET(J>0 ;K<0);1-(J8-K8)/K8;SI(ET(J<0 ;K>0) ;(J8-K8)/K8 ;SI(ET(J<0 ;K<0);1-(J-K8)/K8 ;" "))))

a b 6 Logiciels
6 Septembre 2016 11:48:57

Bonjour
@ mamaray
déterrer un sujet de 2007, je pense donc qu'il a résolu.

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS