Votre question

RPM sur Linux

Tags :
  • linux
  • Logiciels
Dernière réponse : dans Logiciels
11 Septembre 2007 20:51:34

Bonjour,
je télécharge, installe normalement des rpms ils sont correctement installer... Mais je sais pas ou les trouver!!! Comment ouvrir mon programme et créer un raccourcis sur mon bureau?

Je suis sur Mandriva One 2007.1 et j'ai se problème avec tout les rpm (j'ai télécharger zattoo!

Comment faire, où les trouver?

Merci beaucoup
Bonne soirée!

Autres pages sur : rpm linux

11 Septembre 2007 22:29:02

salut, pour avoir la liste des fichiers installés:
rpm -ql nom_du_paquet
12 Septembre 2007 12:49:13

En fait, j'aurrais encore besoin d'aide!

Je n'arrive pas à installer zattoo sur mon Mandriva!

(zattoo.com)

* . Download the deb, rpm or tgz.
o Download Linux Player(.rpm)
Download Linux Player(.tgz)
* 2. Install gtkglext-1.2.0-4.fc6.i386 using your package manager (see distro specific instructions below)
* 3. Check distro-specific instructions below for any other possible pre-requisites
* 4. Install the rpm or deb or unpack the tgz and move everything to the correpsonding location under /usr
* 5. Install xulrunner. We suggest putting the xulrunner in /usr/lib/zattoo. We have a build of xulrunner available or you can download it from mozilla.org.
* 6. Create symbol links from the required (debian) xulrunner library names to the actual names. If you have installed xulrunner in /usr/lib/zattoo, then it would be something like this:
o sudo ln -s /usr/lib/zattoo/xulrunner/libgtkembedmoz.so /usr/lib/zattoo/libgtkembedmoz.so.0d
o sudo ln -s /usr/lib/zattoo/xulrunner/libmozjs.so /usr/lib/zattoo/libmozjs.so.0d
o sudo ln -s /usr/lib/zattoo/xulrunner/libnspr4.so /usr/lib/zattoo/libnspr4.so.0d
o sudo ln -s /usr/lib/zattoo/xulrunner/libplc4.so /usr/lib/zattoo/libplc4.so.0d
o sudo ln -s /usr/lib/zattoo/xulrunner/libplds4.so /usr/lib/zattoo/libplds4.so.0d
o sudo ln -s /usr/lib/zattoo/xulrunner/libxpcom.so /usr/lib/zattoo/libxpcom.so.0d
o sudo ln -s /usr/lib/zattoo/xulrunner/libxul.so /usr/lib/zattoo/libxul.so.0d
* 7. Run ldconfig on the /usr/lib/zattoo directory with something like "sudo /sbin/ldconfig /usr/lib/zattoo"
* 8. Download and install the Adobe Flash plugin from http://www.adobe.com
* 9. Follow any distro specific instructions below.

Pouvez vous m'aider? Parce que même en traduisant sur google j'ai beaucoup de peine à comprendre!

Merci beaucoup
Contenus similaires
12 Septembre 2007 14:06:41

Bon écoutez.... Je sais vraiment pas pourquoi ni comment... MAIS j'arrive pas à installer un logicilel sur Linux.
Seul Audacity j'ai réussi et par le mirroir que j'ai configurer sur easy.urpmi je crois un truck comme ça...

Et comme je trouve prèsque aucun programme sur le mirroir switch (suisse) je suis obliger d'installer par tar.gz ou rmp... mais je sais pas comment!

J'arrive pas! J'ai beau tout essaier... mais rien a faire... j'arrive pas!!!

Comment faire???

Merci beaucoup!
12 Septembre 2007 14:12:24

Salut,

Il ne faut pas s'énerver avec le pingouin sinon il encore plus méchant.

Le plus simple c'est d'installer avec easy.urpmi

Tu as juste à donner les renseignements nécessaires et tu copie le code donner.

Ensuite tu ouvre une console et te connecte en root

Console => su => Mot de passe administrateur.
Coller le code => Enter.

Je t'aide :

Voila le code :
Citation :
rpmi.addmedia main ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mandriva... with media_info/synthesis.hdlist.cz
urpmi.addmedia --update main_updates ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mandriva... with media_info/synthesis.hdlist.cz
urpmi.addmedia main_backports ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mandriva... with media_info/synthesis.hdlist.cz
urpmi.addmedia contrib ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mandriva... with media_info/synthesis.hdlist.cz
urpmi.addmedia --update contrib_updates ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mandriva... with media_info/synthesis.hdlist.cz
urpmi.addmedia contrib_backports ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mandriva... with media_info/synthesis.hdlist.cz
urpmi.addmedia non-free ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mandriva... with media_info/synthesis.hdlist.cz
urpmi.addmedia --update non-free_updates ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mandriva... with media_info/synthesis.hdlist.cz
urpmi.addmedia non-free_backports ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mandriva... with media_info/synthesis.hdlist.cz
urpmi.addmedia --update plf-free ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/plf/mand... with media_info/synthesis.hdlist.cz
urpmi.addmedia plf-free_backports ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/plf/mand... with media_info/synthesis.hdlist.cz
urpmi.addmedia --update plf-nonfree ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/plf/mand... with media_info/synthesis.hdlist.cz
urpmi.addmedia plf-nonfree_backports ftp://distrib-coffee.ipsl.jussieu.fr/pub/linux/plf/mand... with media_info/synthesis.hdlist.cz
12 Septembre 2007 14:35:46

cedric_1993_29 a dit :

Pouvez vous m'aider? Parce que même en traduisant sur google j'ai beaucoup de peine à comprendre!


pour installer un rpm:
rpm -ivh nom_du_paquet

le sudo indique le lancement d'une commande en root, il suffit sous mandriva de se mettre en root avant de lancer la commande
12 Septembre 2007 18:31:42

en tappant : rpm -ivh zattoo.rpm
en mode root (su) il me dit :

[root@localhost cedric]# rpm ivh zattoo.rpm
RPM version 4.4.6
Copyright (C) 1998-2002 - Red Hat, Inc.
Ce programme peut être librement redistribué sous les termes de la licence GNU G
PL

Utilisation: rpm [-aKfgpWHqV] [-aKfgpWHqVcdils] [-aKfgpWHqVcdilsaKfgpWHqV] [-aKf
gpWHqVcdilsaKfgpWHqV] [-aKfgpWHqVcdilsaKfgpWHqV] [-aKfgpWHqVcdilsaKfgpWHqVK] [-a
KfgpWHqVcdilsaKfgpWHqVK] [-aKfgpWHqVcdilsaKfgpWHqVKi] [-aKfgpWHqVcdilsaKfgpWHqVK
iv] [-aKfgpWHqVcdilsaKfgpWHqVKiv] [-aKfgpWHqVcdilsaKfgpWHqVKiv?] [-a|--all] [-f|
--file] [-g|--group]
[-p|--package] [-W|--ftswalk] [--pkgid] [--hdrid] [--fileid]
[--specfile] [--triggeredby] [--whatrequires] [--whatprovides]
[--nomanifest] [-c|--configfiles] [-d|--docfiles] [--dump] [-l|--list]
[--queryformat=QUERYFORMAT] [-s|--state] [--nofdigests] [--nofiles]
[--nodeps] [--noscript] [--comfollow] [--logical] [--nochdir]
[--nostat] [--physical] [--seedot] [--xdev] [--whiteout]
[--addsign] [-K|--checksig] [--delsign] [--import] [--resign]
[--nodigest] [--nosignature] [--initdb] [--rebuilddb] [--aid]
[--allfiles] [--allmatches] [--badreloc] [-e|--erase <paquetage>+]
[--excludedocs] [--excludepath=<chemin>] [--fileconflicts] [--force]
[-F|--freshen <paquetage>+] [-h|--hash] [--ignorearch] [--ignoreos]
[--ignoresize] [-i|--install] [--justdb] [--nodeps] [--nofdigests]
[--nocontexts] [--noorder] [--nosuggest] [--noscripts]
[--notriggers] [--oldpackage] [--percent] [--prefix=<rep>]
[--relocate=<vieux>=<nouveau>] [--repackage] [--replacefiles]
[--replacepkgs] [--test] [-U|--upgrade <paquetage>+]
[-D|--define 'MACRO EXPR'] [-E|--eval 'EXPR'] [--macros=<FICHIER:...>]
[--nodigest] [--nosignature] [--rcfile=<FICHIER:...>]
[-r|--root RACINE] [--querytags] [--showrc] [--quiet] [-v|--verbose]
[--version] [-?|--help] [--usage] [--scripts] [--setperms]
[--setugids] [--conflicts] [--obsoletes] [--provides] [--requires]
[--suggests] [--enhances] [--info] [--changelog] [--xml] [--yaml]
[--triggers] [--last] [--dupes] [--filesbypkg] [--fileclass]
[--filecolor] [--filecontext] [--fscontext] [--recontext]
[--fileprovide] [--filerequire] [--vendorprovides]
[--vendorrequires] [--autorollback] [--buildpolicy=<politique>]
[--with=<option>] [--without=<option>] [--scripts]
[root@localhost cedric]#

Es-ce que c'est bon?
12 Septembre 2007 18:35:27

et en tappant :

rpm -ql zattoo.rpm rien ne marche... le rpm n'est pas installer!!!

12 Septembre 2007 18:37:27

et en tappant rpm -ql zattoo sa me donne plein de fichier...
:S
12 Septembre 2007 18:43:23

t'as oublié le tiret :pfff: 
12 Septembre 2007 19:47:11

Où???

Entoucas merci beaucoup pour votre aide!
12 Septembre 2007 19:55:19

cedric_1993_29 a dit :

[root@localhost cedric]# rpm -ivh zattoo.rpm

12 Septembre 2007 22:35:26

menu k (étoile) → systhème → configuration → configurer votre ordinateur. la on te demmande le passe root, et ta tout ce qu'il te faut pour tout les rpm mandriva. pour avoir des rpm qui ne sont pas sur le(s) cd(s) d'installation de mandrivat tu va dans "sélectionner la source de téléchargement des paquetage pour la mise a jour du systhème" la tu va sur ajouter tu sélectionne source pour la distribution → ok → tu sélectionne le serveur que tu veut et tu fait ok. ca te permétrat d'avoir un max de programme et le mise a jours. après pour installer en toute faciliter c'est comme au début menu k (étoile) → systhème → configuration → configurer votre ordinateur. sauf que la tu va sur vérifier les programme disponibles et en instaler d'autrtes.
tu arrive au paradit de l'instalation rpm tu coches ceux que tu veux et tu fait appliquer, un petit message apparait pour que tu confirme l'instalation et hop ca se fait tout seul.
13 Septembre 2007 18:55:31

Toujours des problèmes!

[root@localhost cedric]# cd /home/cedric/Desktop
[root@localhost Desktop]# rpm -ivh zattoo.rpm
Préparation... ########################################### [100%]
paquetage zattoo-2.2.10.6523-1 déjà installé
[root@localhost Desktop]#
Bon c'est cool j'ai déjà compris le système :) 

Maintenant comment ouvrir le programme si il est installé?

Merci beaucoup

navyn: Je vais essaier ce que tu me dit et je verrais la suite!
A+ je te tiens au courant! :p 
13 Septembre 2007 19:10:39

Alors, navyn j'ai fais ce que tu m'as dit de faire... mais... si je veux installer maintenant zattoo! comment je fais puisqu'il est pas dans les listes!
13 Septembre 2007 20:53:28

coca25 a dit :
salut, pour avoir la liste des fichiers installés:
rpm -ql nom_du_paquet

13 Septembre 2007 21:14:21

Oui mais sa me sert à quoi? une liste s'affiche!! Moi je veux ouvrir le programme!
14 Septembre 2007 11:16:40

... faut quand meme te renseigner un minimum sur comment fonctionne l'os!
parmi ces fichier, il doit y avoir l'executable pour lancer l'application, genre /usr/bin/zattoo

mais si ca se trouve, il s'est rajouté au menu

14 Septembre 2007 15:59:47

ok merci beaucoup!

(je suis en train de me renseigner)
14 Septembre 2007 18:41:31

tu ne trouve pas zattoo normal il n'y ai pas le truc que je t'ai passer c'est pour la plupart des rpms que tu aura besoin, pour zattoo il te faudrat t'assurer que tu a bien pris le rpm pour mandriva, fedora utilise aussi les rpm et bien évidemment ce n'est pas les mêmes. donc faut être sure que il est bien pour mandriva.
15 Septembre 2007 11:01:32


Télécharger Linux Player

Configuration minimale requise:

* Intel P3 1.5 GHz
* 512 MB RAM
* Connexion Internet à haut débit

Puis je mets télécharger et:
il y a la version .deb (debian)

puis:

Other Distributions
General Installation Help
Zattoo may work on other distributions, but will require extra steps. You may try installing with the rpm package or use the tgz to do a more manual installation.

* 1. Download the deb, rpm or tgz.
o Download Linux Player(.rpm)
Download Linux Player(.tgz)
* 2. Install gtkglext-1.2.0-4.fc6.i386 using your package manager (see distro specific instructions below)
* 3. Check distro-specific instructions below for any other possible pre-requisites
* 4. Install the rpm or deb or unpack the tgz and move everything to the correpsonding location under /usr
* 5. Install xulrunner. We suggest putting the xulrunner in /usr/lib/zattoo. We have a build of xulrunner available or you can download it from mozilla.org.
* 6. Create symbol links from the required (debian) xulrunner library names to the actual names. If you have installed xulrunner in /usr/lib/zattoo, then it would be something like this:
o sudo ln -s /usr/lib/zattoo/xulrunner/libgtkembedmoz.so /usr/lib/zattoo/libgtkembedmoz.so.0d
o sudo ln -s /usr/lib/zattoo/xulrunner/libmozjs.so /usr/lib/zattoo/libmozjs.so.0d
o sudo ln -s /usr/lib/zattoo/xulrunner/libnspr4.so /usr/lib/zattoo/libnspr4.so.0d
o sudo ln -s /usr/lib/zattoo/xulrunner/libplc4.so /usr/lib/zattoo/libplc4.so.0d
o sudo ln -s /usr/lib/zattoo/xulrunner/libplds4.so /usr/lib/zattoo/libplds4.so.0d
o sudo ln -s /usr/lib/zattoo/xulrunner/libxpcom.so /usr/lib/zattoo/libxpcom.so.0d
o sudo ln -s /usr/lib/zattoo/xulrunner/libxul.so /usr/lib/zattoo/libxul.so.0d
* 7. Run ldconfig on the /usr/lib/zattoo directory with something like "sudo /sbin/ldconfig /usr/lib/zattoo"
* 8. Download and install the Adobe Flash plugin from http://www.adobe.com
* 9. Follow any distro specific instructions below.

Additional Help For Other Distributions
Fedora Core 6:

* 1. Make symlinks if necessary:
sudo ln -s /lib/libssl.so.0.9.8b /lib/libssl.so.0.9.8
sudo ln -s /lib/libcrypto.so.0.9.8b /lib/libcrypto.so.0.9.8
* 2. To install gtkglext-1.2.0-4.fc6.i386, from above, you can do "Add/Remove Software", then search for "gtkglext" and Add it

OpenSuse 10.2/Gnome

* 1. To install gtkglext package, from above:
o a. Go to "start" menu and choose "Install Software"
o b. In the "Software Installer" window, search for gtkglext and install it.

OpenSuse 10.2/KDE

* 1. Find and install Gnome 2.16 (you might want to do this before installing Zattoo)
* 2. To install the gtkglext package, from above:
o a. Start-->Applications-->System-->Configuration-->Install Software
o b. In the "Software Installer" window, search for gtkglext and install it.
* 3. Verify that the gnome-keyring daemon is running (and is configured to run at login)
o a. Create or edit ~/.kde/env/start-custom.sh to be something like:
#!~ /bin/sh
eval `gnome-keyring-daemon`
export GNOME_KEYRING_PID
export GNOME_KEYRING_SOCKET
$

Create or edit ~/.kde/shutdown/stop-custom.sh:
#~/bin/sh
if [-n "$GNOME_KEYRING_PID"];then
kill $GNOME_KEYRING_PID
fi
$

Le meilleurs c'est que tu ailles voir! C'est très rapide! www.zattoo.com ---> télécharger ---> inscrit toi! et c'est bon!


Voilà! Merci beaucoup pour votre aide !

Bonne journée!
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS