Se connecter / S'enregistrer
Votre question

Wamp : connection impossible

Tags :
  • base-de-donnees
  • Logiciels
  • Wamp
Dernière réponse : dans Programmation
a b 6 Logiciels
26 Juin 2013 23:13:18

Bonsoir ,

Du jour au lendemain wamp ne fonctionne plus .
Voici le message d'erreur que j'ai :

  1. Could not execute menu item (internal error)
  2. [Execption] Could not perform service action :
  3. Le service ne peut pas être démarré parce qu'il est désactivé ou qu'aucun périphérique activé ne lui est associé.



Wamp reste donc en rouge je ne peux même pas récupérer la base de données pour repartir sur un autre logiciel.

Autres pages sur : wamp connection impossible

a b 6 Logiciels
27 Juin 2013 01:41:28

Est il possible de migrer vers Easy PHP sans perdre mes données mysql j'ai vu dans data qu'il y avait les données de ma base de données , comment faire pour les récupérer dans easy PHP ?
28 Juin 2013 01:42:53

O_o
Bonjour,

Dans un premier temps l'on vas clarifier tous ça ...
WAMP et EASY PHP sans EXACTEMENT la même chose ... soit un regroupe de Apache2 (httpd), Mysql, PHP... ( Avec un W devant pour Windows ^^ ).

Donc Apache2 ( ou httpd de sont vraie nom ), est votre serveur web ... il s'occupe juste d’écouter les requête http et renvoi la page demander ...
PHP quand a lui viens ce greffer sur Apache2 et lorsqu'Apache vas recevoir une requete sur un document en .php. Apache vas en quelque sorte demander a PHP de lui "décrypter" le fichier pour qu'il puisse le lire ... ce que fais PHP avant de renvoyer la source HTML a Apache qui l'envoie a votre navigateur ...

MySQL n'a techniquement aucun lien avec le reste , c'est juste une base de donner de SQL !
(C'est l'utilisation d'un connecteur en PHP ( exemple PDO ) qui vas vous permetre de faire le lien avec votre BDD).

Installer wamp et easy php sur la même machine risque d’aggraver votre problème plus qu'autre chose !
( Et puis bon pourquoi httpd sur un windows alors qu'il y a IIS, ^^ non je déconne c'est pour le troll ^^ ).

Maintenant il vas falloir identifier qu'elle service ne démarre pas !
(Je dirait a tous hasard le apache qui arrive pas a prendre le port 80 car il est occuper par un petit skype sauvage ! ou une instance de IIS !)
28 Juin 2013 11:19:22

Bonjour,

Moi je dirais que tu peux déjà commencer par essayer :

Clic gauche sur l'icône Wamp > Apache > service > test Port 80
Si le port est OK, cela devrait t'afficher
"your port 80 is actually used by:
Server: Apache/2.2.22 <Win32> PHP/5.4.3 "

Ensuite tu as différents test :

Restart All services ou :
Wamp > Apache > Service > Restart Service
Wamp > MySQL > Service > Restart Service

Si rien n'est changé, tu peux essayer :
Wamp > Apache > Service > Remove Service
Wamp > MySQL > Service > Remove Service

Couper Wamp, Redémarrer
Wamp > Apache > Service > Install Service
Wamp > MySQL > Service > install Service

Wamp > Restart All Services

Dernière possibilité, passer par un autre port :
Wamp > Apache > httpd.conf > cherche la ligne Listen 80 et remplacer 80 par exemple par 8080
Dans votre navigateur penser à écrire : 127.0.0.1:8080 pour accéder à localhost.


Chez moi cela à toujours tout dépanné, mais j'ai peu être de la chance ^^
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS