Se connecter / S'enregistrer
Votre question

Problème : 127.0.0.1 fonctionne mais pas localhost

Tags :
  • Internet explorer 7
  • Internet
Dernière réponse : dans Internet
28 Novembre 2007 11:33:18

Bonjour,

Je pense que je suis dans la bonne section pour mon message.

Je développe des applications sur mon ordinateur et notamment des sites web en PHP et en ASP.Net. Le problème, c'est que le terme localhost ne fonctionne plus dans mes navigateurs alors que son équivalent 127.0.0.1 marche. Le navigateur remplace localhost par www.localhost.com

Si quelqu'un a une idée pour régler le problème, cela m'arrangerai puisque mes logiciels de développement lance les tests avec localhost et non 127.0.0.1

Je sais pas si ça a un rapport mais avant que ça ne fonctionne plus, j'ai installé Nod32, IIS entres autres.

Merci de votre aide !

Autres pages sur : probleme 127 fonctionne localhost

28 Novembre 2007 12:01:34

informe nous sur ton navigateur peu t'etre que ce pourai nous aidé...
2 Décembre 2007 13:50:08

Peut importe le navigateur, cela ne fonctionne pas, que se soit sur Internet Explorer 7 ou Firefox 2, lorsque je saisie l'adresse http://localhost, il cherche http://www.localhost.com
Contenus similaires
2 Décembre 2007 18:01:31

229867,1,40321 a dit :

Citation :
Je sais pas si ça a un rapport mais avant que ça ne fonctionne plus, j'ai installé IIS entres autres.


Bah il y a des chances que cela vienne de la , tu ne pouras pas faire de test de chez toi, c'est vrai, c'est un probleme

3 Décembre 2007 14:31:50

Comment ça se fait que IIS me poserait un problème avec localhost et comment est-ce que je peux le règler ?
3 Décembre 2007 14:50:04

AderynR a dit :
Comment ça se fait que IIS me poserait un problème avec localhost et comment est-ce que je peux le règler ?

tu ne peut faire de test quand local( a ma connaissance) sinon, il faut demander a quelqu'un de se connecter, c'est le meilleurs test
pour IIs, c'est un minimun quand meme
le navigateur n'a rien a voir
127.xxxxx c'est l'adresse de la carte réseaux
3 Décembre 2007 16:19:20

Salut.
vérifie que le fichier c:\windows\system32\drivers\etc\hosts est bien présent et qu'il contient la ligne ci-dessous:
127.0.0.1 localhost
11 Décembre 2007 19:34:06

Il y a bien dans ce fichier la ligne :
127.0.0.1 localhost
11 Décembre 2007 19:35:41

C'est pas la première fois que j'utilise IIS et je n'ai jamais rencontré ce genre de problème, je ne comprends pas et je n'arrive pas non plus à trouver des informations sur Internet !

Çà commence vraiment à me faire ... !
11 Décembre 2007 20:23:59

J'ai supprimé IIS de mon ordinateur et l'adresse localhost ne me donne pas la même page que 127.0.0.1. Le problème de vient donc pas de IIS et je n'ai vraiment pas envie de supprimer mes applications une par une en espérant trouver celle qui me pose problème.

Si quelqu'un à une idée, c'est maintenant ? Merci
11 Décembre 2007 22:46:32

Bon, j'ai avancé ! Je sais que le problème vient de ESET Smart Security (soit Nod32). Quand je le supprime, localhost fonctionne bien mais quand il est installé, ça ne fonctionne plus.

Si quelqu'un connait bien ce logiciel et peu me dire comment régler le problème, j'aprécie !

Merci.
11 Décembre 2007 23:18:00

Suite à de nouvelles recherches, notamment sur des forums italiens, j'ai trouvé la source du problème. Je vous en fait part au cas où d'autres personnes auraient un problème similaire.

Il s'agit d'une configuration du pare-feu de Nod32, il suffit de désactiver le filtre sur les protocoles dans les configurations avancées du pare-feu.

Merci à ceux qui ont tenté de m'aider !
12 Décembre 2007 00:25:51

merci d'avoir posté la réponse, ça servira à d'autres personnes

mais un bémol sur ta réponse, il ne faut pas supprimer tous les filtres, mais simplement mettre une exclusion pour ceux dont on a besoin
Anonyme
5 Juin 2009 18:08:24

Euh moi j'ai telechargé XAMPP et je n'arrive pas a aller sur http://localhost ou 127 XxxxX

u_U si quelqu'un a une solution pacque j'essaie de me creer un jeu
18 Juin 2009 13:00:01

il faut juste ajoute Listen 192.168.0.XX:80 sur le fichier httpd.conf de l'apache et le redémarrer.
en tout cas ça m'ai été arriver et maintenant le problème est résolut
Anonyme
21 Novembre 2009 14:37:10

J'ai eu un problème similaire (127.0.0.1 marche mais pas localhost). J'ai corrigé en modifiant le fichier c.\windows\system32\drivers\etc\hosts. J'ai remplacé la ligne ::1 localhost par 127.0.0.1 localhost. Le problème semble venir d'un conflit entre ipv4 et ipv6.
7 Février 2010 20:25:11

Bonjour Moi , J'ai XAMPP Et Depuis le Début je peu y allé avec internet Explorer , mais pas avec firefox. Sauf que , Apres avoir été sur phpmyadmin Je N'arrive pas a allé sur http://localhost/install.php ni Simplement http://localhost/ meme sur un onglet différent ou sur une nouvelle page. Je ne pense pas que le probleme soir de phpmyadmin mais avant sa tou allais bien.

Jai vraiment besoin d'y allé ...pouver vous maider ?
6 Mars 2010 22:53:43

Bonjour, quand je tape sur Firefox http://localhost/ ou http://www.localhost.com/phpmyadmin/ ou http://localhost/sqlitemanager/ sa me mé une page blanche... je ne sait pas quoi fair!

Merci d'avance...
23 Avril 2010 10:34:33

Localhost marche plu putin
16 Juillet 2012 18:59:57

Bonjour jessaye de faire un retro.J'utilise xaamp.Jarrive sur la page ou il les langue mai apres il faut aller a: http://localhost/phpmyadmin/ mais il me maque cela Accès interdit!

Vous n'avez pas le droit d'accéder à l'objet demandé. Soit celui-ci est protégé, soit il ne peut être lu par le serveur.

Si vous pensez qu'il s'agit d'une erreur du serveur, veuillez contacter le gestionnaire du site.

Error 403

localhost
07/16/12 18:58:09
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8
Pouvez vous me dire ce que je doit faire
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS