Se connecter / S'enregistrer
Votre question
Résolu

Lubuntu Échec de l’installation du chargeur d’amorçage

Tags :
  • Windows XP
  • téléphone
  • Système d'exploitation
  • Musique
  • Ordinateur
Dernière réponse : dans Systèmes d'exploitation
21 Janvier 2017 16:20:02

salut a tous :hello: 

j'utilise un ordinateur dédié a la musique dans mon salon il ne sert qu'a lire des CD et a écouter la radio sur internet
le problème c'est que le seul OS que j'avais sous la main au moment de sa mise en fonction c'était un Windows xp sp3 et que les serveur d'activation ainsi que l'activation par téléphone (du moins pour XP) sont désormais hors ligne

j'ai tenté l'activation en modifiant la clé de registre associé (ça ne marche pas) et je n'ai surtout pas envie d'utiliser un activateur (c'est des nids a virus, addware et autre joyeuseté et je suis pas sur que ça détruise pas tout le software sur le long terme)

donc j'ai téléchargé Lubuntu (on y vient) pour obtenir un OS en restant dans la légalité sans pour autant payer en gravant l'ISO sur un CD (un DVD plus exactement) j'ai clické sur "installer lubuntu" l’installation se déroule bien jusqu’à ce que...

Citation :
Le paquet grub-pc n'a pas pu être installé dans /target/. En l'absence du programme de démarrage GRUB le système installé ne pourra pas démarrer
[ok]


après avoir clické sur "Ok" le message suivant apparais

Citation :
Échec de l’installation du chargeur d’amorçage
<!> Désolé une erreur s'est produite. Il n'a pas été possible d'installer le chargeur d’amorçage a l'endroit indiqué
comment souhaitez vous procéder ?
(.) choisir un autre périphérique sur lequel installer le chargeur d’amorçage :
-> /dev/sda ATA Maxtor 6L250S0 (251.0 Gb)
-> /dev/sda1

( ) continuer sans chargeur d'amorçage

( ) annuler l’installation

j'ai essayé de copier la mise en page des message d'erreur :D 

je précise au cas ou ca puisse servir que j'ai choisis "formater le disque puis installer" et que l'ordre de boot est le suivant je tiens aussi a signaler que ce PC ne prend pas en charge le boot sur support USB
1 CD-ROM
2 HDD
3 USB HDD

en espérant avoir été asse détaillé et compréhensible (c'est pas trop mon monde les distrib linux) ^^
merci par avance pour vos réponses :) 

Autres pages sur : lubuntu echec linstallation chargeur damorcage

21 Janvier 2017 18:04:25

Bonjour,

as tu vérifié le checksum de l'ISO avant de graver ?
quelle taille disponible pour le MBR avant la première partition ? as tu simplement formaté la partition système W$ ou refait le schéma de partitionnement du disque ?
m
0
l
21 Janvier 2017 18:58:10

j'ai absolument rien compris :heink: 
checksum? le MBR? shema de partition?
m
0
l
Contenus similaires
21 Janvier 2017 21:08:29

prenons dans l'ordre ;
- le fichier ISO, pour être sûr qu'il n'a pas été corrompu lors du téléchargement, doit être vérifié. Pour cela, le distributeur met à disposition un fichier de somme de contrôle du fichier ISO, un checksum (MD5/SHA1 généralement). Il faut donc avec une application générant une somme de contrôle à partir d'un fichier, comparer ladite somme de contrôle à celle fournie avec l'image ISO.
- le MBR est la zone d'amorçage en début de disque, avant la première partition, et que le BIOS va automatiquement vérifier puis lire pour chercher un chargeur de démarrage qui va ensuite pointer sur un ou plusieurs systèmes. Or, il est possible que cette zone est trop petite pour accueillir le chargeur de démarrage GRUB. il existe aussi le standard GPT, plus récent. Tout dépend du partitionnement du disque.

Tu peux à la limite tester avec une version Live de Linux, qui te permettra d'obtenir des informations grâce à ses outils comme l'utilitaire de disques.
m
2
l
21 Janvier 2017 22:13:53

dit moi les données qu'il te faut et comment les obtenir et je te fais ca demain ;) 
m
0
l
22 Janvier 2017 11:58:24

je viens d'essayer la manip du lien
sudo -i
grub-install /dev/sda
update-grub

et j'ai obtenu ca

Citation :
To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

lubuntu@lubuntu:~$ sudo -i
root@lubuntu:~# grub-install /dev/sda
The program 'grub-install' can be found in the following packages:
* grub
* grub2-common
* lupin-support
Try: apt install <selected package>
root@lubuntu:~# update-grub
The program 'update-grub' can be found in the following packages:
* grub
* grub2-common
Try: apt install <selected package>


sans être expert je pense que c'est pas bon :D 
m
0
l
22 Janvier 2017 12:07:30

Bon ,

Je ne connais pas du tout Linux , mais sur le lien manipulation doit être faite " super-utilisateur (root) . " ...

ÉDIT :

J'ai traduit une partie de ton texte :

" To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details. "

Et donc

" Pour exécuter une commande en tant qu'administrateur (utilisateur "root"), utilisez "sudo <command>".
Voir "man sudo_root" pour plus de détails. "
m
0
l
22 Janvier 2017 12:58:01

merci mais pas besoin de me traduire j'ai pas de problème avec l'anglais :D 
je tente "sudo grub-install /dev/sda" ducoup?
si j'en crois le message le problème vient surtout du fait qu'il ne parvient pas a trouver de programme "grub-install" dans ses fichiers. ce n'est (je pense) pas un problème de permission mais plutôt d’existence du fichier, (simple supposition) :/ 
m
0
l
22 Janvier 2017 13:11:29

" merci mais pas besoin de me traduire j'ai pas de problème avec l'anglais "

Je n'ai pas la possibilité de savoir ci tu maitrise l'anglais ...
;) 
m
0
l

Meilleure solution

22 Janvier 2017 15:59:05

Bonjour,

il faut en effet installer un paquet grub ou grub2-common (plutôt grub2 que grub, d'ailleurs) afin d'avoir accès à la commande d'installation du grub.

le premier lien de windows23 concerne RedHat, or LUbuntu est de la famille Debian. Il y a des différences et je ne suis pas expert en Debian, étant sous une distrib de la famille RedHat.

le deuxième lien concerne la gestion des utilisateurs autorisés à utiliser certaines commandes avec des droits root. sauf que pour les gérer, il faut ... des droits root. logique.

donc d'abord faire, éventuellement après un
  1. sudo -i
pour être en mode interactif pseudo-root, ou
  1. su - root
en indiquant le mot de passe root pour être directement super-utilisateur,
  1. apt install grub2-common
pour installer le paquet et ses dépendances, qui fourniront les exécutables nécessaires pour enfin faire
  1. grub-install /dev/sda
et
  1. update-grub


et de fait le problème venait bien de là, vu que la commande sudo -i que tu avais entré était bien passée, donc tu aurais eu les droits s'il avait trouvé les binaires dans le path.
partage
22 Janvier 2017 16:12:07

windows23 a dit :
" merci mais pas besoin de me traduire j'ai pas de problème avec l'anglais "

Je n'ai pas la possibilité de savoir ci tu maitrise l'anglais ...
;) 


c'est vrais que je me suis vexé un peu vite :D 

qu'est ce que je suis censé faire avec les liens par contre?
m
0
l
22 Janvier 2017 16:19:06

Je pense que la proposition @VaderFR sera plus pertinente et plus efficace ...

ÉDIT :

Comme là dit @VaderFR en rapport à une corruption à l’occasion du téléchargement ...

Et donc il faudrait commencé par contrôlé L'algorithme MD5 ( http://www.commentcamarche.net/faq/41-md5sum-verifier-l... ) .



;) 

m
0
l
22 Janvier 2017 20:14:39

j'ai utilisé "verifier le disque" dans le menu du CD et il m'a dit que tout allais bien ca compte?
m
0
l
24 Janvier 2017 17:33:23

Salut leo_85
leo_85 a dit :

Citation :
Le paquet grub-pc n'a pas pu être installé dans /target/. En l'absence du programme de démarrage GRUB le système installé ne pourra pas démarrer
[ok]


après avoir clické sur "Ok" le message suivant apparais

Citation :
Échec de l’installation du chargeur d’amorçage
<!> Désolé une erreur s'est produite. Il n'a pas été possible d'installer le chargeur d’amorçage a l'endroit indiqué
comment souhaitez vous procéder ?
(.) choisir un autre périphérique sur lequel installer le chargeur d’amorçage :
-> /dev/sda ATA Maxtor 6L250S0 (251.0 Gb)
-> /dev/sda1

( ) continuer sans chargeur d'amorçage

( ) annuler l’installation

Pour une raison indéterminée, grub ne s'est pas installé sur ton unique disque dur /dev/sda mais cherchait un /target/
Te l'a-t-il demandé lors de l'installation, as-tu oublié de cocher un bouton ?
Plutôt que de passer un temps fou à essayer d'installer grub via un Live-CD qui n'a pas les binaires, tu auras plus vite fait de refaire l'installation...
Mais cette fois, vérifie bien si à un moment, il te demande quelque chose à propos de grub... Au pire, il te remettra le message d'erreur cité ci dessus, et là, tu installeras sur /dev/sda (à la racine du disque). Je pense d'ailleurs que /dev/sda1 (racine de la première partition) devrait marcher aussi.

Tiens-nous au courant.

m
0
l
24 Janvier 2017 22:21:21

Geis007 a dit :
Salut leo_85
Pour une raison indéterminée, grub ne s'est pas installé sur ton unique disque dur /dev/sda mais cherchait un /target/
Te l'a-t-il demandé lors de l'installation, as-tu oublié de cocher un bouton ?
Plutôt que de passer un temps fou à essayer d'installer grub via un Live-CD qui n'a pas les binaires, tu auras plus vite fait de refaire l'installation...
Mais cette fois, vérifie bien si à un moment, il te demande quelque chose à propos de grub... Au pire, il te remettra le message d'erreur cité ci dessus, et là, tu installeras sur /dev/sda (à la racine du disque). Je pense d'ailleurs que /dev/sda1 (racine de la première partition) devrait marcher aussi.

Tiens-nous au courant.



refaire l'instalation? je n'ais que ce CD et le disque et formaté chaque fois que je tante d'installer l'OS j'ai ce message pourtant on me dit que l'integrité des fichiers de l’installateur est ok
qu'est ce que je dois faire?
existe-t-il un moyen d'installer grub a part?
autre chose l'installeur est 64X mais je ne sais pas si le proco est en 64 ou 86 (ya marqué 64 sur l'etiquette du boitier)
m
0
l
25 Janvier 2017 07:12:52

leo_85 a dit :
refaire l'instalation?

Oui ! Ça te prendra 1/2 heure, bien moins que n'importe quelle bidouille.
leo_85 a dit :
je n'ais que ce CD

Pas besoin d'autre chose...

leo_85 a dit :
et le disque et formaté chaque fois que je tante d'installer l'OS

Normal ! Et alors ?
leo_85 a dit :
j'ai ce message pourtant on me dit que l'integrité des fichiers de l’installateur est ok

Donc ton CD est bon, tu n'as besoin de rien d'autre.
leo_85 a dit :
qu'est ce que je dois faire?

Relancer l'installation en vérifiant bien que, lorsqu'il le demande, grub s'installe sur /dev/sda
leo_85 a dit :

existe-t-il un moyen d'installer grub a part?

Pourquoi faire simple si on peu faire compliqué...
leo_85 a dit :

autre chose l'installeur est 64X mais je ne sais pas si le proco est en 64 ou 86 (ya marqué 64 sur l'etiquette du boitier)

Maintenant, tous les procs sont en 64 bits.

A +
m
0
l
25 Janvier 2017 20:39:12

tu a decoupé ma question au point de lui donner le sens que tu voulais XD
je resume
-ce PC n'a aucun OS
-je le demarre donc en mode boot CD et la on me demande si je veut tester ou installer lubuntu
-je choisis installer en vérifiant scrupuleusement que rien ne concernant le grub ne m'aurais échappé
-plantage systématique avec le message d’erreur précédemment cité
m
0
l
26 Janvier 2017 18:41:34

leo_85 a dit :

-plantage systématique avec le message d’erreur précédemment cité

Le message d'erreur te demande :
Citation :
(.) choisir un autre périphérique sur lequel installer le chargeur d’amorçage :
-> /dev/sda ATA Maxtor 6L250S0 (251.0 Gb)
-> /dev/sda1

( ) continuer sans chargeur d'amorçage

( ) annuler l’installation

Tu as à ce moment la possibilité d'effectuer un choix, et il faut choisir d'installer sur /dev/sda
Sans doute avec les touches de flèches haut et bas, tu dois pouvoir pouvoir sélectionner cette option : soit la ligne se met en surbrillance, soit un point se déplace...
Mais avant de quitter ou appuyer sur [Entrée], sélectionne bien installer sur /dev/sda

Sinon... J'ai de nombreuses fois installé Ubuntu sans rencontrer ce problème, mais pas tout à fait comme ça...
Je lance d'abord "Essayer Ubuntu", et j'installe ensuite avec l'icône qui est sur le bureau. En faisant comme ça, il a toujours su où installer grub.

Bonne chance
m
0
l
26 Janvier 2017 21:34:23

Si c'est figé, c'est planté !
As-tu testé via "Essayer Ubuntu".
Après, lors du partitionnement, essaie "Partitionnement personnalisé" (ou peut-être "manuel" (de mémoire, je ne suis plus sûr) ent créant :
- une partition de 25Go, en ext4, montée en "/" (racine du système)
- une partiton de swap égale au double de ta ram
- une partition en ext4 de tout le reste de ton disque montée en "/home"
Là aussi, vérifie si on te demande où installer grub

m
0
l
28 Janvier 2017 12:08:25

pourquoi avoir edité mon message pour me repondre? XD
m
0
l
28 Janvier 2017 18:37:38

leo_85 a dit :
pourquoi avoir edité mon message pour me repondre? XD

M**de !!!! J'ai effacé ton message en y répondant !!!!!
Mauvaise manip de ma part, sincèrement désolé !
Tu te souviens de ton message ? Tu peux le remettre ?

m
0
l
28 Janvier 2017 23:01:20

bah pas la peine X)
donc si j'ai bien compris je dois créer trois partitions repondant aux critères que tu a inscrit?
aussi je dois preciser que peut importe la facon dont j'installe lubuntu on ne me demande jamais ou installer le grub
m
0
l
2 Février 2017 18:18:44

Si le formatage automatique ne fonctionne pas (du moins pas jusqu'à l'installation de grub), tu peux tenter le manuel. Une partition système (25Go sera TRÈS confortable), une partition de swap et une partition /home séparées sont un minimum.
J'ai installé chez un ami Ubuntu 16.04 (version de base, pas Lubuntu) dernièrement sans aucun problème.
Si c'est le Live Lubunutu qui a un bug, tu peux tenter d'installer Ubuntu classique, puis après, installer le bureau Xfce. En ouvrant ta session, tu choisiras Xfce, ça reviendra quasiment à Lubuntu...

m
0
l
5 Février 2017 00:21:37

j'ai réussit!
très connement en branchant un CPL l’installateur est allé cherché se dont il avais besoin :D 
merci beaucoup pour votre aide
m
0
l
6 Février 2017 08:05:20

leo_85 a dit :
j'ai réussit!
très connement en branchant un CPL l’installateur est allé cherché se dont il avais besoin :D 
merci beaucoup pour votre aide

Ah ! Effectivement... Sans liaison internet...
Tout est donc bien qui finit bien.

m
0
l
13 Février 2017 14:19:52

Bonjour à tous, avant de faire n'importe quoi, il faudrait peut être se renseigner un minimum, au lieu de faire perdre du temps aux gens avec de tel erreur de débutant!
Bien à vous!
m
0
l
13 Février 2017 15:01:10

philou21850 a dit :
Bonjour à tous, avant de faire n'importe quoi, il faudrait peut être se renseigner un minimum, au lieu de faire perdre du temps aux gens avec de tel erreur de débutant!
Bien à vous!


ok donc selon toi penser qu'une image CD de système d'exploitation contient le nécessaire pour s'installer toute seule (donc sans internet) te semble illogique? on parle d'un CD censé fonctionner sur des PC offline c'est un CD d'OS mais puisqu' apparemment tu a la science infuse ca ne doit pas être le cas

tu parle de faire perdre du temps aux gens mais jusqu'a preuve du contraire je n'ai pas reçu de remarque négative (sauf la tienne bien sur) et je ne t'ai pas forcé a lire ce topic. qu'est ce que tu fou sur un forum d'entraide si tu n'est la que pour descendre les gens qui on justement besoin d'aide

chaque foi que je me dit qu'internet a changé et que les gens sont devenus sympas y'a toujours un guignol comme toi qui débarque pour tout foutre en l'air

bien a toi ;) 
m
0
l
13 Février 2017 18:09:45

Don't feed the troll !

Vu qu'il y ait de grande chances pour que l'install aille chercher des paquets sur les dépôts du net (peut pas y avoir tout sur le CD) et que normalement l'essentiel (dont GRUB) est sur le DVD, on pouvait pas savoir que c'était qu'un truc aussi con qu'un problème réseau (d'autant que normalement il ne propose pas les paquets qu'il ne trouve pas)
m
0
l
13 Février 2017 19:11:13

j'ai réagit sur un coup de chaud c'est vrais mais c'est le genre de guss qui ont le talent de m’énerver
pour le reste ca me paraissait cohérent que le disque possède tout le nécessaire (pour palier aux PC hors-ligne :??: 
m
0
l
13 Février 2017 20:27:10

Réponse à léo, j'ai été poli mais ce n'ai pas ton cas.
Et oui pour installer une distribution linux tu doit être connecté "configuration minimum requise" si tu te serais renseigné avant de chier dans ton slip et appeler au secour ! tu n'aurais pas commis cet bourde et pour info je suis un pro à mon compte depuis plus de vingt ans donc "je ne sais pas tout"
Mais les trolls et guss comme tu le dit, j'en vois souvent qui se permettent de dire certaines choses alors qu'ils ne savent pas comment les cartes mère sont fabriquées!
Bonne soiré à tous!
m
0
l
13 Février 2017 20:45:08

philou21850 a dit :
Réponse à léo, j'ai été poli mais ce n'ai pas ton cas.

pas besoin d'être malpoli pour être agressif comme tu l'a bien montré a maintenant 2 reprises
philou21850 a dit :
Et oui pour installer une distribution linux tu doit être connecté "configuration minimum requise" si tu te serais renseigné avant de chier dans ton slip et appeler au secour !

ca c'est marrant de la part d'un mec qui parle de politesse. et je me répète mais ca parait logique de ce dire qu'un installateur d'OS contient tout le nécessaire pour s'installer
philou21850 a dit :
tu n'aurais pas commis cet bourde et pour info je suis un pro à mon compte depuis plus de vingt ans donc "je ne sais pas tout"
Mais les trolls et guss comme tu le dit, j'en vois souvent qui se permettent de dire certaines choses alors qu'ils ne savent pas comment les cartes mère sont fabriquées!
Bonne soiré à tous!

c'est quoi le rapport entre comment sont fabriquée les cartes mères et la situation qui nous occupe ?
m
0
l
13 Février 2017 21:04:17

Bon, j'ai pas de temps à perdre avec un personnage comme toi donc: pour conclure tu es impoli et menteur de plus, j'ai quitter tom's il y quelque années maintenant, je suis revenue voir si les choses avaient changer avec le temps.= C.Q.F.D"demonstrandum".
Bien le bonjour à coplan et à asusien.
CLDT.
m
0
l
13 Février 2017 21:09:46

philou21850 a dit :
Bon, j'ai pas de temps à perdre avec un personnage comme toi donc: pour conclure tu es impoli et menteur de plus


comme ca sans explication? faut te détendre hein tu joue pas ta vie
m
0
l
14 Février 2017 18:06:30

philou21850 a dit :
Bonjour à tous, avant de faire n'importe quoi, il faudrait peut être se renseigner un minimum, au lieu de faire perdre du temps aux gens avec de tel erreur de débutant!
Bien à vous!

Il n'est pas marqué sur le CD qu'une liaison internet est nécessaire... Et je n'ai pas l'impression d'avoir perdu mon temps...
Bien à vous
m
0
l
4 Avril 2017 01:32:22

Je me permet de m'inscrire sur ce forum pour répondre à ce message.
J'ai aussi essayé d'installer Lubuntu et j'ai eu exactement le même problème d'installation du grub.
J'ai essayé comme préconisé ici de faire le partitionnement à la main (trois partitions, /, /home et swap) mais ça n'a rien changé.
J'ai aussi activé le réseau (alors que j'avais fait une installation de Ubuntu Gnome juste avant sans réseau et sans problème), et ça n'a rien changé.

En cherchant à droite à gauche, j'ai vu qu'il y avait un problème avec la Table des Partitions, et il était conseillé d'essayer de partitionner avec Gparted, ce que j'ai fait.
Par la suite j'ai relancé l'installation (pour au moins la dixième fois, mais j'aime insister) et elle s'est déroulé convenablement.
Je ne sais pas si c'est Gparted qui a résolu le problème (j'en doute), mais si ça peut aider quelqu'un d'autre !
m
0
l
4 Avril 2017 17:14:40

Olorim a dit :
Je me permet de m'inscrire sur ce forum pour répondre à ce message.
J'ai aussi essayé d'installer Lubuntu et j'ai eu exactement le même problème d'installation du grub.
J'ai essayé comme préconisé ici de faire le partitionnement à la main (trois partitions, /, /home et swap) mais ça n'a rien changé.
J'ai aussi activé le réseau (alors que j'avais fait une installation de Ubuntu Gnome juste avant sans réseau et sans problème), et ça n'a rien changé.

En cherchant à droite à gauche, j'ai vu qu'il y avait un problème avec la Table des Partitions, et il était conseillé d'essayer de partitionner avec Gparted, ce que j'ai fait.
Par la suite j'ai relancé l'installation (pour au moins la dixième fois, mais j'aime insister) et elle s'est déroulé convenablement.
Je ne sais pas si c'est Gparted qui a résolu le problème (j'en doute), mais si ça peut aider quelqu'un d'autre !


toute solution est bonne a prendre pour ceux chez qui ma solution n'a pas marché ^^
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS