Votre question
Résolu

Formule Excel - Multiples Conditions

Tags :
  • Microsoft Excel
Dernière réponse : dans Logiciels
28 Juin 2017 13:49:37

Bonjour,

J'aimerai créer un tableau excel "intelligent" afin de pouvoir connaitre la qté de tablettes, de serre-livres et de porte-étiquette à positionner sur un rayonnage avec plusieurs hauteurs.

En gros, littéralement ça serait :
Si mon rayonnage a pour dimension 180cm, alors j'affiche 5 tablettes, 10 serre-livres et 10 porte-étiquettes.

J'ai essayé avec une seule condition :

=SI(B7=180;A23;"Néant")

De manière logique, je souhaitais pouvoir rentrer n'importe quelle dimension de rayonnage et avoir directement le NB global de matériel à ajouter pour un rayonnage. Donc on prend par exemple les hauteurs :

150cm
180cm
200cm

Ce qui nous donne normalement :

=SI(B7=150;A24;"Néant";SI(B7=180;A23;"Néant";SI(B7=200;A22;"Néant")))

Pour info, j'ai essayé aussi :

=SI.CONDITIONS(B7=150;A24;"Néant";SI(B7=180;A23;"Néant";SI(B7=200;A22;"Néant")))

Mais cette formule ne fonctionne pas... Auriez-vous une solution Svp ?

Merci beaucoup pour votre aide !
Cdt

cédric

Autres pages sur : formule excel multiples conditions

Meilleure solution

28 Juin 2017 18:33:47

Bonjour
Dans votre formule "néant" est toujours vrai quelque soit la valeur choisie.
Je propose
=SI(B7=150;A24;SI(B7=180;A23;SI(B7=200;A22))).
partage
29 Juin 2017 11:22:43

Bonjour,

Finalement j'ai travaillé hier mon fichier à plusieurs reprises, et j'en suis arrivé à la même chose que vous.

Merci beaucoup pour votre aide !

Bonne journée.

m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS