Se connecter / S'enregistrer
Votre question

CyberReseaux

Tags :
  • linux
  • Internet
Dernière réponse : dans Internet
12 Octobre 2008 12:39:05

bonjour a tous ,

j aimerais monter un cyber, sous linux , j'utilise Maelys mais je n'arrive pas a l'installer , en particulier Maelys admin
J ai deja installer le support du langage PHP5 et la base de donnée MYSQL ,

je tourne sous linux Ubuntu.

merci de bien vouloir m'éclairer ...

Cordialement

Autres pages sur : cyberreseaux

13 Octobre 2008 13:19:20

cybercafé
13 Octobre 2008 14:41:52

Comment as-tu installé Maelys ?
Gestionnaire de paquet, source ?
13 Octobre 2008 19:30:41

Je l'ai téléchargé et tenté d'installer....
Mais ce n'est pas claire car, le readme, informe de faire quelques commandes inexistantes !???
Je continue mes investigations !
13 Octobre 2008 20:57:34

Je viens de l'essayer !
Hum, comment dire, sont pas fortiche pour expliquer l'install !

A installer :
1) http://packages.aledde.org/maelys/1.0/maelys-webadmin_1...
Le décompresser
Mettre dans /var/www (debian, ubuntu)....
Le renommer
Luis mettre les droits 777
Il s'occupe de l'installation (MySQL, mot de passe, etc...)
Premier login :admin/admin (Mais l'on est pas informé, ni prévenu, pas dans le readme, pas dans le install,...)

2) installer le serveur : http://packages.aledde.org/maelys/1.0/maelys-server_1.0...
Avoir GLIBC_2.4... Sous Debian, y a pas ! plok !


J'en suis là :
# /usr/local/maelys/server/bin/master start
waiting for Maelys Server to start... ..............failed
master: Maelys Server does not start


Le log : /usr/local/maelys/server/var/server.log
/usr/local/maelys/server/libexec/maelys-master: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /usr/local/maelys/server/libexec/maelys-master)
/usr/local/maelys/server/libexec/maelys-master: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /usr/local/maelys/server/libexec/maelys-master)
/usr/local/maelys/server/libexec/maelys-master: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /usr/local/maelys/server/libexec/maelys-master)
/usr/local/maelys/server/libexec/maelys-master: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /usr/local/maelys/server/libexec/maelys-master)


maelys-server-mysql : est une librairie :
/usr/local/maelys/server/lib/libmaelys-data.so.1.0.0
/usr/local/maelys/server/lib/libmaelys-data.so
/usr/local/maelys/server/lib/libmaelys-data.so.0


Je vais m'installer une *ubuntu en virtuelle et voir !
Ou mettre la glibc_2.7 ?!
13 Octobre 2008 21:33:06

je viens de l'installer, ça prend 2min :
  1. apt-get install apache2 libapache2-mod-php5 mysql-server-5.0 php5-mysql gdebi
  2. cd /tmp
  3. wget <a href="http://packages.aledde.org/maelys/1.0/maelys-server-mysql_1.0.0-rc1_i386.deb" rel="nofollow" target="_blank">http://packages.aledde.org/maelys/1.0/maelys-server-mys...</a>
  4. wget <a href="http://packages.aledde.org/maelys/1.0/maelys-server_1.0.0-rc1_i386" rel="nofollow" target="_blank">http://packages.aledde.org/maelys/1.0/maelys-server_1.0...</a>
  5. wget <a href="http://packages.aledde.org/maelys/1.0/maelys-webadmin_1.0.0_rc1.tgz" rel="nofollow" target="_blank">http://packages.aledde.org/maelys/1.0/maelys-webadmin_1...</a>
  6. gdebi maelys-server-mysql_1.0.0-rc1_i386.deb
  7. gdebi maelys-server_1.0.0-rc1_i386.deb
  8. cd /var/www/
  9. tar zxvf /tmp/maelys-webadmin_1.0.0_rc1.tgz
  10. vi /etc/apache2/sites-enabled/000-default
  11. /etc/init.d/apache2 restart

le reste ce fait dans le navigateur

alors soit j'ai loupé un truc, soit ...

edit : je continu jusqu'au bout pour voir

edit2 : il y a un problème avec la version de la libc demandée
la 2.4 n'existe pas sous debian, on passe de 2.3 (stable) à 2.7 (sid)

edit3 : je passe la debian en testing pour voir, ce qui est équivalent à une ubuntu

edit4 : ça s'installe tout doucement, en passant j'ai trouvé ça : https://wiki.ubuntu.com/Cafebuntu

edit5 : fini

donc même manip, sauf qu'il faut partir d'une testing (en debian)
pour le reste c'est bon

c'est pas top le bleu de l'écran de login du client, un peu flash
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS