Se connecter / S'enregistrer
Votre question

Serveur FTP avec IIS 6 sur windows serveur 2003

Tags :
  • Serveur
  • Internet
Dernière réponse : dans Internet
14 Octobre 2004 21:23:28

Hello,

J'ai configuré un serveur ftp avec IIS6 sur un windows 2003. Depuis un autre ordi, je peux m'y connecter.

Mais lorsque j'essaye un transfert de fichiers, cela ne marche pas correctement. Il me créer un fichier sur le serveur ftp qui fait 0 ko.

J'ai vérifié les droits en écriture et c'est OK.
Je passe via un firewall sur lequel j'ai bien configuré une règle pour faire du ftp sur le port 21.
Je ne me suis pas occupé du port 20, est-ce vous pensez que c la cause du problème ?

Autres pages sur : serveur ftp iis windows serveur 2003

15 Octobre 2004 16:33:50

Tu as vérifié que ton port ftp est ouvert en udp ?
(je suis pas un pro, je début plus ou moins, alors je sais que parfois il faut ouvrir les port en udp en ce qui concerne les transferts de fichiers).
5 Juin 2006 11:10:04

Non, c'est bien en TCP qu'il faut ouvrir les ports 20 et 21.

Sinon, IIS, j'ai jamais bien aimé, c'est super mal fait leur zone de paramétrage ...

Ton problème viens surement du faite que tu as un routeur.

Si tu veut, j'ai fais un tutoriel entier pour créer un serveur FTP avec filezilla.
Je le préfère très largement à IIS, parce qu'il est opensource, et le panneau de réglage est très claire.

A+, Pierre.
22 Août 2008 14:05:54

manb a dit :
Hello,

J'ai configuré un serveur ftp avec IIS6 sur un windows 2003. Depuis un autre ordi, je peux m'y connecter.

Mais lorsque j'essaye un transfert de fichiers, cela ne marche pas correctement. Il me créer un fichier sur le serveur ftp qui fait 0 ko.

J'ai vérifié les droits en écriture et c'est OK.
Je passe via un firewall sur lequel j'ai bien configuré une règle pour faire du ftp sur le port 21.
Je ne me suis pas occupé du port 20, est-ce vous pensez que c la cause du problème ?


Le port 20 est un port sortant, tu n'as pas a t'en occuper. Le probleme vient que tu essaies d'acceder a ton fichier en mode passif (dans ce mode le client qui instancie la connection de transfert), il faut donc que tu desactives ce mode :

Dans internet explorer
1 : Outils -> Option Internet -> Avancé
2 : Decochez l'option Navigation -> Utiliser le mode ftp passif
3 : Ok puis redemarrer IE.
4 : C est tout !
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS