Votre question

connexion wifi et linux

Tags :
  • Connexion wifi
  • Internet
Dernière réponse : dans Internet
24 Mai 2005 14:06:11


boujour tout le monde!

je souhaite permettre à mon pc linux ( mandrake 10.1) de se

connecter à internet. je suis en réseau sans fil .je n'ai pas accès au

routeur je suis simplement un poste client.

je possède un carte wifi netgear ma311 pc1 chipset prism 2.5.

je pensais avoir tout bien configurer mais en effectuant un ping sur l'ip de ma passerelle cela ne fonctionne pas.

voici le résultat de cette manipulation:


[root@localhost djim]# ping 192.168.1.1

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

From 192.168.1.xx icmp_seq=1 Destination Host Unreachable

From 192.168.1.xx icmp_seq=2 Destination Host Unreachable

From 192.168.1.xx icmp_seq=3 Destination Host Unreachable

From 192.168.1.xx icmp_seq=5 Destination Host Unreachable

From 192.168.1.xx icmp_seq=6 Destination Host Unreachable


--- 192.168.1.1 ping statistics ---
9 packets transmitted, 0 received, +5 errors, 100% packet loss, time 7999ms
,

pipe 3


[root@localhost djim]# /sbin/route


Table de routage IP du noyau

Destination Passerelle Genmask Indic Metric Ref Use Iface

192.168.1.0 * 255.255.255.0 U 0 0 0 eth0

127.0.0.0 * 255.0.0.0 U 0 0 0 lo

default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0


[root@localhost djim]# iwconfig

lo no wireless extensions.



eth0 IEEE 802.11-DS ESSID:"F@st2ef20e_Etang-Chaveau" Nickname:"localhost"
Mode:Managed

Frequency:2.462GHz Access Point: 44:44:44:44:44:44
Bit Rate:2Mb/s Tx-Power=15 dBm Sensitivity:1/3


Retry min limit:8 RTS thr:o ff Fragment thr:o ff
Encryption key:0147-2583-69 Security mode:o pen


Power Management:o ff
Link Quality:0/92 Signal level:-68 dBm Noise level:-122 dBm
Rx

invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed

beacon:0


eth1 no wireless extensions.


sit0 no wireless extensions.


[root@localhost djim]# ifconfig


eth0

Lien encap:Ethernet HWaddr 00:09:5B:91:55:F4
inet adr:192.168.1.xx Bcast:192.168.1.255

Masque:255.255.255.0
adr inet6: fe80::209:5bff:fe91:55f4/64 Scope:Lien
UP BROADCAST RUNNING

MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:313 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000

RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interruption:17 Adresse de base:0xc000

Mémoire:f8000000-f8000fff

eth1 Lien encap:Ethernet HWaddr 00:07:E9:55:17:11

adr inet6: fe80::207:e9ff:fe55:1711/64 Scope:Lien

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:11 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 lg file transmission:1000

RX bytes:0 (0.0 b) TX bytes:2430 (2.3 Kb)




lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128

Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1


si vous avez une idée d'où peux venir le probleme merci pour votre aide!!

PS: j'ai évidement effectuer des recherches sur l'ami google avant de venir ici.

Autres pages sur : connexion wifi linux

24 Mai 2005 14:15:46

c'est surprenant, d'après ton ifconfig, ta carte wifi est connectée (elle a une adresse réseau dans le même domaine que le routeur) et il sait qu'il doit passer par le routeur :?

fais voir (en root)
ifdown eth0
ifup eth0
(ça permet de relancer la connexion ; j'y crois pas trop mais bon...)
24 Mai 2005 15:23:34

j'ai effectué ce que tu m'a dis

voici le résultat:

[root@localhost djim]# ifdown eth0

[root@localhost djim]# ifup eth0

Error for wireless request "Set Mode" (8B06) :
SET failed on device eth0 ; Invalid argument.


l'icone de réseau que j'ai dans la barre de tache en bas a droite m'indique que la connexion ethernet est établie. Or qu'en je clik sur surveillance réseau cela m'indique que je ne suis pas connecté. je clique sur connexion. cela ce connecte quelque seconde apparament puis sa revient en non connecter.
30 Janvier 2006 07:14:43

Bonjour,
Je suis un new sur Linux et j'ai le même problème avec mandriva 2006 une carte à base de chipset rt2500 (belkin).
Pas de prob pour la carte. Reconnue et connectée au réseau (routeur). Mais je garde la connexion internet quelques secondes et puis rien (après qq pages visitées). Je retourne dans config réseau et OK et ça remarche. Please, Help me car ça m'énerve.
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS