Votre question

partage connection internet xp->linux

Tags :
  • linux
  • Internet
Dernière réponse : dans Internet
14 Octobre 2004 19:03:28

Salut à tous
Alors voila mon probleme:
j'ai mon pc en xp pro qui à une connection adsl
j'ai un portable en SuSE9.1
je voudrais partager la connection internet, mais la je craque je n'y arrive pas

Autres pages sur : partage connection internet linux

14 Octobre 2004 20:25:48

L'ethernet a pas besoin de driver!!

Aller @++ ;-)
15 Octobre 2004 12:51:15

merci c'est gentil, je le savais quand même

mais ca ne m'aide pas plus
Contenus similaires
15 Octobre 2004 13:20:18

Slt,

Il te faudrait ptet 2 interfaces réseaux sur ton xp et configurer le xp pour qu'il serve de passerelle à la suze.

Sinon utilisez un switch.

Personnellement, je l'ai réalisé mais dans le sens Linux -> Windows, et non Windows-> Linux.

Je ne suis pas sur que tu puisses utiliser les outils tout près qui permette le partage de connexion de windows, car je crois que cela fonctionne que entre windows (à confirmer).

Je ne sais pas si il existe un équivalent de iptables pour windows.

Bref, je ne t'ai pas trop aider dsl ...

15 Octobre 2004 13:28:21

Pour sa, active le partage de connexion sur ton pc sous XP Pro, et sur ton ordi sous Suse, regle les proprietés de ta connexion Ethernet pour qu'il acquiere son IP etc via DHCP ;-) Et normalement c'est bon.

Sinon si ca ne marche pas, regle manuellement :

IP : 192.168.0.xxx
Masque de sous reseaux : 255.255.255.0
Passerelle : 192.168.0.1

Serveur DNS : 192.168.0.1

Et la c'est obliger de marcher ou alors c'est l'ordinateur sous Windows XP Pro qui déconne :-D

18 Octobre 2004 13:38:28

je vais essayé
mais le 192.168.0.1 c'est l'adresse de mon windows ou une adresse comme ca??
car en DNS j'avais mis les adresses DNS de wanadoo (qui est evidement mon FAI)
18 Octobre 2004 13:42:00

que tu dois donner a ton windows
18 Octobre 2004 13:45:20

Citation :

codex a écrit :
que tu dois donner a ton windows

Merci mec :) 

Tu disposes d'un switch ou l'un des deux ordi fait office de passerelle?
18 Octobre 2004 13:47:14

perso oui :D 

mais Jerome_ITII je sias pas
demande lui :D 
18 Octobre 2004 13:47:57

Citation :

codex a écrit :
perso oui :D 

mais Jerome_ITII je sias pas
demande lui :D 

Ca tombe bien c'est a lui que je parlais :) 
18 Octobre 2004 22:08:06

non non je n'ai pas de switch, je suis juste en câble croisé.
et j'ai pas envie d'acheter un modem routeur pour çà. donc voila
sinon l'adresse DNS sur le SuSE (192.168.0.1) doit être celui de mon XP c'est bien çà?
18 Octobre 2004 22:23:06

oui. Enfin tu n'es pas obligé, tu peux aussi utiliser celui de wanadoo (ton PC XP fera le NAT qui va bien et te forwardera les requetes DNS).
Mais bon c'est moins pro ;-)
21 Octobre 2004 12:59:15

j'en ai marre, j'ai tout bien fait comme vous dites, mais rien à faire
sur mon xp je fais un ping : pas de problème il voit très bien mon portable
sur mon SuSE je fais un ping : il ne vois rien, alors il doit y avoir quelquechose à faire sur le SuSE mais je ne sais pas quoi
21 Octobre 2004 13:17:59

Bon en fait la solution est simple c'est norton firewall qui me fait chier
quand je le desactive SuSE voit bien mon XP
mais j'ai beau paramètrer partout dans norton l'adresse de mon linux, il veut pas le laisser passer
donc bon, si vous avez une idée
21 Octobre 2004 13:19:10

Si le ping marche dans le sens XP -> Suze mais pas dans l'autre c'est que tu dois avoir un firewall sur ton XP qui bloque les paquets ICMP ...

Ce qui peut arriver aussi c'est que ta config IP soit foireuse et que lorsque depuis ton XP tu crois pinger ton Suze et bien en fait tu te ping toi meme.

Sinon tu as donne quoi comme adresse a ton Suze ? un truc du genre 192.168.0.2 ? Et la carte reseau de ton XP un truc du genre 192.168.0.1 ?

Too late, tu as poste pendant que j'ecrivais ma reponse, oublies donc mes questions ...

Sinon pour Norton, je sais pas, moi j'ai la config inverse, j'utilise un Linux pour faire router et firewall :-D
21 Octobre 2004 13:55:19

et oui je suis rapide héhéhé, enfin ca dépends des fois.
mais la ce norton firewall 2004 m'énerve vraiment, j'ai paramètrer partout où il était possible l'adresse du suse pour qu'il le laisse passer, j'ai même créer des règles de communication, mais il ne veut psa de mon SuSE!!!!
21 Octobre 2004 14:19:24

Dans les filtres specifiques que tu souhaites ajouter pour autoriser l'autre PC a faire un ping (ICMP request) il faut que tu fasses attention a les appliquer sur l'interface ethernet qui est branchee sur ton PC Suze (pas l'interface ADSL).

Je connais pas du tout Norton firewall, mais vu que la configuration que tu souhaites mettre en place (un PC XP qui fait du partage de connection internet avec un reseau local) est ultra classique, je ne pense pas qu'il faille chercher des trucs compliques.

Sur Kerios (que je connais un peu) il suffit de dire que le PC suze est sur ton reseau local et voila. Avec norton ca doit bien etre du meme genre (enfin bon Symantec, on peut s'
attendre a tout :-D ).
21 Octobre 2004 15:01:25

c'est sur qu'il faut s'attendre à tout, mais le truc c'est qu'il ne font pas de distinction entre réseau local et adsl
et c'est la le problème
21 Octobre 2004 15:25:28

autant pour moi il font une différence
mais pas ADSL - carte réseau, c'est du style internet-pc avec des options qui se melangent un peu
pour l'instant j'ai désactiver la sécurité du réseau (pas d'internet) mais c'est elle qui gère des chevaux de troie, c'est dommage quand même, vive symantec!!!!



Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS