Votre question

medieval 2 total war: erreur inconnue en pleine bataille

Tags :
  • MMORPG
  • Restauration système
  • Jeux
Dernière réponse : dans Jeux et consoles
1 Septembre 2008 22:30:29

bonjour


tout est résumé là dedans :

http://www.hebergementimages.com/images/1220288243_tota...

cela s'est produit lors d'une grosse bataille nocturne contre les timurides.... pensez vous que mon problème de patches (cf. topic sur les tours à balistes lançant des boulets de canon) est lié à cela ?

Autres pages sur : medieval total war erreur inconnue pleine bataille

1 Septembre 2008 22:57:00

Ca s'est reproduit ?
2 Septembre 2008 00:23:02

ben comme j'ai sauvegardé juste avant cette bataille je suis obligé de faire cette dernière... et à chaque fois que je reprend ma partie et que je recommence la bataille concernée, pouf! de nouveau ce bug !
Contenus similaires
2 Septembre 2008 01:31:53

Il est sensé être compatible Vista ce jeu ?
2 Septembre 2008 01:39:31

oui oui il a toujours très bien fonctionné et je n'ai jamais entendu parler de problème de compatibilité
2 Septembre 2008 13:21:27

aïe aïe aïe ! ça me le fait à chaque bataille finallement ! j'ai pourtant refait une réinstallation complète !!!
2 Septembre 2008 13:44:13

T'as mis la dernière mise à jour ? Et tous tes drivers sont à jour aussi ?
2 Septembre 2008 13:49:24

non justement je n'ai pas mis à jour car l'install du patch 1.2 a bugué (cf. les derniers posts de ce forum: http://www.jeuxvideo.com/forums/1-11471-142637-1-0-1-0-... )

j'ai alors fait une restauration système puis une réinstall complète du jeu qui buguait encore

c'est depuis ce jour que j'ai ce bug

quant aux drivers oui ils sont à jours en tout cas avec ceux là je n'ai JAMAIS eu de soucis et surtout pas avec medievalII total war....
sauf que récemment pour ma CG j'ai pris un laptopvideo2go... j'avais le plus récent mais là j'ai pris un certifié WHQL au cas où le problème viendrait de là (ce qui n'est, après vérification, pas le cas !)
2 Septembre 2008 14:00:09

Sinon c'est un jeu original ou cracké, par que les cracks posent très souvent ce genre de problème...
2 Septembre 2008 14:01:57

cracké ? ben oui j'ai un crack je trove ça plus simple de pas avoir à mettre le CD à chaque fois mais je l'ai presque depuis le début !

et encore une fois ça n'avait jamais fait ça avant
2 Septembre 2008 14:06:48

Ben voilà t'as trouvé un des possibles problèmes. Joue avec le CD et ça devrait au moins éliminer une source d'erreur. La majorité des cracks sont foireux et posent de graves problèmes de stabilité.
2 Septembre 2008 14:16:09

comme ça, tout à coup, paf ? bon ok j'essaye
2 Septembre 2008 14:23:20

ben non c'est pas ça non plus, ça bug aussi avec le cd (mais le crack est toujours dans le dossier du jeu dans C:/ par contre)
2 Septembre 2008 14:30:28

Ben faut virer le crack aussi, et restaurer l'original. Et ça explique aussi pour la mise à jour foire, vu qu'elle peut pas mettre à jour un crack. Jouer avec un jeu pirate n'apporte que des emmerdes...
2 Septembre 2008 14:30:54

Bah retire le !!^^ On te demande de le supprimer !

edit: grilled par le néléphant ^^
2 Septembre 2008 14:37:54

c'est pas un jeu pirate

il me semblait ue les cracks sont autorisés si le jeu n'est pas piraté non ?

bon sinon je vais en effet essayer de réinstaller de nouveau et là ok pas de crack
2 Septembre 2008 15:19:45

Acheté ou pas, un crack reste illégal, et de toute façon ça fout toujours autant la merde.
2 Septembre 2008 17:41:41

ok si tu le dis, désolé j'étais pas au courant
2 Septembre 2008 20:14:33

ben non ça marche toujours pas :( 

j'ai essayé autre chose: j'ai encore fait une restauration système à une date ENCORE plus ancienne, puis fait une réinstallation, rien à faire, ça continue...
2 Septembre 2008 20:49:11

SUpprime le entièrement c'est a dire supprime le puis passe un coup de ccleaner pour netoyer le registre ! Met a jour tes drivers Video puis dis si tu as fait des mises a jour recemment !
2 Septembre 2008 22:37:10

déjà essayé, sans succès...

edit: ah non j'ai pas encore nettoyé la BDR avec CCleaner, juste un nettoyage classique en fait.... bon je vais essayer mais un gros bug que j'avais eu avant était dû à une erreur de BDR elle même dûe à un logiciel de "nettoyage" comme CCleaner... alors méfiance !

mon driver vidéo est un laptopvideo2go, j'ai pris le plus récent (parmis les certifiés WHQL... j'en avais pris un non certifié et plus récent avant mais je croyais que le souci venait de là...)

et j'ai fait toutes les mises à jour vista possibles...

quant aux patches du jeu: http://www.infos-du-net.com/forum/264894-13-medieval-to...
2 Septembre 2008 23:28:59

ben non... ça non plus ça donne rien...

euh... on s'est bien compris ? ce que j'ai fait, c'est désinstaller, supprimer le dossier de jeu, passer un coup de CCleaner dans la BDR, puis réinstallé le jeu... c'était ça que je devais faire non ?
3 Septembre 2008 17:04:12

Bah la je suis a sec d'idées je vais y réfléchir mais je ne pense plus avoir de solution a ton problème !

SI tu la desinstalé, reinstalle le et la essaye la MAJ 1.2 !
3 Septembre 2008 17:27:02

de nouveau ?

mais c'est ça qui a provoqué le bug et aussitôt que je remet le patch 1.2 ça recommence à foirer... ( http://www.infos-du-net.com/forum/264894-13-medieval-to... ) j'ai aussi essayé d'installer le 1.1, le seul que j'avais réussi à installer complètement, puis de désinstaller ensuite le jeu et de le réinstaller après avoir supprimé le dossier de jeu et passé un coup de CCleaner dans la BDR...
3 Septembre 2008 17:31:41

SI j'ai bien compris c'est en installant le 1.2 que le jeu a planté ! OK et dans la BDR tu fait une recherche de tout ce qui concerne Medieval Total war 2 (par exemple tu recherche le nom de l'éditeur) et tu vire mais fait gaffe a ne pas virer nimporte koi et en plus c'est pas la solution donc je te le dis mais c'est toi qui le sens !
3 Septembre 2008 17:36:59

ben en fait j'ai déjà essayé ça aussi

en désinstallant le jeu il ne reste plus RIEN en lien avec les mots clés "Medieval II"....
et puis, de toute manière, c'est le 1.1 qui a tout fait planté, puisque même l'INSTALLATION du 1.2 n'a pas marchée...

enfin, les restaurations systèmes et nettoyage de BDR aurait déjà dû virer tout ce qu'il fallait virer... je vois vraiment pas ce que je pourrais faire d'autre, d'autant que j'ai déjà essayé de virer les bugs liés au patch comme je l'expliquait ici: http://www.infos-du-net.com/forum/264894-13-medieval-to...
3 Septembre 2008 18:23:23

Et le nom de l'éditeur du jeu????
3 Septembre 2008 18:57:10

c'est SEGA

quant au développeur c'est The Creative Assembly
3 Septembre 2008 20:50:24

Bah recherche Sega et The creative assembly dans ta base de registre après on pourra dire qu'on a tout essayé !
3 Septembre 2008 22:18:41

ok je vais essayer
3 Septembre 2008 23:53:25

bon je préfère te citer ce que je trouve avant de faire quoi que ce soit, au cas où tu verrais une raison particulière à ne rien faire:

dans HKEY_LOCAL_MACHINE\SOFTWARE\SEGA

il y a une clé REG_SZ nommée "(par défaut) dont la valeur n'est pas définie

idem dans HKEY_LOCAL_MACHINE\SOFTWARE\The Creative Assembly

sauf que là, le dossier concerné contient aussi un autre dossier sur le jeu... Rome-Total War... et oui, je les collectionne... (ce sont de bons jeux)


tu crois que je devrais virer le dossier HKEY_LOCAL_MACHINE\SOFTWARE\SEGA de la BDR ?


EDIT: aaah flute en fait il y a un dossier Medieval II Total War dans le dossier HKEY_LOCAL_MACHINE\SOFTWARE\SEGA .... la fonction recherche de la BDR ne me l'avait pas trouvé... bizarre ! alors, je vire ? bon allez j'essaye, j'ai fait une sauvegarde de la BDR, dis moi si j'ai eu tort... merci pour ton aide, et si t'as d'autres idées, elles sont les bienvenues

merci aussi au "néléphant"
4 Septembre 2008 13:37:54

^^ ok si tu as fait une sauvegarde tu peux essayer mais je te disait ca en pensant que tu avais qu'un seul jeu de chez eux ! donc vire juste ce qui concerne Medieval Total WAR II et si ca va pas restaure ta sauvegarde !
4 Septembre 2008 20:40:44

aaaah ça n'a rien changé, le bug est encore là !!! mais enfin il y a bien une origine à ce bug bon sang, ça peut pas être dû à RIEN ???!

edit: aha, j'ai trouvé comment faire mieux fonctionner la recherche sur regedit.exe ! et j'ai ainsi trouvé d'autres clés liées au jeu !!!

bon, j'essaye ça aussi !
4 Septembre 2008 22:27:35

bon ça n'a pas marché mais je n'avais pas tout viré à 100 %

là j'ai viré tout ce qui était en lien (par le nom) avec les mots clés "medieval" "sega" "the creative assembly".... en décochant la fonction "mot entier seulement" bien sûr
juste avant j'ai désinstallé totalement rome total war... puis repassé un coup de CCleaner

bon là ça réinstalle... c'est ma dernière chance je crois.... et si ça fait rien là non plus, que devrais-je faire ?

autant je me passerai du jeu mais je n'aime pas laisser un bug sur un PC sans le virer....


edit: toujours rien, après 3 tentatives...

bon parmi les fichiers que je trouve lors de ma recherche, même après désinstallation, suppression du jeu et des clés registres liés au jeu, à The Creative Assembly et à SEGA, je trouve des éléments que je ne connais pas:

nvapps.xml qui se trouve à l'emplacement :
c:\Users\[MON NOM]\{d83c9f24-ba7e-448e-8b0a-2e2d75c64b69}

et en fait c'est tout... sauf que ce fichier a LE MÊME NOM qu'una autre fichier situé dans le dossier d'installation de mon pilote graphique laptopvideo2go

sinon, parmis les clés registres, les seules qui restent concernant Total war sont A PRIORI des clés de ROME TOTAL WAR

alors, qu'en pensez vous ? qu'est ce qui peut ENCORE déclencher ce bug ?

P.S:au fait, j'ai pas besoin de restaurer ma sauvegarde de BDR tout de suite ? je le fais que si j'ai un souci dans l'immédiat non ?
5 Septembre 2008 12:10:27

Oui tu n'est pas obligé de restaurer ta BDR vu que tout marche encore ! La je suis a sec d'idées !!
5 Septembre 2008 12:16:25

Ah j'oubliais. La mise à jour modifie sûrement le fichier exe du jeu, mais comme il est cracké, la mise à jour ne se fait pas, et tu te trimballe avec l'ancien exe.
Donc est-ce que t'as à un moment installé le jeu, la mise à jour, et joué direct avec ?
5 Septembre 2008 15:48:18

oui je pense avoir essayé ça sauf que d'après mon souvenir le jeu se lançait pas dans ces conditions...

et puis, quand je réinstalle le jeu, ainsi que le crack éventuellement... il est neuf, il ne peut donc pas être touché par la mise à jour, non ?

sinon, vous en pensez quoi du "nvapps.xml" dont je parlais avant ?

edit: bon je sais que c'est pas bien mais après ce que tu as dit j'ai essayé de mettre un tout nouveau crack dans le dossier du jeu....
ben ça bug toujours....

edit2: bon il n'y a vraiment rien à faire ! j'ai essayé de continuer ma partie et la bataille suivante a bugué aussi... après un temps de jeu plus long cependant

un autre bug que je n'avais pas encore signalé: le mode "vue limité" du jeu ne fonctionne pas...
5 Septembre 2008 21:02:42

La mise à jour met l'exécutable à jour. Si t'as le crack, ça marche pas, et la mise à jour foire. Faut faire la mise à jour avec l'original, et ne surtout pas le remplacer par le crack derrière.
5 Septembre 2008 21:38:04

ça peut être ça aussi... c'est même carrément ça en fait, mais ça semblait évident

sauf que mon bug est visiblement dû à autre chose... je crois avoir trouvé l'origine du problème: les éléphants des timurides dans ma bataille... il paraît que ce sont eux qui provoquent le bug, rien à voir avec le patch en fait !

comme chacune des batailles que j'essayais de faire dans ma campagne étaient contre les timurides et leurs éléphants, j'ai cru que le bug se produisait lors de toutes les batailles de campagne... en fait le problème est limité à un certain type de batailles...

et oui, la solution était toute simple... j'ai peut être moyen de le réparer définitivement cette fois ci
je vous donnerai des nouvelles
6 Septembre 2008 19:18:27

bon même si c'est un peu HS, je viens de découvrir qu'un autre jeu (sans aucun rapport avec total war) a complètement disparu de mon PC... comme s'il avait été désinstallé... je l'ai réinstallé et retrouvé mais sauvegardes mais bon...

aurais-je des trous de mémoire ou un bug lié à mon tripatouillage de la BDR ?
6 Septembre 2008 20:42:48

Je pense que tu as un trou de mémoire car meme si tu lavait bidouillé dans la bdr il serait toujours dans program files ! donc !
18 Septembre 2008 21:17:59

fantomas33 a dit :
ça peut être ça aussi... c'est même carrément ça en fait, mais ça semblait évident

sauf que mon bug est visiblement dû à autre chose... je crois avoir trouvé l'origine du problème: les éléphants des timurides dans ma bataille... il paraît que ce sont eux qui provoquent le bug, rien à voir avec le patch en fait !

comme chacune des batailles que j'essayais de faire dans ma campagne étaient contre les timurides et leurs éléphants, j'ai cru que le bug se produisait lors de toutes les batailles de campagne... en fait le problème est limité à un certain type de batailles...

et oui, la solution était toute simple... j'ai peut être moyen de le réparer définitivement cette fois ci
je vous donnerai des nouvelles



Salut !

Moi aussi j'ai le même problème sur ce jeu !

Voilà quelque temps que je suis sur ce jeu et, effectivement, à chaque rencontre contre les timurides on a le droit à un gros bug.

Aucun moyen non plus d'éviter l'invasion timurides dans la campagne.

Tu dis avoir peut être le moyen de réparer définitivement... T'as trouvé ou pas ?

A bientôt...
18 Septembre 2008 22:40:28

oui ça y est et ce tout récemment ! ton post me fait penser qu'il est temps d'expliquer comment procéder:

le souci était bien du aux timurides et à leurs éléphants: met les patches 1.1 et 1.2 voire 1.3 et tout ira mieux !

dans mon cas, l'installation des patches de s'étaient pas faite correctement... quand j'ai compris pourquoi cela ne le faisait que chez moi (un souci de langage en fait...) j'ai pû mettre le jeu à jour et régler définitivement le souci !

si tu as besoin de renseignements très particuliers à ce sujet n'hésite pas à me contacter par MP ! pour l'installation des patches, et pour ceux qui sont dans le même cas que moi (jeu venant d'un autre pays, en allemand, en anglais;...), j'ai tous les fichiers nécessaires !
13 Juin 2009 17:58:37

salut tu peu me donner les lien pour chopper les patch stp ? si possible en francais

car j'ai me meme probleme avec les elephant
le jeux de merde xD

si quelqu'un peu m'aider merci
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS