Votre question

[Résolu] Problème de lecture de fichiers *.mkv

Tags :
  • windows media player
Dernière réponse : dans Photo et vidéo
15 Mai 2005 23:04:32

:bounce:  Salut !
J'ai des films au format .mkv que je n'arrivé pas à lire avec mon lecteur windows média. Ne trouvant pas de codecs, j'ai finalement télécharger "média player classic", mais lorsque j'ouvre un film, il me dit qu'il ne peut faire le rendu de quelques points du graphe, que je n'ai peut étre pas les codecs ou filtres neccessaire..." :-o
Je fais "ok" et j'ai le son du film mais pas d'image !;-)
J'ai télécharger plusieurs codecs comme "matroska_pack_full, _MPeg4..." et le "pack lazy man's", mais toujours pareil !
J'espère que pour vous se n'ai pas trop compliqué parske pour moi, ça le devient "grave".
Si vous pouvez m'aider :gg:

Autres pages sur : resolu probleme lecture fichiers mkv

15 Mai 2005 23:08:10


Desintalles tous tes codecs et reinstalles le Matroska pack,
ces packs de codecs, y servent qu'a foutrent la m...,
vaut mieux en installer qu'un seul a la fois.
16 Mai 2005 10:30:51

va voir ici et je pense que tu auras ce que tu veux. tien nous au courant...
Contenus similaires
16 Mai 2005 10:32:24

moi j'ai juste installé le K-LITE CODEC PACK FULL, je le trouve cool, jamais eu de pb, meme avec les .mkv
16 Mai 2005 11:38:11

VLC bouffe pas mal le CPU, il vaut mieux installer les codec si tu a un pc pas trop puissant pour eviter d'avoir un décalage du son et de l'image voire des lags.

si tu as un bon pc VLC est pas mal.
16 Mai 2005 11:41:32

:bounce: 
J'ai dézinstallé tous ces codecs de m*** et réinstallé unikement le "Matroska pack full v1.0.3",
mais c'est toujours pareils !!! :-o
16 Mai 2005 11:45:52

Citation :

XoReSs a écrit :
moi j'ai juste installé le K-LITE CODEC PACK FULL, je le trouve cool, jamais eu de pb, meme avec les .mkv


installe ce codec il marche trés bien, je croi qu'il est m^me disponible en telechargement sur ce site fait une recherche.
16 Mai 2005 12:01:27

:bounce:  En fait, j'ai sept pack de codecs différents, dont quatre Matroska et trois Mkvinst.
Je les ai tous installé un par un, en dézinstallant l'ancien avant d'installé le nouveau :hum:  , vous suivez toujours ?
Mais ça marche toujours pas !!!
Comment faire ?
16 Mai 2005 16:30:59

J'ai essayé avek le "K-lite codec pack fUll", mais toujours rien ! :evil: 
En plus avek ce "pack", maintenant j'ai le "Média player classic" ki c'est mit en anglais.
Franchement, je commence à eN avoir plein lé cou***es, ou alors, c'est moi ki comprend plUs rien !
Aidez mOi, je vais finir par craquer !!! :lool:
16 Mai 2005 16:33:42

tu as essayé vlc ?
16 Mai 2005 16:38:11

lu*
Normalement sa marche bien avec BSplayer
16 Mai 2005 16:50:40

:p lus1: pour bs player il fonctionne bien avec les mkv...
16 Mai 2005 17:09:47

:bounce: 
Une choze qui est bien avec ce pack de codec c'est que j'avais des films au format .avi qui ne passé pas alors que maintenant ça fonctionne.
Mais pour les .mkv, ça ne marche toujours pas !
Il me dit toujours qu'il ne peut pas faire le rendu de quelques points du graphe, que je n'ai peut étre pas les codecs ou filtres neccessaire...
Pour ce qui est de "vlc", j'ai lu qu'il fallait un ordi assez puissant ?!? Le mien ne l'est pas trop, je crois.
J'espère qu'on va réussir à régler ce problème...
16 Mai 2005 17:12:16

:bounce: 
Mais j'ai quand méme le son des .mkv !!!
Y me manque plus que l'image, put***.
16 Mai 2005 17:18:42

J'ai un atlhon 1.8GHz et 512 de ram VLC marche nickel chez moi. Bon courage
16 Mai 2005 17:39:46

J'ai un Pintium IIIE, 1000 mhz avec 256 de Ram.
16 Mai 2005 17:49:52

alors essaye ca devrait aller je pense et de toute manière ca coute rien de tenter
16 Mai 2005 19:59:46

faut eviter de mettre 36 pack de codec sinon ça fait tout foirer.

desinstalle tout les codec et installe que le k-lite mega codec pack et ça marchera.
16 Mai 2005 20:56:01

:bounce: 
Je l'ai fais SURITON, mais ça ne marche toujours pas !
Et pour le "vlc", je l'ai téléchargé, installé mais, mes .mkv ne fonctionne toujours pas !!! ;-)
J'ai le son mais pas l'image. :crying:
16 Mai 2005 22:37:17


t'as peut etre une merde avec ton ffdshow,
essaye de le changer, des fois on sait jamais,
j'ai eu plein de merde a cause de lui.
17 Mai 2005 18:37:24

:bounce: 
EscUsez moi, je suis novice !
C'est quoi le "ffdshow" ? :-o
Comment fait on pour le changer ?
Par ce que, franchement, j'aimerai bien les lire ces salO de .mkv !
Merci de vos réponses.
17 Mai 2005 19:30:50

:bounce: 
C'est bOn, je sais c'est quoi "ffdshow" !
Un filtre apparament, j'ai fais une recherche sUr mon ordi et il n'y à rien d'installé à ce nom !

Mes .mkv ne fonctionne toujours pas ! :-(
17 Mai 2005 21:33:23

çA y est, ça fonctionne !!! :banane:
En fait, j'ai tout dézinstallé, [ça m'avé franchement gavé !], je suis allé télécharger Real Alternative 1.37 [sUr Ratatium.com] que j'ai installé .
çA ne marché toujours pas ! :-(
J'ai installé K-lite Code Pack, pour voir, et là ............. miracle !!!
çA marcHe !!! :-D
mErci pour vos répOnses et vOs conseils qui mOn bOcOu aidé !
[méme si pour Real, j'me sUi un pEu débrouillé seUl]
Mais MERCI quand méme !!!
3 Novembre 2006 07:51:25

Bonjour,

Alors moi je rencontre le même problème que notre ami fase pour les fichiers .MKV
J'ai le son, mais pas l'image.

J'ai dû chercher et faire un nombre incroyable de manip pendant plusieurs heures, et cette fois je craque.

Donc, seul le son est lu sur des lecteurs type Win Media Player, Win Media Classic, VLC.

J'ai essayé une montagne de codecs: Pack Matroska, SLD, FFdshow, K-Lite et j'en passe des meilleurs
J'ai téléchargé des fichiers en .ax manuellement pour les exécuter dans la base de registre, bref tout ce qui était possible de faire, mais sans succès.
J'ai bien évidemment désinstallé tout les codecs pour les réinstaller 1 un 1 et tester entre chaque avec plusieurs lecteurs multimédia, mais le problème reste inchangé.

J'ai essayé de télécharger BS Player, qui nécessite l'installation d'un logiciel de pub requierant évidemment de fermer Firefox pour pouvoir ouvrir le bon vieux Internet Explorer (pas louche déja). Immédiatement AVG a détecté un trojan, donc j'ai zappé BS Player, d'autant que le programme de pub était déjà installé mais qu'il ne voulait pas se lancer pour autant.

Gspot et autre détecteurs de codecs ne m'en apprennent pas davantage puisqu'il ne prennent pas en charge les fichiers .MKV

Je précise que ces fichiers ne sont pas innexploitables (les commentaires qui lui ont été attribués étaient positifs, j'en déduis que le fichier fonctionne chez certaines personnes)

Je suis Win XP Pro service Pack 2. J'ai un P4 de 3,2 GHZ, 1go de ram, bref tout ce qu'il y a de plus courant.

Alors dans une dernièrement manip ou j'ai pour la 50ème fois désinstallé tous mes codecs (donc 50 reboots). J'ai retéléchargé K-Lite Codec, et j'ai eu la bonne surprise d'avoir une 30aine d'erreurs, dont celle-ci par exemple:




Et enfin, si ça peut vous aider, lorsque je lance le fichier sous média classic, j'ai ce rapport d'erreurs:

C:\Documents and Settings\Véhémence\Bureau\OZ S4-Ep.01 - A Cock and Balls Story VOstFR.mkv::Video

Media Type 0:
--------------------------
Video: RealVideo 4 380x288 25.00fps

AM_MEDIA_TYPE:
majortype: MEDIATYPE_Video {73646976-0000-0010-8000-00AA00389B71}
subtype: Unknown GUID Name {30345652-0000-0010-8000-00AA00389B71}
formattype: FORMAT_VideoInfo2 {F72A76A0-EB0A-11D0-ACE4-0000C0CC16BA}
bFixedSizeSamples: 0
bTemporalCompression: 0
lSampleSize: 1
cbFormat: 146

VIDEOINFOHEADER:
rcSource: (0,0)-(0,0)
rcTarget: (0,0)-(0,0)
dwBitRate: 0
dwBitErrorRate: 0
AvgTimePerFrame: 400000

VIDEOINFOHEADER2:
dwInterlaceFlags: 0x00000000
dwCopyProtectFlags: 0x00000000
dwPictAspectRatioX: 380
dwPictAspectRatioY: 288
dwControlFlags: 0x00000000
dwReserved2: 0x00000000

BITMAPINFOHEADER:
biSize: 40
biWidth: 380
biHeight: 288
biPlanes: 0
biBitCount: 0
biCompression: RV40
biSizeImage: 0
biXPelsPerMeter: 0
biYPelsPerMeter: 0
biClrUsed: 0
biClrImportant: 0

pbFormat:
0000: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
0020: 00 00 00 00 00 00 00 00 80 1a 06 00 00 00 00 00 ........€.......
0030: 00 00 00 00 00 00 00 00 7c 01 00 00 20 01 00 00 ........|... ...
0040: 00 00 00 00 00 00 00 00 28 00 00 00 7c 01 00 00 ........(...|...
0050: 20 01 00 00 00 00 00 00 52 56 34 30 00 00 00 00 .......RV40....
0060: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
0070:|00 00 00 22 56 49 44 4f 52 56 34 30 01 7c 01 20 ..."VIDORV40.|.
0080: 00 0c 00 00 00 00 00 19 00 00 00 08 10 20 40 00 ............. @.
0090: 80 00 €.


Media Type 1:
--------------------------
Video: RealVideo 4 380x288 25.00fps

AM_MEDIA_TYPE:
majortype: MEDIATYPE_Video {73646976-0000-0010-8000-00AA00389B71}
subtype: Unknown GUID Name {30345652-0000-0010-8000-00AA00389B71}
formattype: FORMAT_VideoInfo {05589F80-C356-11CE-BF01-00AA0055595A}
bFixedSizeSamples: 0
bTemporalCompression: 0
lSampleSize: 1
cbFormat: 122

VIDEOINFOHEADER:
rcSource: (0,0)-(0,0)
rcTarget: (0,0)-(0,0)
dwBitRate: 0
dwBitErrorRate: 0
AvgTimePerFrame: 400000

BITMAPINFOHEADER:
biSize: 40
biWidth: 380
biHeight: 288
biPlanes: 0
biBitCount: 0
biCompression: RV40
biSizeImage: 0
biXPelsPerMeter: 0
biYPelsPerMeter: 0
biClrUsed: 0
biClrImportant: 0

pbFormat:
0000: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
0020: 00 00 00 00 00 00 00 00 80 1a 06 00 00 00 00 00 ........€.......
0030: 28 00 00 00 7c 01 00 00 20 01 00 00 00 00 00 00 (...|... .......
0040: 52 56 34 30 00 00 00 00 00 00 00 00 00 00 00 00 RV40............
0050: 00 00 00 00 00 00 00 00|00 00 00 22 56 49 44 4f ..........."VIDO
0060: 52 56 34 30 01 7c 01 20 00 0c 00 00 00 00 00 19 RV40.|. ........
0070: 00 00 00 08 10 20 40 00 80 00 ..... @.€.



En gros là, j'abandonne, j'ai l'impression que je suis en train de bousiller mon PC pour rien dans l'histoire.
Si quelqu'un veut bien jouer les bon samaritains, je lui en serais éternellement reconnaissant.
Merci
4 Novembre 2006 08:29:02

Je le crois pas, ça marche!!!
Franchement en faisant ces manips, et en résinstallant K-Lite pour la 50ème fois, j'étais assez pessimiste sur la solution que tu me proposais. Et finalement Media Classic les lit désormais.

Tu gagnes mon respect éternel Marwan, je te remercie de t'être intéressé à mon cas, et de m'avoir enlevé cette belle épine du pied.=)
4 Novembre 2006 08:30:56

tu es le bienvenu

n oublie pas d editer le sujet de ton post en y inserant resolu
4 Novembre 2006 16:31:47

Oui enfin ça va être difficile étant donné que je ne suis pas l'auteur initial du topic =)
J'avais bien pris soin de faire une recherche avant d'exposer mon problème pour ne pas encombrer le forum de sujet similaires.

Mais je suppose qu'un modérateur pourra le faire, car la personne qui a créé le topic avait elle aussi résolu son problème.
2 Août 2007 12:20:20

Moi aussi j'ai ce problème. L'autre problème c'est que les liens de Marwann ne fontionnent plus et que je ne sais pas quoi télécharger!!! Serait-il possible de les remettre a jour ou de me dire ce qu'il faut télécharger? SVP!!
3 Mars 2009 12:05:24

marwan1001 a dit :
Bon tout d abord desinstalle tous les pack de codec que tu as installe

ensuite installe ca
http://www.free-codecs.com/download_soft.php?d=2541&s=6...

puis installe ca
http://www.free-codecs.com/download_soft.php?d=2351&s=9...

apres tu pourras les lire


Salut à vous!
Je viens de trouver ce message après une longue recherche Google. On est en 2009 et moi aussi j'ai ce problème...
Idem je suis sous XP SP2.
Les 2 liens que tu proposes ici me paraissent très intéressants mais ils ne fonctionnent plus, apparemment depuis très longtemps...
Pourrais tu juste me dire quels sont ces 2 "choses" à télécharger et dans quel ordre?

Merci d'avance.
3 Mars 2009 13:33:40

j'ai exactement le même problème je suis sous vista 32bit
j'ai installé k-lite matroska satsuki real alternative tout y est passer et impossible d'avoir l'image alors si on veut bien nous aidez svp
merci
18 Octobre 2009 11:53:37

j'utlise klitecodec pack full + real alternative + quicktime alternatine et j n'ai aucun soucis avc mes videos.
si vous avez un probleme avec un format de video: ouvrir menu demarrer > k-lite codec pack > configuration > ffdshow video decoder puis rechercher votre format de fichier a droite et la valeur du decoder. s'il est disabled changer la valeur en LIBAVCODEC cliquer sur ok et reouvrir la video (faites le pr chaq format de fichier qui ne fonctionne pas).
ca devrait fonctionner now

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS