Se connecter / S'enregistrer
Votre question

Probleme de lecture du son d'un fichier avi [résolu!]

Tags :
  • Système d'exploitation
Dernière réponse : dans Photo et vidéo
15 Septembre 2007 16:42:18

Bonjour,

Je suis nouveau sur le forum et souhaiterais vous soumettre un probleme que je rencontre depuis quelques heures :

Je voudrais modifier avec Movie Maker un fichier *.avi qui m'a été transmis. Comme MM ne parvenait pas à le lire j'ai utilisé GSpot et AVIcodec pour identifier le codec approprié (Xvid) que j'ai téléchargé. A présent, MM et Windows Media Player parviennent à lire la vidéo du fichier mais.... PAS LE SON!?

Je précise que le fichier en question est parfaitement lu par VLC (y compris le son!).

Quelqu'un peut-il m'expliquer cela et m'aider?

D'avance merci!

Autres pages sur : probleme lecture fichier avi resolu

15 Septembre 2007 17:19:01

bonjour, que veux-tu faire comme modification ?
15 Septembre 2007 17:22:09

Je veux simplement ajouter un générique de fin
Contenus similaires
15 Septembre 2007 17:39:38

Salut, WMP n'a pas autant de codecs integres que VLC, il faudrait que tu trouve le convertisse vers un format (avec les bons codecs) qui soit compatible avec WMP si tu veut le lire
15 Septembre 2007 17:39:42

Salut :)  ,

1/ Si VLC lit parfaitement ta vidéo, avec le son, c'est parce qu'il embarque ses propres codecs avec lui, et ne sert pas de ceux installés au noyau de ton système d'exploitation.
2/ => Or, tu as installé le codec XvID dans le système. Donc WMP ou WMM devraient lire aussi le son, qui est d'ailleurs tout simplement, normalement, au format mp3 sur les XviD.
> soit le fichier .avi qui t'intéresse est 'particulier', et la piste son n'est pas en mp3...
> soit il y a un "problème" (sans doute un tout petit dysfonctionement) dans la gestion de tes codecs par Windows.
- As-tu installé d'autres codecs ou packs avant XviD, dont tu parles ici ?
- peux-tu poster les caractéristiques précises de ce fichier vidéo, formats vidéo et audio ? (Export depuis Gspot ou AVIcodec) ? :) 
15 Septembre 2007 18:01:27

Merci pour vos réponses! Pour te répondre, Brutus, voici quelques infos complémentaires (que je n'ai pas mentionnées dès le début pour ne pas compliquer...)

> soit le fichier .avi qui t'intéresse est 'particulier', et la piste son n'est pas en mp3...

C'est tout a fait probable. En effet, quand j'ouvre le fichier avec VLC, j'ai le message suivant :

"Ce fichier AVI est cassé, il ne sera pas possible de se déplacer dedans correctement. Souhaitez-vous essayer de le réparer?"

Que je choisse "oui" ou "non", le film est bien lu par VLC cependant.

Concernant les codecs, je n'ai installé rien d'autre qu' XviD (en particulier, pas de packages de codecs).

Voici le rapport Gspot :

*Container*
File length correct
AVI v1.0
Interleave: 1 vid frame (40ms), preload=504
Audiofames: Aligned on interleaves
Video: 33.4 MB (83.51%)
Audio: 6.11 MB (15.27%)
AVI Overhead: 497 KB (1.21%)

*Audio*
Codec: 0x0055 MPEG-1 Layer 3
Info: 3200Hz 128 kb/s, Monophonic
Stat: Codec(s) Installed

*Video*
Codec: XVID
Name: XviD ISO MPEG-4
Stat: Codec(s) are installed

Pour AVIcodec

Fichier : 40 Mo (40 Mo), durée 0:06:39, type AVI, 1 flux audio, qualité 46 %

Vidéo : 33 Mo, 712 Kbps, 25.0 fps, res. 576*432 (4:3), XVID = XVID Mpeg-4, Supporté
Audio : 6.10 Mo, 128 Kbps, 32000 Hz, 1 canaux, 0x55 = MPEG Layer-3, Supporté

Je précise que le film fait 6 mins environs. J'espère que ces infos vous permettront de m'aider!
15 Septembre 2007 19:01:11

Re :)  ,

Hum...
Peut-être une idée... (Encore une fois, pas de procès si on arrive pas !? ;)  )

1/ Ne "bidouille" rien au niveau codecs dans ton système, n'ajoute rien, n'enlève rien, ne répare rien.

2/ Je pense que ton système va bien, et que ça vient peut-être du fichier.

2/ Je te propose réencoder ta vidéo, et de nouveau en XviD, tant qu'on y est ! Ca c'est pour m'éclaircir et pour ma gouverne. Et aussi en DivX au cas où, pour avoir plus de chances que "ça marche"...

3/ Si tu n'as pas déjà le logiciel Super dans ta config, je te suggère de le télécharger et l'installer.
http://www.clubic.com/telecharger-fiche19891-super.html
NB : aucun risque pour Windows : comme avec VLC, tous codecs & filtres demeurent dans les répertoires d'installation.

NB2 : tu pourrais encoder direct avec d'autre méthodes, mais cela me paraît moins pertinent pour le moment.

4/ Dans Super, choisis en sortie : avi + XvID, puis re-coche le fichier & fais avi + DivX...

Si l'encodage se déroule sans erreur, essaie la lecture dans WMP...

Si erreur à la conversion (possible mais pas grave !), faudra changer les paramètres ou essayer un autre soft mais on en est pas là...
hop, bon courage ;) 
15 Septembre 2007 19:35:25

Re-Salut Brutus,

Merci infiniment! J'ai installé SUPER, suivi tes indications et mon nouveau fichier .avi est lu par WMP et WMM (avec le son cette fois)! Je vais a présent me mettre à mon générique de fin.

Encore merci pour ton aide efficace :-)
15 Septembre 2007 19:53:18

Re,
Heureux pour toi :)  ,

Mais pour ma gouverne perso, peux-tu répondre à 2 petites questions s'il te plaît ?
Ca me rendrait réellement service.

Citation :
mon nouveau fichier .avi est lu par WMP et WMM (avec le son cette fois)!


Lequel ? Celui réencodé en XviD, donc de XviD... vers XviD ?

(DivX je suis quasi-sûr que ça marche.)

Ensuite, tu peux mettre [resolu] à ton post. :) 
15 Septembre 2007 19:53:24

Une dernière question relative à WMM : la musique de mon film a été enregistrée sur un fond noir (fond que je souhaite remplir avec un générique). Comment rajouter de l'image en gardant la trame sonore de départ? Toutes mes modifs s'appliquent au son ET à l'image alors que je souhaiterais dissocier les deux :-( D'avance merci!
15 Septembre 2007 20:05:33


Je répondrai à ta question... quand t'auras répondu à la minenne :D  ;)  !
15 Septembre 2007 20:19:55


Alors ? XviD vers XviD ?
Pour WMM, ce n'est pas compliqué.
15 Septembre 2007 20:37:39

Désolé pour ma réponse tardive, j'étais occupé avec mon générique du coup ;-)

Lequel ? Celui réencodé en XviD, donc de XviD... vers XviD ?

oui XviD! La première tentative fut la bonne...

Pour ma dernière question, je m'en suis finalement sorti (en glissant les séquences sur AUDIO)...

Brutus, merci! Je ne pensais pas m'en tirer à si bon compte :-)))))
15 Septembre 2007 20:59:25

Pas de quoi :) 

Merci pour l'info en retour... ;) 
Je pense... -hypothèse- que l'ennui provenait de la piste audio du fichier vidéo XviD de départ.

> Pour WMM : oui il semble bien qu'il n'y ait pas, directement, une commande affichée pour fractionner/séparer les pistes, faut glisser & dupliquer sur la 2ème piste audio.

Bonne soirée :)  ,
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS