Votre question

Exercide d'algorithme minimum

Tags :
  • Programme
  • Programmation
Dernière réponse : dans Programmation
21 Mars 2011 11:09:14

Bonjour,

j'ai un soucis pour mon algorithme.

Voici son énoncé : J'ai une expression : 2x -z(x+y) +6z

j'ai x qui varie de -7 à 20
y varie de 48 à 220
x qui varie de -100 à 100

je dois faire un algo qui me donne la valeur min de l'expression.

Je ne peux pas utiliser directement les valeurs 20-220-100.

j'ai donc fait :

  1. Algorithme Minimum
  2.  
  3. Début
  4. variable i, x, y, z minimum : entier
  5. minimum <- Le nombre le plus petit
  6.  
  7. Pour i allant de -7 à 20 répéter
  8. Lire x
  9. Si x < minimum alors
  10. minimum <- -x
  11. Fin si
  12.  
  13. Pour i allant de 48 à 220 répéter
  14. Lire y
  15. Si y < minimum alors
  16. Minimum <- -y
  17. Finsi
  18.  
  19. Pour i allant de -100 à 100 répéter
  20. Lire z
  21. Si z < minimum alors
  22. Minimum <- -z
  23.  
  24. Fin pour
  25.  
  26. Afficher : « L’expression vaut donc : », 3*x –z(x+y) + 4*z
  27.  
  28. Fin




est-ce correct ?

merci d'avance.

Autres pages sur : exercide algorithme minimum

a c 232 L Programmation
21 Mars 2011 12:27:00

Salut,

Ca me parait bizarre tout ça...
Pourquoi tu fais des "Lire x", "Lire y", "Lire z" ? Sachant que x y et z tu as leurs valeurs dans ce que tu appelles i.
Tu as 3 "Pour" d'ouverts, mais un seul de fermé.

Et puis même l'algorithme en soit n'est pas bon du tout.

Essaie d'exprimer avec des mots ce que tu veux faire d'abord.
m
0
l
a b L Programmation
21 Mars 2011 20:37:39

C'est de la programmation linéaire (minimisation de coûts). Il faut réfléchir à la méthode de cherche du point minimal.
m
0
l
28 Mars 2011 02:14:06

ça me parait bizarre c incohérent ....tu peux utiliser seulement une seule boucle en affectant à chaque valeur sa variable correspondante et après tu va utiliser des condition globale pour mettre en avant chaque valeur et son minimum //pour que le programme puisse entamer l'exécution ..... tu va commencer par (pour i allant de ......et ce n'est pas la peine de répéter (la boucle répéter) ....
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS