Votre question

Je recois pas les mails php mail

Tags :
  • Php
  • Programmation
Dernière réponse : dans Programmation
29 Janvier 2010 13:45:35

bonjour alors je suis debutant,apres moulte essais j'ai reussi a faire un formulaire avec flash mais je ne recois aucun message pouvez vous m'aider voici
mes codes as3
<
  1. var enveloppe:URLLoader = new URLLoader;
  2. var variables:URLVariables=new URLVariables();
  3. var formulaire:URLRequest=new URLRequest("<a href="http://perso.numericable.fr/" rel="nofollow" target="_blank">http://perso.numericable.fr/</a>!!!!!!!!/envoyer.php");
  4. //fonction d'envoi
  5. butt_comFormulaire.buttonMode=true;
  6. butt_comFormulaire.addEventListener(MouseEvent.CLICK,envoyerMail);
  7. function envoyerMail(event:MouseEvent){
  8. {
  9. variables.nom_formulaire = this.nom_formulaire.text;
  10. variables.prenom_formulaire = this.prenom_formulaire.text;
  11. variables.adresse_formulaire = this.adresse_formulaire.text;
  12. variables.tel_formulaire = this.tel_formulaire.text;
  13. variables.mail_formulaire = this.mail_formulaire.text;
  14. variables.sticktplate_formulaire = this.sticktplate_formulaire.text;
  15. variables.dimension_formulaire = this.dimension_formulaire.text;
  16. variables.reference_formulaire = this.reference_formulaire.text;
  17. variables.coulmatiere_formulaire = this.coulmatiere_formulaire.text;
  18. variables.commentaire_formulaire = this.commentaire_formulaire.text;
  19.  
  20. formulaire.data= variables;
  21.  
  22. enveloppe.load(formulaire);
  23.  
  24. commentaire_formulaire.text="message envoyé"
  25. }
  26.  
  27. }
>


ensuite voila mon php
  1. <?php ਍ ഀ
  2. mail(" \n xxxxxxx@voila.fr", "Mail du site <a href="http://perso.numericable.fr/xxxxxx/" rel="nofollow" target="_blank">http://perso.numericable.fr/xxxxxx/</a> ", $nom, "From:$prenom=$_POST['prenom'];
  3. $nom=$_POST['nom'];
  4. $mail=$_POST['mail'];
  5. $tel=$_POST['tel'];
  6. $adresse=$_POST['adresse'];
  7. $sticktplate=$_POST['sticktplate'];
  8. $dimension=$_POST['dimension'];
  9. $coulmatiere=$_POST['coulmatiere'];
  10. $commentaire=$_POST['commentaire'];($formulaire)"); ਍ ഀ

Si une personne charitable pour m' eclairer sachant que je suis un debutant et ne comprend pas trop
j'ai essayer de faire au plus simple.
Donc ce que je demande c'est de savoir pourquoi je ne recois pas les mails, je suppose que j'ai oublie un detail
quelqu'un pour m'aider please
ps: as3+php

Autres pages sur : recois mails php mail

a c 145 L Programmation
29 Janvier 2010 17:35:20

Il faut d'abord que tu définisses tout ce qui ira dans le mail (from, to, subject, body, headers) et qu'ensuite tu appelles la fonction mail().

J'ai fait une petite classe disponible ici qui pourra sûrement t'aider.
m
0
l
29 Janvier 2010 17:58:51

salut si tu utiliste easyphp ou wamp, il faut que tu declare ton smtp, port, et mail, dans ton php.ini.
attention si tu est chez free, tu ne peut pas utilisté le smtp free avec easyphp ou wamp
m
0
l
Contenus similaires
29 Janvier 2010 19:36:07

tout d'abort je vous remercie de m avoir repondu dans de bref delais; vous sur cool, ensuite pour repondre a ta question non je suis sur filezilla
Par contre je suis vraiment un newbees parce que je comprend guillaume.
Je travaille tous ca demain matin je vous tiens au courant sur l'avancement.
m
0
l
14 Février 2010 14:15:49

crazycat@idn a dit :
Il faut d'abord que tu définisses tout ce qui ira dans le mail (from, to, subject, body, headers) et qu'ensuite tu appelles la fonction mail().

J'ai fait une petite classe disponible ici qui pourra sûrement t'aider.



Bonjour CrazyCat,

j'ai un problème similaire, je travaille sous WAMP5 1.7.3 (PhP 5.2.4) depuis une couple d'années, tout allait bien...

Mais depuis quelques temps, et je ne vois pas ce qui a changé, je reçois le message suivant:

  1. Warning: mail() [function.mail]: Failed to connect to mailserver at "smtp.axion.ca" port 25,


Je connais cet avis, je sais qu'il s'agit d'éditer le fichier php.ini avec les coordonnées de mon fournisseur d'accès, et c'est fait depuis deux ans... c'est bien smtp.axion.ca et le port 25. J'ai aussi le «sendmail_from» correctement inscrit.

Puisque je n'ai rien changé et que la fonction mail() a toujours bien fonctionné sur cet environnement windows xp, est-ce que vous avez une petite idée d'où pourrait venir le problème ? j'avoue que je ne sais pas par où commencer...

J'ai fait un telnet smtp.axion.ca 25 et la réponse est:

  1. 220 aphrodite.videodery.qc.ca ESMTP Sendmail 8.13.8/8.13.5; Sun, 14 Feb 2010 09:05:34 -0500


Un grand merci à celui qui saura me lancer une piste...

Cordialement,

PS... merci pour la class mail
m
0
l
14 Février 2010 18:06:58

il se peut que ton FAI ai bloquer le port 25, pour évité les spam
m
0
l
14 Février 2010 18:14:11

guillaume2vo a dit :
il se peut que ton FAI ai bloquer le port 25, pour évité les spam


Merci pour ta réponse mais je viens d'essayer avec TELNET et mon message s'est bien rendu à destination, avec les mêmes coordonnées (smtp et port).

Je suis vraiment perdue...
m
0
l
15 Février 2010 00:52:58

OK j'ai trouvé ! j'ai installé il y a peu, le logiciel Ashampoo Firewall Free, j'ai pensé qu'il pouvait être la cause de mes soucis et je l'ai simplement désactivé, il semble que ce n'était pas suffisant.

La règle qui bloquait la fonction mail() est configurée à l'avance, et on ne peut pas l'éditer. J'ai dû désinstaller le firewall.

merci pour votre support

Émilie 1955
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS