Votre question

[resolu]Lien ie6 image

Tags :
  • Arrière plan
  • Programmation
Dernière réponse : dans Programmation
22 Mai 2009 11:19:32

Bonjour a tous

Voila j'ai un petit probleme j'ai fait un site qui tourne ma fois pas mal bien
Mais j'ai fait des liens sur des images et avec ie6 le linkage ne se fait pas
voila le code qui gere cela
Dans le aspx
  1. <a href="lien.aspx" id="lien"><span style="display:none;">Lien</span></a>


Dans le css
  1. #lien{display:block; width:104px; height:28px; float:left; background: url("/images/image_lien.gif") no-repeat; margin:0 2px;}


Merci d'avance

Autres pages sur : resolu lien ie6 image

22 Mai 2009 12:32:51

Le span display none ne sert à rien (a priori vu comme ca)
il ne faut pas utiliser des id mais des class quand tu as plusieur lien identique (pour utiliser les meme propriété)
le float je ne vois pas non plus à quoi il sert. Pour aligné l'image il faut utiliser background-position dans ton cas.
google est ton ami.
m
0
l
22 Mai 2009 17:19:20

En même temps tu dis explicitement de ne pas afficher l'image ... le display:none à priorité sur le display:block du css.
m
0
l
Contenus similaires
25 Mai 2009 09:30:05

pourtant il m'affiche bien les images et le probleme ne se pose qu'avec ie6
m
0
l
25 Mai 2009 10:04:51

en fait j'ai trouver le probleme viens d'ailleurs
j'avais deplacé le div du coup mais lien ne marche plus mais pourquoi ca le fait aucune idée je vais chercher dans ce sens

merci de votre aide quand meme
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS