Se connecter / S'enregistrer
Votre question

Exercice d'algorithme

Tags :
  • Programme
  • Programmation
Dernière réponse : dans Programmation
23 Janvier 2009 20:10:21

salut,j'ai un probléme dans un exercice d'algorithme:exercice qui permet de déterminer si un nobmre donné est un nombre premier,est-ce que vous pouvez me donné des sites pour avoir des exercices de boucles tant que-faire..merci d'avoir m'aider

Autres pages sur : exercice algorithme

24 Janvier 2009 07:33:51

Quel est ton problème exactement ? Les boucles, ou l'algorithme pour tester la primalité d'un nombre ?
Parce qu'une boucle il n'y a rien de plus simple.. Tu répètes tant que la condition est vraie.. Il faut bien s'assurer que la condition sera fausse un jour, sinon c'est la boucle infinie assurée..
m
0
l
24 Janvier 2009 23:42:06

salut Dr_cube,merci de me répondre,mon probléme c'est quel est la solution de cet exercice:un programme qui permet de déterminer un nombre premier,c sa,et je cherche des sites web ou je trouves des séries d'exercices sur la boucle tant que-faire...voila,merci encore une fois
m
0
l
Contenus similaires
a b L Programmation
25 Janvier 2009 18:21:24

Et tu as commencé par quoi ?
m
0
l
Anonyme
26 Février 2009 11:47:18

:bounce:  salut
m
0
l
27 Février 2009 15:08:38

Salut,

  1. nombre : Entier
  2. nbDiviseur : Entier <- 0
  3. cpt : Entier <- 0
  4.  
  5. DEBUT
  6.  
  7. nombre <- saisir()
  8.  
  9. tant que ( cpt < nombre ET nbDiviseur < 2) faire
  10. si (nombre%cpt = 0) alors
  11. nbDiviseur <- nbDiviseur + 1
  12. fin si
  13.  
  14. cpt <- cpt + 1
  15. fin tq
  16.  
  17. si (nbDiviseur = 1) alors
  18. afficher("Ce nombre est premier")
  19. sinon
  20. afficher("Ce nombre n'est pas premier")
  21. fin si
  22. FIN


Je pense que c'est bon mais j'ai fais ça à la va vite donc à vérifier.

@+
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS