Se connecter / S'enregistrer
Votre question

[RESOLU] Musique de fond en HTML

Tags :
  • Musique
  • Programmation
Dernière réponse : dans Programmation
5 Janvier 2009 21:31:44

Bonsoir à tous,

Voilà j'ai crée une page HTML que j'ai hébergé chez ifrance. J'ai pas la suite voulu y mettre une musique en fond. J'ai donc trouvé la possibilité de la faire par

<bgsound src="url_de_a_musique" loop=x>

mais ma musique étant en MP3, j'ai préféré tester de la manière suivante

<embed src="ton_fichier.mp3" autostart="true" loop="false" hidden="true"></embed>

J'ai donc mis mon fichier index.html dans un dossier (sur mon PC) et la musique dans ce même dossier. Quand j'ouvre le fichier HTML avec Firefox, tout fonctionne à merveille. Mais le problème est qu'une fois hebergé sur ifrance, même quand la musique est dans le même dossier que l'index (à savoir la racine du serveur) la page s'ouvre, mais aucune musique ne se fait entendre :( 

J'ai donc pensé m'être trompé dans le chemin de la source, que j'ai remplacé par le nom du serveur, suivit d'un " / " puis du nom de la musique ainsi que l'extension .mp3
Toujours rien :cry: 

Bref, je suis en galère, je ne trouve pas comment faire fonctionner cette satanée musique :pfff: 

Si vous avez besoin d'infos supplémentaires (captures d'écran, copié-collé de mon fichier HTML etc...) faites-moi signe ;) 

Et merci d'avance :) 


EDIT: Je viens de tester avec le lecteur Dewplayer. Il s'affiche bien dans la page, mais rien ne se laisse entendre :/  rien ne charge d'ailleurs... J'ai tenté de mettre la musique dans un dossier situé dans la racine, et j'ai indiqué /dossier/musique.mp3 dans le code, mais rien :( 

Autres pages sur : resolu musique fond html

6 Janvier 2009 02:34:29

Bonjour,

Le mieux serais que tu donne le lien de ton site ifrance, pour qu'on puisse regarder le code source et voir ou la musique se situe par rapport au fichier html.

Le problème pourrait venir aussi du nom du fichier... caractères spéciaux etc.
6 Janvier 2009 18:38:42

Voici le lien (ouais je sais c'est un truc de loveur :p  )

http://xje-taimex.ifrance.com/

La musique a comme nom 1.mp3 tout simplement. La partie du lecteur se situe dans le bas du code ;) 

EDIT: Je viens de tester avec le nom aa.mp3 au cas où le problème viendrais du fait que le nom soit un chiffre. Aucun résultat :/ 
Contenus similaires
6 Janvier 2009 19:19:26

C'est normal, j'ai trouvé le problème :D 

Il s'agit d'un serveur FTP, il fallait donc mettre en adresse ftp://xje-taimex etc... Maintenant ça fonctionne :) 

C'est en utilisant le serveur FTP d'un copain que j'ai fais le rapprochement :lol: 

Merci du coup de main ;) 
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS